TopMenu

Windows Security Manager
Guardian　V9.0

下記画像内の各部分をクリックすると、対応する機能の説明へジャンプします。


Guardianとは

Windows Security Manager Guardian はMicrosoft Windowsの下で動作するアプリケーションソフトウェアです。
Guardian はネットワーク上の任意の端末から、他の端末のWindows環境を管理、制御することができるソフトウェアです。
Guardian は大きく分けて、次の３つの機能を提供しています。

１．セキュリティー機能
Guardian はシステムレベル（OS）で、クライアントパソコンの利用環境に制限を掛けることが可能です。
企業、教育機関などにおいて、パソコンおよびネットワークを使用者の乱用から守ることが可能です。

２．リモートメンテナンス機能
Guardian にはクライアントパソコンの動作環境を強力にコントロールする機能が搭載されています。
本来 各クライアントパソコン上で行わなければならない様々な作業を、コントローラーパソコンからの指示で一括実行が可能です。
面倒な繰り返し作業からシステム管理者を開放します。

３．プレゼンテーション、コミュニケーション機能
Guardian はコントローラーおよび各クライアントパソコン間にメッセージ交換の機能を提供します。
また、コントローラーパソコンのデスクトップ画面を全クライアントパソコンに同時配信する機能を有しており、教育機関などにおいてCAI的なご利用が可能です。

クライアントパソコン上のプログラムは完全にバックグラウンドで動作するため、使用者にGuardianの存在を全く意識させることなく、クライアントの管理、制御を行うことができます。

利用対象者
  ・システム管理者
  ・教師、講師
  ・システム納入業者

ご利用に際して
※Guardianはネットワーク上のクライアントを強力にコントロールする機能を持っています。
使用方法を誤りますと、重大な損害を与える可能性があります。
またプライバシーの侵害につながる機能もありますので、管理者の方はそのことを十分に認識した上でご利用いただくことをお願い申し上げます。


機能概要

Guardian は下記の基本機能を持っています。

●基本機能

【セキュリティー関連機能】

・ウィンドウ（アプリケーション）のアクセスを制御
クライアントにおいてアクセスすることができるアプリケーションをウィンドウ単位で制限します。
また逆に、アクセスすることができないウィンドウの設定も可能です。
アクセス権の無いウィンドウに対してはマウス及びキーボードの操作が完全にプロックされます。
デスクトップ上のショートカットやボタンに対してもアクセス制御できます。
設定は各クライアントパソコンごと、あるいはユーザー別、グループ別に行う事が可能です。

・アクセス権の無いアプリケーションを自動終了
クライアントにおいてアクセス権の無いアプリケーション（ウィンドウ）が起動されたとき、自動的にそのウィンドウを消去してアプリケーションの実行を阻止することができます。

・クライアントのロック
すべてのアプリケーション（ウィンドウ）及びデスクトップに対して、瞬時にロックを掛けることができます。
クライアントはフルロックされ、一切の操作が拒絶されます。

・ネットワークパケットのブロック
設定されたIPアドレスとの通信をブロックすることができます。
ポート番号によるパケットのブロックも可能です。

・プロセスの監視、制御
プロセスの起動、終了を監視し、その操作を阻止することができます。

・各種クライアント情報の取得
  ・クライアントパソコンに関する各種情報を取得、表示します。
  ・OS種別（動作中のWindowsのバージョンとサービスパックナンバー）
  ・デスクトップサイズ
  ・搭載している総メモリ容量とフリー容量
  ・ハードディスクの総容量とフリー容量
  ・デスクトップに表示されているウィンドウの一覧
  ・起動中のプロセスの一覧
  ・登録されているサービスの一覧
  ・ハードディスクにインストールされているアプリケーションの一覧
  ・動作状態（各制御コマンドの実行結果をフィードバック）
  ・動作開始時刻
  ・ＩＰアドレス、コンピュータ名、ログオンユーザー名、MACアドレス

・クライアントのデスクトップ画面をキャプチャーして表示
任意のクライアントのデスクトップ画面をキャプチャーしてコントローラー側で表示、確認できます。
表示サイズは縮小サイズと等倍サイズがあり、ファイルに保存することができます。

・クライアントのビデオカメラの画像をキャプチャーして表示（ライブカメラ）
クライアントにビデオキャプチャーの装備がある場合、カメラ画像をキャプチャーしてコントローラー側で表示、確認できます。
キャプチャーされた画像はファイルに保存することができます。

・クライアントの詳細情報をスキャン（巡回）
選択されたクライアントのデスクトップ画面と各種情報を一定間隔で順次にスキャン（巡回）し表示します。
ビデオカメラ画像のスキャンも可能です。

・アプリケーション利用ログの記録、回収、閲覧
クライアントにて表示、利用されたすべてのウィンドウ、アプリケーション情報を、利用者名、利用日時と共にログとしてリアルタイムに記録することができます。
記録されたログは、コントローラー側で随時回収することができます。
自動的に全クライアントのログを回収することもできます。（バッチ処理）
また任意のクライアントのログを一時的に閲覧表示することができます。

・Windowsの終了を禁止
Windowsの終了操作（シャットダウン、リブート、ログオフ）を無効にします。

・スタートボタンへのアクセスをブロック
デスクトップ上のスタートボタンへのアクセスをプロックすることができます。

・タスクバーへのアクセスをブロック
デスクトップ上のタスクバーへのアクセスをプロックすることができます。

・タスクバー消去
デスクトップ上のタスクバーを消去します。
ユーザーがタスクバーを通じて行う操作を未然に防ぎます。

・ウィンドウの移動、サイズ変更の禁止
デスクトップ上のウィンドウに対して、移動したりサイズの変更ができないようにします。

・システムキーの無効化
[Ctrl + Alt + Del]や[Windows]などのシステムキー操作を無効にします。この設定により、ユーザーはシステムをシャットダウンしたり、再起動できなくなります。
（[Ctrl + Alt + Del]のキー操作だけは、WindowsNT、2000ではＯＳの仕様により無効化できません。）

・キーブロック設定
[Esc],[Tab],[Alt]や[F1～F12]など、ブロック(無効化)したいキーの個別設定が可能です。組み合わせによって、より高度なセキュリティーの確保が可能となります。

・タイマーロック機能
タイマーによる自動制御ができます。設定した時間を経過後に、［全解除］または［全ロック］の操作を自動で行うことができます。

【リモートメンテナンス関連機能】

・アプリケーションの起動、終了
クライアントにおいて、任意のアプリケーションを自動起動（遠隔起動）させることができます。
ログオンしているユーザーとは異なる権限で起動することが可能です。
また実行中の任意のアプリケーション（ウィンドウ）を強制終了させることもできます。

・クライアントのファイル操作
クライアントの任意のローカルドライブをエクスプローラーで操作できます。

・プロセスの強制終了
クライアントにおいて起動中のプロセスを強制終了させることができます。

・サービスの開始、停止
クライアントにおいて、サービスを開始したり停止したりできます。

・ウェイクアップ(Wake On LAN)、リブート、シャットダウン、ログオン、ログオフ
クライアントにおいてウェイクアップ（電源投入）、リブート、シャットダウン（電源切断）、ログオン、ログオフの操作を実行させることができます。
クライアントにおいて実行中のアプリケーションがあった場合でも強制終了させ、実行させることができます。

・レジストリのリモート操作
クライアントパソコンのレジストリをコントローラーからリモートで設定することができます。

・ファイル配信機能
同時に複数のファイルを任意のクライアントに配信することができます。

・ファイル回収機能
任意のクライアントから同時に複数のファイルを回収することができます。

・一括ファイル削除機能
クライアントのハードディスク上の任意のファイルを削除することができます。

・フォルダ共有機能
クライアントパソコンのフォルダを共有させることができます。

・時計合わせ機能
クライアントの内蔵時計をコントローラーの時刻に合わせることができます。

・ネットワーク設定機能
クライアントパソコンのネットワーク設定を行うことができます。

・リモートコントロールソフトの起動
「リモート デスクトップ」や「WinVNC」を起動し、クライアントに自動接続させることができます。
簡易型リモコン機能も内蔵しています。

・Windows Updateの支援
OSの修正プログラム(Hot Fix)の適用状況を調査したり、コントローラーから一斉に修正プログラムを配信し、適用することができます。

【プレゼンテーション、コミュニケーション関連機能】

・コントローラーのデスクトップ画面を全クライアントに配信して表示
コントローラーのデスクトップ画面をキャプチャーして全クライアントに配信し、表示させることができます。

・クライアントのデスクトップ画面をコントローラーのデスクトップ画面に入れ替え、表示（プレゼンテーションモード）
コントローラーのデスクトップ画面をキャプチャーして全クライアントに配信し、表示させることができます。
クライアントのデスクトップにフルサイズで表示されます。（タスクバーも消去されます。）
コントローラーのマウスポインターの移動がクライアントでリアルタイムに再現されます。

・任意のクライアントのデスクトップ画面を全クライアントに配信して表示
任意のクライアントのデスクトップ画面をキャプチャーして全クライアントに配信し、表示させることができます。
表示サイズはクライアントのデスクトップサイズいっぱいにリサイズされて表示されます。

・メッセージ配信機能
クライアントに対してワンラインのメッセージ文を送ることができます。
配信されたメッセージに対して返信することもできます。
クライアントから他のクライアントに対してメッセージの送信を行うこともできます。

・音声メッセージ機能
クライアントに対して音声メッセージを送ることができます。音楽データの送信も可能です。
同時に複数のクライアントに対して送信することもできます。

・ブラウザURLの配信
コントローラーのブラウザに表示されているページのURLを配信し、クライアントでも同じページを表示させることが出来ます。

【共通機能】

・コマンドライン実行機能
コントローラーの各種制御機能をコマンドラインから実行させることができます。
ＯＳ付属のスケジュール機能などと組み合わせることで、完全自動実行（無人制御）が可能となります。

・自動実行機能
Guardianをシステムの起動時に任意のアプリケーションと共に自動起動させ、制御を開始することができます。


動作環境

Guardianをインストールして使用するためには下記の条件を満たすシステム環境が必要です。

オペレーティングシステム（ＯＳ）環境

Microsoft Windows Vista Home Basic
Microsoft Windows Vista Home Premium
Microsoft Windows Vista Business
Microsoft Windows Vista Ultimate
Microsoft Windows XP Home Edition
Microsoft Windows XP Professional
Microsoft Windows Server 2003 Standard Edition
Microsoft Windows Server 2003 Enterprise Edition
Microsoft Windows 2000 Professionalv
Microsoft Windows 2000 Server

※ 64bit版は対応していません。
※ マイクロソフトによるサポートが終了したOS(Service Pack含む)は動作保証外となります。
※ 動作環境によってはシステムモジュール（DLLファイルなど）の追加、更新が必要となる場合があります。
※ Windows Vista では利用できない機能があります。

ハードウェア環境

上記のＯＳが安定して動作するパソコン
1024×768ドット以上の表示環境 (コントローラー側のみ）
LANカードが装着されていること。（ユニークなMACアドレスを有するもの）
ビデオキャプチャー装置（ドライバがVideo for Windowsに対応していること） ※1

ネットワーク環境

TCP/IPでの通信が可能なLAN環境
固定IPアドレスの環境を推奨します。
ルーターを介した他のセグメントのネットワークに対しては、一部利用できない機能があります。 ※2

※1
ビデオキャプチャーデバイスとドライバの種類によってはビデオキャプチャー機能が正常に機能しない場合があります。
本ソフトウェアの購入前には、十分な動作試験を実施してください。

※2
画像配信、音声メッセージ
但しルーターの設定により、ＩＰマルチキャストの通過が許可されている場合はご利用いただけます。
また、ブロードキャストパケットの通過ができないネットワークに対しては、電源の遠隔投入(Wake on LAN)はご利用いただけません。


導入の手引き

初めてGuardianをご利用になる場合、下記の様な作業が必要となります。
利用するために必須のものと、任意のものがあります。
下記はGuardianを利用する上で必須の作業項目です。

①コントローラーのインストール（必須）
コントローラー環境のセットアップです。通常は１台のパソコンにインストールします。

②クライアントのインストール（必須）
クライアント環境のセットアップです。必要な台数分インストールを行います。

③クライアントの登録（必須）
コントローラーで管理するクライアントを登録します。（固定ＩＰアドレスでない場合［DHCP利用時］は不要）


インストールの準備

Guardianのインストールプログラムが格納されたCD-ROM。 または、インターネットからダウンロードされたインストールプログラム。
通常、オンラインによって配布されるGuardianのインストールプログラムは「Guardian.exe」というファイルネームを持った自己解凍型のファイル１つだけです。
Guardianのインストールを開始する前に、できるだけ他のアプリケーションを終了させておいてください。


インストール

Guardianをインストールするには下記の手順に従ってください。

まず「Guardian.exe」のファイルを解凍して、次の4つのファイルを取り出してください。
    ① 「GCInstall.exe」 ・・・・・・・・・・・・・・・ クライアントパソコン用セットアッププログラム
    ② 「GRInstall.exe」 ・・・・・・・・・・・・・・・ コントローラーパソコン用セットアッププログラム
    ③ 「Manual.chm」 ・・・・・・・・・・・・・・・ Guardian マニュアル （コントローラーにインストールされるものと同一です。）
    ④ 「最初にお読みください.txt」 ・・・・・・ セットアップに関するガイド

インストールするOS環境や状態によってはシステムモジュールの更新を行う必要があります。
万一、インストール途中でエラーメッセージが表示された場合は、直ちに「キャンセル」によってインストール作業を中断してください。
その後、システムモジュールの更新作業を行ってください。

Guardianはインストールする環境により実行するセットアッププログラムが異なります。
Guardianには次の２つの動作環境があります。

【コントローラー環境】のセットアップ
コントローラーとなるマシン上で下記の手順を実行します。
「GRInstall.exe」を適当なフォルダにコピーし、ダブルクリックなどで起動します。
セットアッププログラムが起動しますので、以降は画面の指示に従ってください。
セットアップが終了しますと、システムの再起動を促すメッセージが表示されますので一度システムを再起動してください。

【クライアント環境】のセットアップ
クライアントのインストールには対話式にインストールする方法と、フルオートでインストールする方法の２種類があります。
初めて「Guardian」のクライアントをインストールする場合や、少数のパソコンへのインストールを行う場合は、「対話式インストール」の方法をお勧めします。
一方、「フルオートインストール」は多数のパソコンにインストールする際にご利用いただくと大変ご便利です。

１．対話式インストール
インストーラーの指示に従ってセットアップを進めて行く、通常のインストール方法です。
下記の手順でインストールを行ってください。

  - 「GCInstall.exe」を適当なフォルダにコピーし、ダブルクリックなどで起動してください。
  - セットアッププログラムが起動しますので、以降は画面の指示に従ってください。
  - セットアップが終了しますと、システムの再起動を促すメッセージが表示されますので、一度システムを再起動してください。
  - システムの再起動後、クライアントプログラムが自動的に起動します。
- 「GCInstall.exe」を削除します。

２．フルオートインストール
ひとたびインストールプログラムが起動されると、すべてのインストール処理は自動で進行し、作業者は全く操作を行う必要はありません。
ネットワークを利用してインストールプログラムを各クライアントに配布し、インストールプログラムを起動させれば、短時間で大量のクライアントにインストールを行う事ができます。
フルオートインストールによるクライアントのセットアップを行うには、インストールプログラム「GCInstall.exe」の他に、インストールするフォルダを指定する為のファイル「GCInstall.dat」を用意します。「GCInstall.dat」は１行のみのテキストファイルで、「メモ帳」等で作成してください。
コントローラーがインストールされているフォルダ下の「forClientフォルダ」にサンプルの「GCInstall.dat」がありますので、それを編集していただいても結構です。
インストールフォルダの指定は必ずフルパス形式で記述する必要があり、文字列の最後には必ず改行を伴わなければなりません。
記述例：（C:\Program Files\Kanri）

- 「GCInstall.exe」および「GCInstall.dat」を、必ず「Program Files」フォルダ直下に格納してください。
  万一、他のフォルダに格納して実行した場合は、「対話式インストール」でのインストールとなります。
-　「GCInstall.exe」を起動してください。
- 以降のインストール作業はすべて自動で行われ、インストールの完了後、システムは自動的に再起動されます。（ご注意ください。）
- 「Program Files」直下に格納した「GCInstall.exe」および「GCInstall.dat」の両ファイルは自動的に削除されます。

インストール完了後は「対話式インストール」でも「フルインストール」による方法でも、全く同じ動作環境となります。

ご注意
クライアントのアンインストールはWindows標準のアンインストール方法である「アプリケーションの追加と削除」からは行えません。
これは使用者が不用意にクライアントシステムのアンインストールを行うことを防止するためです。
クライアントがインストールされたフォルダにある「UnInstall.exe」を実行することによって、クライアントはアンインストールされます。
不用意なアンインストールを防止するため、供用を開始する前に「UnInstall.exe」をクライアントのフォルダから削除しておくことをお勧めします。
「UnInstall.exe」はコントローラーがインストールされたフォルダ下の「forClientフォルダ」にバックアップとして保管されていますので、アンインストールの際はそのファイルを該当のクライアントにコピーしてご利用ください。
コントローラーの「ファイル削除」機能や「ファイル配信」機能を利用すれば、個々にクライアントでこの作業を行う必要はありません。（コントローラーからリモートで処理が可能です。）

クライアント、コントローラーとも、Administratorの権限が無いとインストールに失敗します。
必ずAdministratorの権限を持ったアカウントでログオンしてからインストール作業を行ってください。


アンインストール

Guardianをアンインストールするには下記の手順に従ってください。

【クライアント環境】のアンインストール
クライアントのアンインストールは、Windows標準のアンインストール方法である「アプリケーションの追加と削除」からは行えません。
これは使用者が不用意にクライアントプログラムのアンインストールを行うことを防止するためです。
クライアントがインストールされたフォルダにある「UnInstall.exe」を実行することによって、クライアント環境はアンインストールされます。
万一、フォルダ内に「UnInstall.exe」が存在しない場合は、インストール作業を行った際に作業者によって削除されている可能性があります。
その場合は、コントローラーがインストールされている{for Client}フォルダに「UnInstall.exe」のバックアップがありますので、それをクライアントがインストールされているフォルダにコピーしてご利用ください。

①「UnInstall.exe」を起動する。
②「アンインストール」ボタンをクリックする。
③以降はアンインストーラーの指示に従ってください。

「UnInstall.exe」を起動する前に、動作中のクライアントプログラムを停止させる必要はありません。
「UnInstall.exe」によって自動的に終了処理が行われます。

【コントローラー環境】のアンインストール
①コントローラープログラムが動作している場合は、終了する。
②［スタート］－［設定］－［コントロールパネル］にてコントロールパネルウィンドウを開く。
③「アプリケーションの追加と削除」のアイコンをダブルクリックして、アプリケーションの追加と削除ウィンドウを開く。
④リストの中から「GRemote」を選択し、「変更/削除」ボタンをクリックする。
⑤「削除」を選択し、「次へ」をクリックする。

ご注意
「クライアント環境」、「コントローラー環境」とも、Administratorの権限が無いとアンインストールに失敗します。
必ずAdministratorの権限を持ったユーザー名でログオンしてからアンインストール作業を行ってください。


GClientの起動

クライアントの起動

クライアントプログラムはシステムの起動時に自動起動されるようになっており、起動操作を行う必要はありません。
クライアントプログラムが起動したことを、クライアントのデスクトップ上で確認する手段はありません。
起動後直ちにバックグラウンド動作となり、デスクトップ上には何の表示も出ませんのでご注意ください。


クライアントの手動停止

何らかの理由でクライアント側にて動作中のクライアントプログラムを停止する必要がある場合、下記の手順を実行します。
動作を停止するには、マウスのポインターをデスクトップの左上に移動し、「Ctrl + Shift」キーを押しながらマウスを右クリックします。
（クリックする場所はデスクトップの最上左端からX方向、Y方向にそれぞれ3dotの範囲が有効です。）

パスワード入力用ボックスに事前に登録、設定されているパスワードを入力し、「OK」ボタンをクリックします。
パスワードが正しければ直ちにすべての制御は解除され、クライアントプログラムは終了します。

入力したパスワードが間違っていれば、ダイアログボックスはクローズし、動作は継続されます。

解除用パスワードの登録は「解除パスワードの登録」にて行います。

ご注意
クライアントが「ロック」の状態にある時は、手動停止を行う事はできません。


解除パスワードの登録

解除用パスワードの登録を行うには「GRegist.exe」を利用します。
「GRegist.exe」はクライアントがインストールされたフォルダにあります。
「GRegist.exe」を起動すると下記の画面が表示されます。

解除用パスワードの登録
パスワードの登録、変更を行うには、先ず現パスワード入力ボックスに現在設定されているパスワードを入力します。
インストール後、初めて設定するときは現パスワード入力ボックスは空欄のままにしておいてください。
次に新パスワード入力ボックスに新しく登録したいパスワードを入力し、「パスワード保存」ボタンをクリックします。
このとき、現パスワードが登録されているデータと一致しないと、エラーとなり登録、変更は行われません。
登録することができるパスワードは１５バイト以内の文字列です。（英数字を推奨）
パスワードを消去したいときは、新パスワードを空欄にして「パスワード保存」ボタンをクリックしてください。
パスワードの設定がない場合、クライアントにて制御の解除を行うことは不可能となります。
なお、解除用パスワードの登録はコントローラーから行うこともできます。（この方法をお勧めします。）


メッセージの送信

メッセージの送受信

クライアント側からメッセージの送受信操作を行うことが可能です。

メッセージの受信
コントローラーや他のクライアントからメッセージが到着した場合、自動的にダイアログボックスが表示されます。
受信欄には送信元のユーザー名、コンピュータ名および受信文が表示されます。
返信したい場合は送信先の項目はそのままにし、送信文だけを入力して「送信」ボタンをクリックします。

メッセージの送信
クライアント側からコントローラーや他のクライアントに対してメッセージの送信を行うには下記の手順に従います。
クライアントがインストールされているフォルダ内にある「GRMessage.exe」を起動します。
  （一般ユーザーが利用し易いように、ショートカットを作成しておくとよいでしょう。）

送信先の項目には相手先の「コンピュータ名」又は「ユーザー名」の内、分かっているものを１つ入力します。
入力した文字は大文字、小文字の区別はされません。
送信先に「ユーザー名」を指定した時で、コントローラーのクライアントリストに同一名のユーザーが複数存在する場合は、リスト中 最も上部にあるクライアントに送信されます。
送信先の項目が空欄の場合、メッセージはコントローラー（管理者）宛てに送信されます。

次に送信文を入力し、「送信」ボタンをクリックします。（入力可能な文字数は250バイト以内です。）
送信先に指定したクライアントが稼動していなかったり、該当のクライアントがない場合はダイアログボックス上部に送信できなかった旨のガイド文が表示されます。

ご注意
クライアントから他のクライアントへのメッセージ送信はすべてコントローラーを経由して配信されます。
コントローラープログラムが起動していないと、本機能は利用できません。


ヘルプコール

クライアントの利用者は管理者に対して、必要なときに連絡を取ることが出来ます。
連絡方法には、コントローラーに「ヘルプ」コールを送出する方法と、具体的なメッセージ文を送信する方法の２種類があります。

「ヘルプ」コールを送出
クライアントにて、[Alt]キーを押しながら[Pause]キーを押すと、コントローラーの状態欄に「HELP」と表示し、クライアントおよびコントローラーにてビープ音が鳴ります。
コントローラ側で対象のクライアントをダブルクリック又は「詳細情報」ボタンをクリックすると、「HELP」表示は消え、現在の状態表示に復帰します。

メッセージ文を送信
コントローラーに対してメッセージ文を送信することができます。
クライアントにて、[Shift]キーを押しながら[Pause]キーを押すと、下記のメッセージ送信ウィンドウが表示されます。

メッセージを「送信文」に入力後、[送信]ボタンをクリックしてください。この時、「送信先」は空欄のままで結構です。

ヘルプコール機能の無効化
何らかの理由でヘルプコールの機能を利用したくない場合は、コントローラー側で下記の操作を実行することで機能を無効にすることが出来ます。

    ・対象となるクライアントをリストから選択します。（複数選択可）
    ・メッセージ入力欄に「HELPCALLOFF」と入力し、「コマンド」ボタンをクリックします。
    ・直ちに対象のクライアントでは、ヘルプコールの機能が無効となります。（下記の有効化処理を実行するまで、再起動しても継続します。）

ヘルプコール機能を有効にしたいときは、下記の手順を実行します。
    ・対象となるクライアントをリストから選択します。（複数選択可）
    ・メッセージ入力欄に「HELPCALLON」と入力し、「コマンド」ボタンをクリックします。
    ・直ちに対象のクライアントではヘルプコールの機能が有効となります。


ビデオキャプチャー設定

ビデオキャプチャーに関する設定を行うには、設定プログラムの「VSet.exe」を起動します。
「VSet.exe」はクライアントがインストールされているフォルダにあります。
起動すると、下記の設定ダイアログボックスが表示されます。（画面左側の画像は表示されないことがあります。）

ビデオキャプチャードライバの選択
ビデオキャプチャードライバは「Video for Windows」に対応している必要があります。
クライアントパソコンにインストールされているビデオキャプチャードライバが表示されるので、該当のドライバを選択し「設定」ボタンをクリックします。
有効なドライバが選択され、かつビデオカメラが動作中の場合は画面左側にキャプチャー画像が表示されます。

キャプチャー画像の設定
キャプチャー画像の下には２つの設定用ボタンがあります。
左側のボタンはキャプチャー画像の明るさや色合いなどの「ビデオソース」に関する設定を行うためのものです。
右側のボタンはキャプチャー画像のサイズなど「ビデオ形式」に関する設定を行うためのものです。
それぞれの設定内容、画面構成はビデオキャプチャードライバによって異なります。詳しくはビデオキャプチャードライバの説明をご参照ください。

キャプチャーパフォーマンスの調整
ビデオキャプチャー設定の画面では正常に表示されているにもかかわらず、実際にキャプチャーしてコントローラーで確認すると真っ黒な画像が表示されることがあります。
このようなときは「キャプチャーパフォーマンス調整」を行うことで、正常に表示されるようになる場合があります。
「キャプチャーパフォーマンス調整」の入力欄に10前後の数値を入力し、「設定」ボタンをクリックしてください。
初期値は「0」で、数値が大きくなるほど画像転送に時間がかかります。一般的には、20以上の値に設定しても画像が正常に表示されない場合は、別の障害が考えられます。

ご注意
キャプチャー画像が表示されない場合は、他のドライバに切り替えてみてください。（複数ある場合）
それでも表示されない場合は、基本的なビデオキャプチャーの準備が出来ていないことになります。ビデオキャプチャー機器の説明をご参照ください。
ビデオキャプチャーデバイスおよびドライバの種類によっては正常に機能しないことがあります。
クライアントがWindows Ｖｉｓｔａの場合、本機能は利用できません。


コントローラーの起動

コントローラープログラム（GRemote.exe）の起動は下記の手順で行います。

「GRemote.exe」は「GRInstall.exe」によってセットアップされたフォルダに格納されています。
またセットアップ直後にはスタートメニューにショートカットが「Guardian Controller」として登録されます。
コントローラープログラムを起動すると下記のメイン画面が表示されます。

メイン画面はいくつかのブロックに分かれています。

①クライアントリスト
登録されているクライアントのIPアドレスやコンピュータ名などの情報を表示するためのリストです。
リスト下部にはグループ分けのためのボタンが並んでいます。

②詳細情報
クライアントに関する様々な情報を表示するブロックです。

③コマンドパネル
クライアントに対する制御コマンドや登録コマンドを集めたブロックです。

④ワンライン送信
クライアントに対してメッセージを送ったり、アプリケーションの起動指示を送ったりするためのブロックです。

ヘルプ
「Guardian」のオンラインマニュアルです。

終了
コントローラープログラムを終了します。


クライアントリスト

IPアドレス
登録されているクライアントのIPアドレスを表示します。
第１行目の［255.255.255.255］はプログラムで予約されており、全クライアントを意味します。
ＩＰアドレスの左側にはクライアントの利用状態に関する情報がランプ表示されます。

現在クライアントが利用中（操作中）であるかどうかを識別することができます。
操作中のクライアントはIPアドレスの左側に緑ランプが点灯します。
設定された時間内にマウス操作が行われないと、そのパソコンの緑ランプは消灯します。
インストール直後の初期設定時間は５分（300秒）となっています。（５分間、マウス操作が行われないと消灯します。）
設定時間（アクティブ検出時間）を変更するには「環境設定」にて行います。

利用権限のないユーザーを検出したときは赤ランプが点灯します。

コンピュータ名
IPアドレスに対応するコンピュータ名を表示します。
クライアントと通信を行う度に最新のコンピュータ名を自動取得して表示します。

ユーザー名
現在クライアントマシンを利用しているユーザー名（ログオンユーザー）を表示します。
クライアントと通信を行う度に最新のユーザー名を自動取得して表示します。
「SYSTEM」と表示されている場合は、そのマシンはログオフ状態であることを示します。（Windows NT, Windows 2000, Windows XPのみ）

状態
現在のクライアントの動作状態を表示します。コントローラーからの動作指示に対する実行結果も本欄に表示されます。
本欄が空欄のクライアントは、クライアントプログラムが動作していないことを示します。

動作時刻
状態欄に表示されている内容が実行された時刻を表示します。（時刻の更新を行わないコマンドもあります。）

制御内容
クライアントにて現在設定されている制御ファイル名を表示します。

MACアドレス
クライアントのネットワークカードに固有の物理アドレスを表示します。
ウェイクアップ（Wake On LAN）にて利用されます。

ポート番号
クライアントにて現在設定されているポート番号を表示します。

ログ
クライアントにてログの収集が行われている場合、「ON」と表示されます。

グループ
所属しているグループの番号が表示されます。（1～12）

メモ
クライアントに関する任意のメモ情報が表示されます。
メモの登録は、「クライアント登録」にて行います。

操作ガイド
コントローラーの各制御コマンドを実行するには、クライアントリスト内で実行対象となるクライアントが選択されている必要があります。

クライアントの選択方法
クライアントの選択は、該当する行を左クリックします。選択されたクライアントは反転表示されます。
クライアントの選択は、Windows標準の複数選択が可能です。（「Ctrl」と「Shift」を組み合わせて行う選択操作）
クライアントの選択は、後に述べるグループ管理による方法も利用できます。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべての端末が反転表示され選択されます。
第１行目を左クリックして選択した場合は、第１行目のみが反転 選択されます。
第１行目の「すべての端末」のみが選択された状態で各コマンドを実行した場合、命令の送信はIPマルチキャストによって行われます。
この方法を利用しますと、各クライアントへのコマンドの送信は一括で行われネットワークにも負荷がかかりません。
ただし、ルーターを介した他のセグメントにはコマンドは到達しません。（ルーターの設定に依存）

クライアントリストの表示変更
クライアントリストの各項目（カラムタイトル）をドラッグすることにより、表示順序の変更を行うことができます。
クライアントリストの各項目（カラムタイトル）間をドラッグすることにより、表示幅の変更を行うことができます。
クライアントリストに表示される各クライアントの表示順序を変更（ソート）することができます。
ソートするには、変更したいカラムタイトルをクリックしてください。同一カラムをクリックするごとに、昇順、降順にソートされます。
クライアントリストの表示内容（表示順序、表示幅、ソートカラム）は終了時に保存され、次回起動時に再現されます。

表示内容をデフォルトの状態に戻すには、[Alt]キーを押しながらカラムタイトルをクリックしてください。

※「登録のないクライアントを自動登録する」がオンの状態で自動追加されたクライアントは、必ずクライアントリストの第２行目に追加されます。
任意のカラムをクリックすれば、追加されたクライアントのデータは所定の位置にソートされて表示されます。

クライアントの登録は「クライアント登録」で行います。

クライアントのグループ管理
登録されているクライアントをグループ分けして管理することが出来ます。
グループ分けすることにより、クライアントの複数選択が非常に容易になります。

クライアントをグループに所属させるには、下記の手順に従います。
まず対象となるクライアントを選択します。（複数選択可）
次に[Ctrl]キーを押しながら、該当のチェックボックスをクリックします。
クライアントリストの「グループ」欄に設定したグループ番号が表示されます。
「グループ」のカラムをドラッグし、表示位置を変更すると一覧表示でき、ご便利です。

クライアントを設定したグループ単位で選択するには、対象となるグループのチェックボックスを選択します。（複数選択可）
次に「選択」ボタンをクリックします。
このとき、クライアントリスト内ですでに選択されているクライアントは解除されず追加選択されますのでご注意ください。
クライアントリスト内のすべての選択を解除するには、「解除」ボタンをクリックします。


詳細情報ブロック

詳細情報

              【デスクトップキャプチャー】　　　　　　　　　　　　　　　　　　【ビデオカメラキャプチャー】

コマンドパネル内の「詳細情報」又は「巡回開始」ボタンをクリックすると、下記の情報が詳細情報ブロックに表示されます。

IPアドレス
取得したクライアントのIPアドレスを表示します。

コンピュータ名
取得したクライアントのIPアドレスを表示します。

ユーザー名
取得したクライアントのIPアドレスを表示します。

取得時刻
取得した日時を表示します。

OS
OSの種別を表示します。

デスクトップサイズ
デスクトップの解像度を表示します。

メモリ容量
搭載しているメモリ容量と現在のフリーなメモリ容量を表示します。

ディスク容量
搭載しているディスク容量と現在の空き容量を表示します。
表示される容量はシステムディレクトリのあるドライブのものです。

キャプチャー画像
クライアントパソコンのデスクトップ画像又はビデオカメラ画像を表示します。

ウィンドウ・プロセス・アプリケーション情報
このペインには４種類の情報が表示されます。
１．ウィンドウ・・・・デスクトップに表示されているウィンドウのリスト（最大30）
    表示されるのはキャプション（タイトル名）とクラス名です。
    最小化された状態のウィンドウも表示されます。（タスクバーに格納されたもの）
    リストにはシステムを示す「Program Manager,Program」が必ず含まれます。

２．プロセス・・・・クライアントにて起動しているプロセスのリスト
    ウィンドウを持つ、持たないにかかわらず、起動中のすべてのプロセスを表示します。
    表示内容はハードディスクにおける絶対位置になります。

３．サービス・・・・クライアントに登録されているサービスを表示します。
    各サービス名の先頭には動作状態を示す文字が付加されます。
    先頭文字が「R,」の場合、そのサービスは動作中であることを表します。
    先頭文字が「S,」の場合、そのサービスは停止中であることを表します。

４．アプリケーション・・・・クライアントにインストールされているアプリケーションのリスト（最大100）
    クライアントのハードディスクにインストールされているアプリケーションの一覧を取得し、表示します。
    表示されるのはWindows標準のインストール手法によってインストールされたアプリケーションのみです。
    （「アプリケーションの追加と削除」に表示されるもの）

操作ガイド

クライアントの詳細情報を取得、表示するには下記の手順に従います。
1.画像の選択
キャプチャー画像としてデスクトップ画像を表示するには、「ﾃﾞｽｸﾄｯﾌﾟ」のボタンを選択します。
キャプチャー画像としてビデオカメラ画像を表示するには、「ﾋﾞﾃﾞｵ」のボタンを選択します。

2.リストの選択
ウィンドウのリストを表示するには、「ｳｨﾝﾄﾞｳ」のボタンを選択します。
プロセスのリストを表示するには、「ﾌﾟﾛｾｽ」のボタンを選択します。
サービスのリストを表示するには、「ｻｰﾋﾞｽ」のボタンを選択します。
アプリケーションのリストを表示するには、「ｱﾌﾟﾘｹｰｼｮﾝ」のボタンを選択します。

3.クライアントの選択
情報を取得するクライアントをリストから１つ選択します。
複数のクライアントを選択して実行することはできません。（第１行目の「すべての端末」も不可）

4.取得
「詳細情報」ボタンをクリックすると、情報が表示されます。
リスト内のクライアントをダブルクリックすることでも、詳細情報の取得が可能です。

デスクトップのキャプチャー画像を縮小せず、等倍サイズで表示することができます。
表示方法には下記の２通りがあります。
部分切り取り
[Ctrl]キーを押しながら縮小画像上を左クリックすると、クリックした位置を中心として約260×200ドットの等倍サイズで表示されます。
全画面表示
[Ctrl] + [Shift]キーを押しながら縮小画像上を左クリックすると、等倍サイズで全画面をキャプチャーして表示します。
表示された画像は上下左右、スクロール表示させることができます。

クライアントの詳細情報を一定間隔で自動取得し表示するには下記の手順に従います。（巡回取得）
画像の選択
キャプチャー画像としてデスクトップ画像を表示するには、「ﾃﾞｽｸﾄｯﾌﾟ」のボタンを選択します。
キャプチャー画像としてビデオカメラ画像を表示するには、「ﾋﾞﾃﾞｵ」のボタンを選択します。

リストの選択
ウィンドウのリストを表示するには、「ｳｨﾝﾄﾞｳ」のボタンを選択します。
プロセスのリストを表示するには、「ﾌﾟﾛｾｽ」のボタンを選択します。
アプリケーションのリストを表示するには、「ｱﾌﾟﾘｹｰｼｮﾝ」のボタンを選択します。

間隔の設定
1秒から99999秒まで入力可能で、初期値は3秒となっています。

画像保存の設定
巡回しながらキャプチャーした画像をファイルに保存するには、「保存」のチェックを選択します。

クライアントの選択
情報を取得するクライアントを選択します。
クライアントの選択は、複数のクライアントを選択することが可能ですが、第１行目の「すべての端末」は無効となります。
登録されているすべての端末を選択したいときは、第１行目を右クリックして全クライアントを反転選択してください。

取得
「巡回開始」ボタンをクリックすると、情報が表示されます。
複数のクライアントが選択されている場合、クライアントの巡回はリストの上から下に向かって行い、最後まで到達するとまた最初に戻って巡回を行います。（無限ループ）

中止
「巡回中止」ボタンをクリックすると、巡回は停止します。（「巡回開始」ボタンをクリックすると、ボタンの表示は「巡回中止」に変わります。）

画像ファイルはコントローラーがインストールされたフォルダ直下の「Image」フォルダに保存されます。
ファイル形式はJPEGで、ファイル名は下記のようになります。
コンピュータ名＿ユーザー名＿時’分’秒．jpg

単一のクライアントに対して短い間隔で巡回を行うと、そのクライアントに対して負荷を掛けることになりますのでご注意ください。

キャプチャー画像のマルチ画面表示（巡回取得）
巡回取得において、キャプチャー画像を一覧表示させることが出来ます。
キャプチャー画像を一覧表示するには、次の手順に従います。
画像の選択
キャプチャー画像としてデスクトップ画像を表示するには、「ﾃﾞｽｸﾄｯﾌﾟ」のボタンを選択します。
キャプチャー画像としてビデオカメラ画像を表示するには、「ﾋﾞﾃﾞｵ」のボタンを選択します。

間隔の設定
1秒から99999秒まで入力可能で、初期値は3秒となっています。

クライアントの選択
画像を取得するクライアントを選択します。
クライアントの選択は、複数のクライアントを選択することが可能ですが、第１行目の「すべての端末」は無効となります。
取得画像がデスクトップ画像の場合は、最大48クライアントまで選択が可能です。
一方、取得画像がデスクトップ画像の場合は、最大4クライアントまでとなります。

取得
[Shift]キーを押しながら「巡回開始」ボタンをクリックすると、新しい画像表示用のウィンドウが開きます。
表示ウィンドウは選択したクライアント数に応じて、4、12、24、48に分割されます。
複数のクライアントが選択されている場合、クライアントの巡回はリストの上から下に向かって行い、最後まで到達するとまた最初に戻って巡回を行います。（無限ループ）
取得した最新のクライアント画像には赤い縁取りがつきます。
巡回表示中、任意のクライアント画像を左クリックすると、そのクライアントの最新状態を取得することができます。
取得後は、また巡回表示に自動復帰します。

中止
表示ウィンドウをクローズするか、「巡回中止」ボタンをクリックすると、巡回は停止します。（ボタンの表示は「巡回中止」に変わります。）

・巡回中の画像保存は出来ません。
・画像以外の詳細情報は表示されません。
・履歴保存は行われません。
・表示された画像上を右クリックすると、拡大画像（等倍サイズ）が表示されます。（後述の「拡大画像の表示」を参照）

拡大画像の表示
クライアントリスト内にて対象のクライアントを右クリックすると、大きなキャプチャー画面（等倍サイズ）のデスクトップ画像を表示することが出来ます。（ビデオ画像は不可）
上記操作の代わりに、詳細情報の縮小表示されたキャプチャー画像内を左クリックすることでも同様の操作が可能です。
ただしこの場合表示される拡大画像は、左クリックした縮小画像のクライアントのものになります。
クリック後、画像が表示されるまで数秒かかります。（転送、表示時間）
引き続き新しい画像を表示するには、画面上で左クリックしてください。左クリックするたびに、クライアントの新しいキャプチャー画像が表示されます。
このウィンドウを消去するには、[Esc]キーを押します

キャプチャー画像の保存
表示された画像をファイルとして保存することが出来ます。
保存するには下記の手順に従います。

縮小画像の保存
縮小表示されたキャプチャー画像上を右クリックすると、下図のような保存ダイアログボックスが表示されます。

拡大画像の保存
拡大表示されたキャプチャー画像上を右クリックすると、下図のような保存ダイアログボックスが表示されます。

保存することが出来るファイルの種類はビットマップ（BMP）になります。
1Bit～32Bitまでビット数を選択できます。（8Bit以下はRLE圧縮も可能です。）
保存するビット数によってファイルサイズが異なります。

履歴の参照
一度取得されたクライアントの詳細情報は、設定された保持件数に達するまで履歴として自動的に保存、蓄積されます。
保存された過去の詳細情報は、自由に呼び出して再表示させることが出来ます。
履歴データが保持件数を超えると、自動的に圧縮ファイル(ZIP)に保存され、履歴データはリセットされます。

過去の詳細情報を呼び出すには、キャプチャー画像の真下にあるスクロールバーを利用します。
クロールバーの右下には、保存されている詳細情報の総数が表示されます。（右側の数値）
左側の数値は現在表示されている詳細情報データの位置を表します。
スクロールバーが右に行くほど、新しい詳細情報になります。
過去の詳細情報を表示した状態で新しい詳細情報の取得を行うと、自動的にスクロールバーは最右端に移動し、取得した最新情報を表示します。
画像の種類（ﾃﾞｽｸﾄｯﾌﾟ､ﾋﾞﾃﾞｵ）やリストの種類（ｳｨﾝﾄﾞｳ、ﾌﾟﾛｾｽ、ｱﾌﾟﾘｹｰｼｮﾝ）もボタンの位置で識別することが可能です。

詳細情報の履歴保存を行いたくない場合は、「コントローラー設定」で機能を無効にするとこが可能です。
また、保持する履歴ﾃﾞｰﾀの件数も「コントローラー設定」で設定することが可能です。

圧縮ファイルとして保存された履歴データはいつでも呼び出して参照することが出来ます。
履歴データの管理は「履歴管理」にて行います。

クライアントに表示されているウィンドウを消去するには下記の手順に従います。（強制クローズ）
ウィンドウの消去方法は２種類あります。

１．縮小画像上で指定する方法
先ず、対象となるクライアントの詳細情報を取得します。
消去したいウィンドウを縮小画像上で[Alt]キーを押しながら左クリックします。
直ちにクライアントでは対象のウィンドウが消去されます。
この時、たとえ作業途中の状態であっても、強制的にそのウィンドウ（アプリケーション）はクローズされます。
縮小画像上でクリックした位置にあるウィンドウはすべて消去対象となります。
消去したいウィンドウの下に別のウィンドウがあった場合、そのウィンドウも同時に消去されます。（串刺し）

２．ウィンドウリスト内から指定する方法
先ず、対象となるクライアントの詳細情報を取得します。
このとき、取得するリストは「ウィンドウ」の情報である必要があります。
リストから消去したいウィンドウを選択します。（複数選択は出来ません。）
「ウィンド、ﾌﾟﾛｾｽ終了」ボタンをクリックすると、選択されているウィンドウを消去させることができます。
この時、たとえ作業途中の状態であっても、強制的にそのウィンドウ（アプリケーション）はクローズされます。

テクニック
複数のクライアントに対して同一のウィンドウを消去させたいときは、下記の方法に従います。
先ず、消去させたいウィンドウが表示されているクライアントの詳細情報を表示します。
リストから消去したいウィンドウを選択します。
クライアントリストにて、対象となるクライアントをすべて選択状態にします。
「ウィンド、ﾌﾟﾛｾｽ終了」ボタンをクリックすると、選択されているすべてのクライアントにてウィンドウを消去させることができます。

ご注意
アプリケーションによっては強制終了を行えないものもあります。
消去するウィンドウの種類と内容には十分にご注意ください。
ウィンドウによっては強制終了させるとシステム自体がハングアップするなど異常動作するものもあります。

クライアントで起動しているプロセスを終了するには下記の手順に従います。
先ず、対象となるクライアントの詳細情報を取得します。
このとき、取得するリストは「プロセス」の情報である必要があります。
リストから終了したいプロセスを選択します。（複数選択は出来ません。）
「ウィンド、ﾌﾟﾛｾｽ終了」ボタンをクリックすると、選択されているプロセスを終了させることができます。
この時、たとえ作業途中の状態であっても、強制的にそのプロセスは終了します。

テクニック
複数のクライアントに対して同一のプロセスを終了させたいときは、下記の方法に従います。
先ず、終了させたいプロセスが表示されているクライアントの詳細情報を表示します。
リストから終了したいプロセスを選択します。
クライアントリストにて、対象となるクライアントをすべて選択状態にします。
「ウィンド、ﾌﾟﾛｾｽ終了」ボタンをクリックすると、選択されているすべてのクライアントにてプロセスを終了させることができます。

ご注意
プロセスの終了操作は非常に危険を伴います。
不用意に本機能を利用すると、システムに重大な損害を与える可能性があります。
プロセスの終了操作は、無応答となったアプリケーションなどを強制終了させるための最終手段とお考えください。
通常、アプリケーションの終了操作を行うには、上記の「ウィンドウの消去」による方法をご利用ください。

クライアントに登録されているサービスを停止したり、開始するには下記の手順に従います。
本機能はクライアントのOSが Windows NT4.0, Windows 2000, Windows XPの時のみ機能します。
先ず、対象となるクライアントの詳細情報を取得します。
このとき、取得するリストは「サービス」の情報である必要があります。
リストから操作したいサービスを選択します。（複数選択は出来ません。）
「サービス停止」ボタンをクリックすると、選択されているサービスを停止させることができます。
「サービス開始」ボタンをクリックすると、選択されているサービスを開始させることができます。

テクニック
複数のクライアントに対して同一のサービスの操作を行いたいときは、下記の方法に従います。
先ず、操作したいサービスが表示されているクライアントの詳細情報を表示します。
リストから操作したいサービスを選択します。
クライアントリストにて、対象となるクライアントをすべて選択状態にします。
「サービス停止」ボタンをクリックすると、選択されているすべてのクライアントにてサービスを停止させることができます。
「サービス開始」ボタンをクリックすると、選択されているすべてのクライアントにてサービスを開始させることができます。

ご注意
サービスの操作は非常に危険を伴います。
不用意に本機能を利用すると、システムに重大な損害を与える可能性があります。
特にシステム関係のサービスは操作しないことを強くお奨めします。


履歴管理

キャンセル
履歴管理プログラムを終了します。

現在データに復帰
メイン画面の履歴データが過去の保存データの時、現在保持しているデータに内容を戻します。

読み込み
圧縮ファイルに保存されている過去の履歴データを呼び出します。
現在保持されている履歴データは自動的に待避します。

バックアップ
現在保持されている履歴データを圧縮ファイルに保存します。
バックアップ後も履歴データは消去されません。

履歴消去
現在保持されている履歴データを消去します。(リセット)
表示中のデータが過去データの場合は消去されません。

履歴ファイル削除
圧縮して保存されている履歴ファイルを削除します。
リスト内の削除したいファイルを選択し、「履歴ファイル削除」ボタンをクリックすると削除されます。

操作ガイド
圧縮ファイルに保存されている過去の履歴データを表示したいときは、対象となるファイルをリストから選択し、「読み込み」ボタンをクリックします。
リストにはそれぞれ記録されているデータの開始日時と終了日時が表示されます。
過去のデータを表示中は詳細データの保存は行われませんので、ご注意ください。（表示のみ）

過去の履歴データを現在の履歴データに戻すには、「現在データに復帰」ボタンをクリックします。

記録されているデータの件数に応じて、処理には数分から数時間の時間を要します。
処理中は中断処理(キャンセル)を行わないでください。(履歴データが消失することがあります。)


コマンドパネル

コマンドパネルは機能別にいくつかの小グループに分かれています。

詳細情報
クライアントに関する詳細な情報を取得するためのボタンが集められています。

ロック・検知
クライアントをロックしたり、利用状況の検知を行うためのボタンが集められています。

機能制御
クライアントに対し機能制限を課すためのボタンが集められています。

起動、終了
クライアントの起動や終了処理に関するコマンドが集められています。

リモコン・設定
クライアントをリモートコントロールしたり、様々な設定変更を行うためのボタンが集められています。

ファイル
ファイル操作、フォルダ操作に関するボタンが集められています。

ログ
ログ収集、回収、閲覧に関するボタンが集められています。

クライアント設定
管理するクライアントの登録、クライアントのポート番号、解除用パスワードの登録を行うためのブロックです。

補助機能グループ
補助的な機能を提供します。
コントローラーの環境設定も行います。


詳細情報

クライアントに関する様々な情報の取得を行います。
取得された内容は「詳細情報ブロック」に表示されます。


ロック

ロック、ロック解除

クライアントのコンソールをロックし、コンピューターの操作が出来ないようにします。

クライアントのロックを行うには下記の手順に従います。
まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括して命令を送ります。
次に「ロック」ボタンをクリックします。直ちに対象クライアントは完全にロックされ、マウス、キーボードからの操作はすべて無効になります。
このときクライアントリストの状態欄には「ロック」と表示され、正常にクライアントがロックされたことを知らせます。
クライアントのデスクトップには、ロック中を示すメッセージなどは一切表示されません。いわゆるフリーズ状態になります。
メッセージ送信機能を利用して、ロック中であることを告知するメッセージを表示するのも良い方法です。

クライアントのロック解除を行うには下記の手順に従います。
まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括して命令を送ります。
次に「ロック解除」ボタンをクリックします。直ちに対象クライアントのロックは解除されます。
クライアントリストの状態欄は「解除」と表示され、正常にクライアントがロック解除されたことを知らせます。

ご注意
ログオフ状態でロックを行うと、ユーザーは一切ログオンすることが出来なくなります。
クライアントのロックは「機能制御」とは独立して機能します。
クライアントにて何らかの制御ファイルが実行されているときに「ロック」を行った場合、制御ファイルの内容に「コンソールのロック」が付加されます。
この時、クライアントリストの表示は「ロック」となりますが、「ロック解除」を行うと元の状態の「制御」に復帰します。


検知

クライアントにて、登録されたウィンドウに対してアクセスが行われたことを検知します。
ウィンドウの登録は「アクセスを検知するウィンドウ」にて行います。

まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括して命令を送ります。
次に「検知」ボタンをクリックします。
このとき、クライアントリストの状態欄には「検知」という文字が表示され、検知機能が作動していることを知らせます。
検知機能を解除するには、対象のクライアントを選択した後、再度「検知」ボタンをクリックします。（トグル操作）

ご注意
検知するウィンドウの情報は、「制御ファイル」として事前にクライアントに転送しておく必要があります。
本機能は、クライアントがログオフや再起動を行っても直前の状態が継続します。
検知結果（詳細情報）を受け取る際、「画像を所得する」がオンの場合クライアントパソコンに負荷が掛かりますのでご注意ください。


制御開始

クライアントにおいて、制御ファイルに基づく制御を開始します。

まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括して命令を送ります。
次に「制御開始」ボタンをクリックします。直ちに対象クライアントでは制御が開始されます。
制御される内容は制御内容欄に表示されている制御ファイルの内容になります。（詳しくは「制御内容登録」の項目を参照）
この時、クライアントリストの状態欄には「制御」と表示され、正常に制御が開始されたことを知らせます。
制御を解除するには「解除」の操作を行います。

ご注意
クライアントの「機能制御」は「ロック」とは独立して機能します。
クライアントが「ロック」状態にある時に「制御開始」を行った場合、コンソールはロックしたまま制御内容が摘要されます。
この時、クライアントリストの表示は「ロック」のままですが、「ロック解除」を行うと「制御」表示に復帰します。


解除

制御解除

制御中のクライアントの解除を行います。

まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括して命令を送ります。
次に「制御解除」ボタンをクリックします。直ちに対象クライアントではすべての制御が解除され、自由にコンピューターを利用することが可能となります。
このとき、クライアントリストの状態欄には「解除」と表示され、正常に解除操作が行われたことを知らせます。

ご注意
クライアントの「機能制御」は「ロック」とは独立して機能します。
クライアントが「ロック」状態にある時に「制御解除」を行った場合、コンソールはロックしたままで制御内容の解除が実行されます。
この時、クライアントリストの表示は「ロック」のままですが、「ロック解除」を行うと「解除」表示に復帰します。


制限ユーザー登録

ユーザー別制御登録

画面は５つのブロックに分かれています。

・「管理ユーザー」ブロック
  管理したいユーザー名の追加、変更などを行います。

・「管理グループ」ブロック
  管理したいグループ名の追加、変更などを行います。

・「取得」ブロック
  サーバーからユーザー名やグループ名を取得します。

・「制御」ブロック
  制御内容をユーザー名およびグループ名に適用します。

・「終了、保存」
  登録内容の保存や終了操作を行います。

利用制限を課す対象の登録は、ユーザー単位又はグループ単位で行う事ができます。
両単位とも、組み合わせて設定、運用することができます。
登録された内容でユーザーの利用制限を課すには、「利用環境制限」にて制限スイッチを「ON」にしておく必要があります。

管理ユーザー
［ユーザーの追加］
利用制限をユーザー単位で課したい場合、下記の手順で登録を行います。
管理ユーザーブロック内にある「ユーザー名」の入力ボックスに登録したいユーザー名を入力し、「ユーザー追加」ボタンをクリックするとユーザーリスト内に追加表示されます。

［ユーザー名の削除］
登録済みのユーザー名を削除するには、対象のユーザーを選択した状態で「ユーザー削除」ボタンをクリックします。
同時に複数を選択して削除することが可能です。

［制御内容の設定］
登録されているユーザーに対して制御内容の設定を行うには、まず対象となるユーザー名を選択します。（複数選択可）
次に制御ブロックから適用したい制御内容のボタンをクリックします。設定されるとリスト内の制御欄に表示されます。
なお、「消去」ボタンをクリックすると、登録されている制御内容を抹消することができます。

［適用グループの設定］
グループ単位にて制御を行う場合、必ずユーザー名に対して所属グループの設定がなされていなければなりません。
ユーザー単位にて制御を行う場合は、適用グループ欄は空欄のままでかまいません。
登録可能な所属グループは１グループのみです。
登録するには手動でグループ名を登録する方法と管理グループからコピーする方法の２通りがあります。
ただし手動での登録は、ユーザー名を追加登録するときに同時入力する場合に限られます。

管理グループから所属グループ名をコピーするには、まず対象となるユーザー名を選択します。（複数選択可）
次に適用したいグループ名を管理グループのリストから選択し、「コピー↑」ボタンをクリックします。

適用されているグループ名を削除するには、まず対象となるユーザー名を選択します。（複数選択可）
次に「グループ消去」ボタンをクリックします。

Serverが利用できる場合、登録されているユーザーが所属しているグループを参照することが出来ます。
所属グループを参照するには、対象となるユーザー名を右クリックします。
取得したグループ名は、ユーザーリストの下にあるリストボックスに一覧表示され、適用グループ設定の参考にすることが出来ます。

リストの表示順序を変更（ソート）することができます。
ソートするには、変更したいカラムタイトルをクリックしてください。同一カラムをクリックするごとに、昇順、降順にソートされます。
ソートされた内容は終了時にそのまま保存され、次回起動時にも引き継がれます。

管理グループ
［グループ名の追加］
利用制限をグループ単位で課したい場合、下記の手順で登録を行います。
管理グループブロック内にある「グループ名」の入力ボックスに登録したいグループ名を入力し、「グループ追加」ボタンをクリックするとグループリスト内に追加表示されます。

［グループ名の削除］
登録済みのグループ名を削除するには、対象のユーザーを選択した状態で「グループ削除」ボタンをクリックします。
同時に複数を選択して削除することが可能です。

［制御内容の設定］
登録されているグループに対して制御内容の設定を行うには、まず対象となるグループ名を選択します。（複数選択可）
次に制御ブロックから適用したい制御内容のボタンをクリックします。設定されるとリスト内の制御欄に表示されます。
なお、「消去」ボタンをクリックすると、登録されている制御内容を「設定なし」の状態にすることができます。

リストの表示順序を変更（ソート）することができます。
ソートするには、変更したいカラムタイトルをクリックしてください。同一カラムをクリックするごとに、昇順、降順にソートされます。
ソートされた内容は終了時にそのまま保存され、次回起動時にも引き継がれます。

取得
DNSが利用できる場合、登録されているユーザー名およびグループ名をサーバーから取得して各リスト内に自動登録させることが可能です。
取得するには、「取得」ブロック内にあるサーバー名の入力ボックスにサーバー名を入力し、「更新」ボタンをクリックします。
サーバーに登録されているすべてのユーザー名とグループ名を取得し、各リストに自動追加されます。

この時、管理ユーザーに関しては存在確認が行われ、リストに登録されているユーザー名が、取得したユーザー名の中に含まれていない場合は、存在欄に「×」印が表示されます。（存在する場合は「○」）
この項目は制御の内容には関係なく、あくまでもユーザー管理の補助的な目的の為にあります。

登録内容の保存
登録した内容を有効にするには、「保存」ボタンをクリックしファイルに保存します。
「保存」ボタンをクリックせずに終了しますと、登録、変更した内容はすべて破棄されます。

保存と同時にその内容での制御が開始されます。（ユーザー制限スイッチが「ON」の場合）
ただし、すでにログオンしているユーザーには適用されません。

適用ルール
クライアントにてユーザーがログオンすると、そのユーザー名がコントローラーに通知されます。
コントローラーではそのユーザー名をキーにして、ユーザーリストの検索が行われます。
この時、適用される制御内容は次のルールで決定されます。

・ ユーザー名がユーザーリストにない場合、ユーザー別の制御は行われません。
・ ユーザー名がユーザーリストにあり、制御欄に登録がある場合は、その内容にて制御が行われます。この時、適用グループの設定があっても無視されます。
・ ユーザー名がユーザーリストにあり、制御欄が空欄で、適用グループ欄に設定がある場合は、そのグループに設定された制御内容によって制御が行われます。

ご注意
ユーザー名およびグループ名の大文字、小文字の区別は行われません。


利用環境制限

ユーザー別制御開始、解除

「制御ファイル転送」によって各クライアントに配信された制御ファイルの内容は、各クライアントパソコンを利用するすべてのユーザーに対して共通に作用します。
言い換えれば、クライアントパソコン単位の利用制限になります。
パソコン単位の利用制限ではなく、ユーザーごとに異なる利用制限を課すには下記の手順に従います。

１．利用制限内容の登録
利用制限を課したいユーザーと、その制限内容を事前に登録しておきます。
登録は「ユーザー別制御登録」にて行います。

２．利用制限を開始する。
利用制限を開始するには、「ユーザー別制御開始」ボタンをクリックします。ボタンの表示が「ユーザー別制御解除」に変わります。
利用制限を解除するには、「ユーザー別制御解除」ボタンをクリックします。
本設定は直ちに有効となりますが、すでにログオンしているクライアントのユーザーには適用されません。
一度利用制限が開始されると、コントローラープログラムを終了しても動作は継続します。

ご注意
本機能を利用するには、コントローラーパソコンが起動している必要があります。（コントローラープログラムが起動している必要はありません。）

利用制限が課せられたユーザーがログオフした場合、制御内容はログオン前にそのクライアントパソコンに適用されていた制御ファイルの内容に自動復帰します。
また、コントローラーから「解除」の操作が行われたときも同様に、ログオン前の状態に復帰します。
これはマシンに対して適用された制御内容を維持するための措置です。（ログオンしたユーザーの制限内容を、他のユーザーに適用させない為。）


制御内容登録

GRemoteメイン画面において「制御内容登録」のボタンをクリックすると、次の設定画面が表示されます。

設定画面は機能別にいくつかのブロックに分かれています。

制御ファイル
９種類の制御ファイルの読込や保存を行うためのブロックです。

利用を禁止するドライブ
ロックするドライブの設定を行うためのブロックです。

基本制御機能
デスクトップの制限方法や運用方法などの基本な動作設定を行うためのブロックです。

タイマー
タイマーによる制御を行うためのブロックです。

ブロックするキーの設定
ブロック（無効化）したいキーを設定します。

プロセスの監視
起動や終了の監視を行うプロセスの登録を行うためのブロックです。

パケットのブロック
通信をブロックするアドレスの登録を行います。

アクセスを制御するウィンドウ
アクセスを制御するウィンドウの登録を行うためのブロックです。

ワークウィンドウ
「アクセスを制御するウィンドウ」内のデータを再利用（編集）する目的で使用します。

アクセスを検知するウィンドウ
アクセスを検知するウィンドウの登録を行うためのブロックです。

タイトルバーの「X」をクリックすると、コントローラーのメイン画面に戻ります。このとき設定内容の保存は行われませんのでご注意ください。
設定内容の保存は「制御ファイル」にて行ってください。

制御ファイルの作成に関するチュートリアルがあります。参考にしてください。


制御ファイル

制御ファイルリスト
９種類のファイルのリストを表示します。

読込
「読込」ボタンをクリックすると、制御ファイルリストにて選択されているファイルの内容を読込み、その設定内容を各ブロックに表示します。

保存
「保存」ボタンをクリックすると、制御ファイルリストにて選択されているファイルに各ブロックで設定されている現在の内容を保存します。

ファイル名
「ファイル名」のボックスにファイル名を入力して「保存」ボタンをクリックすると、制御ファイルリストにて選択されているファイルのファイル名が変更されます。
このボックスが空欄のまま「保存」ボタンがクリックされた場合は、ファイル名の変更は行われず設定内容だけが保存されます。

操作ガイド
コントローラーでは９種類の制御ファイルを管理し、その内１つの設定内容をクライアントに転送する形で制御内容の登録を行います。
制御ファイルは半角１２文字以内の任意のファイル名を付けることができます。このとき、同一ファイル名の登録もできます。
ファイル名の入力ボックスを空欄のまま「保存」ボタンをクリックすると、ファイル名の変更は行わず設定内容だけが更新保存されます。
ある制御ファイルを読み込んだ後、他のファイル名（ファイル位置）を選択して「保存」を行うと、設定内容の複写が行えます。
各制御ファイルにはクライアントの運用を制御するための、多くの設定項目が記録されています。
項目の設定を行った場合は忘れずに「保存」の操作を行ってください。

制御ファイルの作成に関するチュートリアルがあります。参考にしてください。


利用を禁止するドライブ

利用を禁止したいドライブのチェックをオンにしてください。

注意事項
システム(アクティブ)のあるドライブをロックすることは出来ません。
クライアントのシステム状態によっては、ロックできない場合もあります。
ネットワーク仮想ドライブのロックは出来ません。


基本制御機能

Windowsの終了を禁止する。
Windowsの終了操作（シャットダウン、リブート、ログオフ）を無効にします。

スタートボタンへのアクセスを許可する
「スタートボタンへのアクセスを許可する」のチェックボックスをオンにすると、デスクトップ左下にある「スタートボタン」へのアクセスが可能となります。

タスクバーへのアクセスを許可する
「タスクバーへのアクセスを許可する」のチェックボックスをオンにすると、デスクトップ上にある「タスクバー」へのアクセスが可能となります。

タスクバーを消去する
「タスクバーの消去」のチェックボックスをオンにすると、デスクトップ上のタスクバーを消去します。
すっきりしたデスクトップとなりますが、タスクバーには一切アクセスすることができなくなります。

ウィンドウの移動、サイズ変更を禁止する
「ウィンドウの移動、サイズ変更を禁止する」のチェックボックスをオンにすると、ウィンドウの位置を移動したり、サイズの変更を行うことができなくなります。

システムキーを無効にする
「システムキーを無効にする」のチェックボックスをオンにすると、「Ctrl + Alt + Del」、「Ctrl + Esc」、「Windows Key」のキー操作が無効になります。
キーボードがUSB接続の場合、「Ctrl + Alt + Del」の操作は無効とすることはできません。（OSの仕様）

GClientの起動と同時に制御を開始する
「GClientの起動と同時に制御を開始する」のチェックボックスをオンにすると、クライアントが起動されると同時に制御が開始されます。
つまりコントローラーから「制御開始」のコマンドが送られたときの状態になります。
コントローラーが起動していない時でもクライアントにて制御を行いたいときに設定します。

クラス名「#32770」の利用を禁止する
クラス名が「#32770」のウィンドウをすべて利用禁止にするには、チェックボックスをオンにします。
コントロールパネル内の各ウィンドウ、一般ダイアログボックスなどがこれに当たります。
クラス名「#32770」は多くの一般アプリケーションで利用しますので、この設定には注意が必要です。

クラス名「MMCMainFrame」の利用を禁止する
クラス名が「MMCMainFrame」のウィンドウをすべて利用禁止にするには、チェックボックスをオンにします。
「コンピュータの管理」、「サービス」、「イベントビューア」などがこれに当たります。

クラス名「CabinetWClass」の利用を禁止する
クラス名が「CabinetWClass」のウィンドウをすべて利用禁止にするには、チェックボックスをオンにします。
「マイ コンピュータ」、「マイ ネットワーク」、「プリンタ」、「ネットワークとダイヤルアップ接続」などがこれに当たります。

クラス名「ExploreWClass」の利用を禁止する
クラス名が「ExploreWClass」のウィンドウをすべて利用禁止にするには、チェックボックスをオンにします。
エクスプローラーがこれに当たります。

クラス名「ConsoleWindowClass」の利用を禁止する
クラス名が「ConsoleWindowClass」のウィンドウをすべて利用禁止にするには、チェックボックスをオンにします。
「コマンドプロンプト」がこれに当たります。

操作ガイド
ウィンドウのクラス名を知るには、「詳細情報」にてウィンドウ情報を取得するとリストに表示されます。


タイマー

タイマーの作動
「作動」のチェックボックスをオンにすると、設定された時間が経過したとき「コンソールをすべてロック」したり「制御をすべて解除」したりできます。

作動時間
タイマー作動させたい時間を「タイマー時間」の設定ボックスに入力します。（1分～999分）

すべてロック
「すべてロック」のボタンをオンにすると、タイマー動作時にコンソールをロックします。（すべてのマウス及びキーボードの操作をロック）
ロックは他の制御内容に優先します。
ロックを解除するには「解除」又は「クライアント停止」の操作を行います。

すべて解除
「すべて解除」のボタンをオンにすると、タイマー動作時にすべての制御を解除し、コンピューターを自由に利用できるような状態に戻します。


ブロックキー

ブロックするキーの設定

ブロックしたいキーのチェックボックスをオンにすると、そのキーの操作は無効となります。
クライアントのOS種別や動作環境によっては、正常に機能しない場合もありますのでご注意ください。


プロセスの監視

プロセスの監視、制御

起動を監視するプロセスのリスト
起動操作を監視し、実行を禁止したいプロセスのリストです。

プロセス情報の取得
「プロセス情報の取得」ボタンをクリックすると、メイン画面の「詳細情報」のリストに表示されている内容をそのままコピーして、中央のリストに表示します。

終了を監視するプロセスのリスト
終了操作を監視し、自動的に再起動させたいプロセスのリストです。

再起動までの間隔
プロセスの終了を検知してから、そのプロセスを再起動させるまでの間隔を設定します。

操作ガイド
監視するプロセスの登録は「詳細情報」によって得られたプロセス情報を利用します。
プロセス以外の情報が表示されている場合、情報の取得はできません。

【起動を監視するプロセスの登録手順】
１．任意のクライアントにて、監視したいプロセス（アプリケーション）をすべて起動しておく。
２．メイン画面の「詳細情報」でクライアントにて起動中のプロセス情報を入手し、リストに表示させます。
３．「制御内容登録」ボタンをクリックして、制御内容登録画面を表示します。
４．「プロセス情報の取得」ボタンをクリックします。
５．中央のリストにプロセスデータが複写され表示されます。
６．リストから登録したいプロセスを選択します。（同時に複数の選択が可能です。）
７．「↑」ボタンをクリックすると「起動を監視するプロセス」のリストに内容がコピーされます。

リストに登録されている内容を削除したいときは、対象のプロセスを選択し、[Delete]キーを押してください。

【終了を監視するプロセスの登録手順】
１．任意のクライアントにて、監視したいプロセス（アプリケーション）をすべて起動しておく。
２．メイン画面の「詳細情報」でクライアントにて起動中のプロセス情報を入手し、リストに表示させます。
３．「制御内容登録」ボタンをクリックして、制御内容登録画面を表示します。
４．「プロセス情報の取得」ボタンをクリックします。
５．中央のリストにプロセスデータが複写され表示されます。
６．リストから登録したいプロセスを選択します。（同時に複数の選択が可能です。）
７．「↓」ボタンをクリックすると「終了を監視するプロセス」のリストに内容がコピーされます。

リストに登録されている内容を削除したいときは、対象のプロセスを選択し、[Delete]キーを押してください。

再起動までの間隔
登録されているプロセスの終了を検知してから、自動再起動させるまでの間隔を設定します。
通常、設定値は「0」でかまいませんが、アプリケーションによっては終了と同時に再起動させると不具合が発生するものがあります。
その場合は若干の間隔を設定した方がよいでしょう。
また、意図的に再起動までの時間を多く設定することも可能です。設定可能値は「0～999秒」となっています。

注意事項
「現在起動中のプロセス」には、システム関係のプロセスも含まれています。
不用意に監視プロセスに登録しますと、思わぬ不具合が発生することもありますので、十分にご注意ください。


パケットのブロック

遮断
デフォルトの動作を「遮断」とします。
すべてのパケットがブロックされます。

通過
デフォルトの動作を「通過」とします。
すべてのパケットが自由に通過できます。

除外アドレス入力ボックス
デフォルト動作から除外するIPアドレスを入力します。

除外アドレスリスト
登録されている除外IPアドレスをリスト表示します。

無条件通過アドレス入力ボックス
無条件に通過させたいIPアドレスを入力します。

無条件通過アドレスリスト
登録されている無条件通過IPアドレスをリスト表示します。

遮断ポート入力ボックス
遮断したいポート番号を入力します。

遮断ポートリスト
登録されている遮断ポートをリスト表示します。

操作ガイド
クライアントが通信することができる相手を制限したり、遮断するポートを設定できます。

IPアドレスによるフィルタリング
IPアドレスによって通信可能な対手を制限します。
基本動作モードとして、「遮断」と「通過」があります。
「遮断」を選択すると、デフォルトとしてすべてのIPアドレスに対するパケットがブロックされます。
「遮断」のモードで動作中、登録された除外アドレスに対するパケットは通過させます。

「通過」を選択すると、デフォルトとしてすべてのIPアドレスに対しパケットの通過が許可されます。
「通過」のモードで動作中、登録された除外アドレスに対するパケットはブロックされます。

除外アドレスの登録
基本動作モードで設定された動作から除外したいIPアドレスを登録します。（基本動作モードと逆の動作をします。）
IPアドレスの除外ルールは下記の規則に従います。
１．IPアドレスのすべてのオクテットに値が入力された場合は、そのIPアドレスだけが対象となります。
    入力例： 192.168.0.11 → 192.168.0.11のみに除外ルールが適用

２．IPアドレスの第４オクテットに 「0」 が入力された場合は、ネットマスクとして「255.255.255.0」が適用されます。
    入力例： 192.168.0.0 とした場合、192.168.0.1～192.168.0.255のIPアドレスに除外ルールが適用

登録可能なIPアドレス(ルール)は最大300データです。
コントローラーのIPアドレスはブロックの対象とすることはできません。
基本動作モードが「すべて通過」のとき、除外IPアドレスにコントローラーのアドレスが含まれている場合、その内容は無効となります。

登録は、IPアドレスを入力し、「追加」ボタンをクリックします。
リストに登録されている内容を削除したいときは、対象のIPアドレスを選択し、[Delete]キーを押します。

無条件通過アドレス
基本動作モードや除外アドレスの設定には関係なく、無条件に通過させたいアドレスを登録することが出来ます。
登録は、IPアドレスを入力し、「追加」ボタンをクリックします。
リストに登録されている内容を削除したいときは、対象のIPアドレスを選択し、[Delete]キーを押します。

遮断ポート
ポート番号によるパケットの遮断を行います。
アプリケーション別のフィルタリングが可能となります。
登録は、ポート番号を入力し、「追加」ボタンをクリックします。
リストに登録されている内容を削除したいときは、対象のポート番号を選択し、[Delete]キーを押します。

ご注意
この設定はクライアントのＯＳがWindows 2000, Windows XPの時にのみ有効です。(他のOSでは無効となります。)
パケットのブロックは、TCP,UDP,ICMPなどのすべてのTCP/IPパケットに対して機能します。


アクセスを制御するウィンドウ

ウィンドウを消去せず、アクセスのみ禁止する
「ウィンドウを消去せず、アクセスのみ禁止する」のチェックボックスをオンにすると、アクセス権のないウィンドウが表示されてもそのウィンドウを消去しません。
通常はオフの状態で利用します。

ウィンドウ情報の取得
「ウィンドウ情報の入手」ボタンをクリックすると、メイン画面の「詳細情報」のリストに表示されている内容をそのままコピーして、ウィンドウリストに表示します。

アクセスを許可
「アクセスを許可」のボタンをオンにすると、設定されたウィンドウに対してアクセスを許可します。

アクセスを拒否
「アクセスを拒否」のボタンをオンにすると、設定されたウィンドウに対してアクセスを拒否します。

アクセスを制御するウィンドウリスト
アクセスを制御（許可または拒否）するウィンドウのリストが表示されます。（最大30ウィンドウ）

操作ガイド
アクセスを制御するウィンドウの登録は「詳細情報」によって得られたウィンドウ情報を利用します。
ウィンドウ以外の情報が表示されている場合、情報の取得はできません。

【ウィンドウデータの登録手順】
１．任意のクライアントにて、制御したいアプリケーションをすべて起動しておく。
２．メイン画面の「詳細情報」でクライアントのデスクトップに表示されているウィンドウ情報を入手し、リストに表示させます。
３．「制御内容登録」ボタンをクリックして、制御内容登録画面を表示します。
４．「ウィンドウ情報の入手」ボタンをクリックします。
５．アクセスを制御するウィンドウのリストにウィンドウデータが複写され表示されます。（リスト内に表示されているデータがあった場合は上書きされます。）

リストに登録されている内容を削除したいときは、対象のデータを選択し、[Delete]キーを押してください。

補足説明
アプリケーションを起動しておくクライアントは、必ずしも制御対象のクライアントである必要はありません。
同じアプリケーション（実行ファイル）であれば、どのクライアントのものでも共通に機能します。

ウィンドウの制御方法には二種類の動作モードがあります。
１．【アクセスを許可】

利用できるアプリケーションを少数に制限したい場合に利用するモードです。
登録されているウィンドウ（アプリケーション）に対してのみアクセス権を与えます。その他のウィンドウへのアクセスは一切できません。
登録されているもの以外のウィンドウ（アプリケーション）を開こうとすると、直ちにそのウィンドウは消去されます。
ただし、ウィンドウ（アプリケーション）の種別によっては自動消去されないことがあります。その場合は、マウスポインタが該当のウインドウ上に移動した瞬間に消去されます。

２．【アクセスを拒否】
１．の【アクセスを許可】とは逆の制御動作を行うモードです。
限られたウィンドウ（アプリケーション）だけ利用することを禁止したいときに利用するモードです。
登録されているウィンドウ（アプリケーション）にのみアクセス権を与えず、他のウィンドウに対しては自由にアクセスできます。

すべてのウィンドウに対してアクセス権を与えるには、リストからウィンドウデータをすべて削除し、【アクセスを拒否】のモードで動作させます。
この設定は、基本的にウィンドウには制限を一切掛けないで、「基本制御機能」や「ブロックするキーの設定」の機能のみ利用したいときに有効です。
（解除の状態では「基本制御機能」や「ブロックするキーの設定」の機能は働きません。）

「ウィンドウ情報の入手」を行ったとき、リストには「Program Manager,Progman」というデータが表示されます。
これはWindowsのデスクトップを意味します。このウィンドウデータに対してアクセス権が与えられると、デスクトップ上のアイコン（ショートカット）にアクセスすることが可能となります。

クライアント登録では自己のアドレスも登録することができますので、コントローラーパソコンでアプリケーションを起動し、ウィンドウデータの取得を行うこともできます。
クライアントからウィンドウデータの取得が困難な場合などに活用できる手法です。

ご注意
制御したいアプリケーションのトップウィンドウ（アプリケーション起動時に、最初に表示されるウィンドウ）だけを登録した場合、そのアプリケーションの実行中に表示されるすべてのウィンドウに対してアクセス制御が有効となる保証はありません。
アプリケーションの種類によっては、複数のウィンドウ（別プロセス）を登録しないと有効に制御できないものも存在します。
例えば、インターネットエクスプローラー（IE）からメールアプリケーションが自動起動される場合などがこれに当たります。
本機能は「アクセスを検知するウィンドウ」の機能とは独立して動作します。


ワークウィンドウ

↑
「↑」をクリックすると、ワークウィンドウリストボックスで選択されているウィンドウデータを上側のアクセスを制限するウィンドウリストボックスにコピーします。

↓
「↓」をクリックすると、上側のアクセスを制限するウィンドウリストボックスで選択されているウィンドウデータをワークウィンドウリストボックスにコピーします。

ワークウィンドウリストボックス
アクセスを制御するウィンドウのリストが表示されます。（最大200ウィンドウ）

操作ガイド
アクセスを制御するウィンドウのデータは９種類の制御ファイルにそれぞれ記録されていますが、それとは別に編集用のウィンドウデータをストックしておくことができます。
「アクセスを制御するウィンドウ」のリストボックスに表示されているデータの中から任意のウィンドウを選択し（複数選択可）、「↓」ボタンをクリックします。
「ワークウィンドウ」のリストボックスにウィンドウデータが追加表示されます。このワークウィンドウには最大200のウィンドウデータを保存することができます。

「ワークウィンドウ」から「アクセスを制御するウィンドウ」にデータを複写するには上記と逆の操作を行います。（「↑」ボタンを利用する。）

リストに登録されている内容を削除したいときは、対象データを選択し、[Delete]キーを押してください。


アクセスを検知するウィンドウ

ウィンドウキャプション入力ボックス(上段)
アクセスを検知したいウィンドウのキャプションを入力します。

リストボックス（下段）
登録されているウィンドウキャプションをリスト表示します。

追加
「追加」ボタンをクリックすると、ウィンドウキャプション入力ボックスに入力された内容をリストボックスに追加登録します。

ウィンドウを消去する
「ウィンドウを消去する」のチェックボックスをオンにすると、登録されているウィンドウに対してアクセスが行われたとき、そのウィンドウを消去します。

画像を取得する
「画像を取得する」のチェックボックスをオンにすると、登録されているウィンドウに対してアクセスが行われたとき、デスクトップ画面をキャプチャーしコントローラーに送信します。

メッセージ文
クライアントにて登録されているウィンドウに対してアクセスが行われたとき、表示させたいメッセージ分を入力します。

操作ガイド
入力ボックス（上段）には、アクセスを検知したいウィンドウのキャプション（タイトル）の文字列を入力します。
入力後「追加」ボタンをクリックすると、リストに追加されます。このリストには最大100のキャプションデータを保存することができます。
アクセスしたウィンドウのキャプション（タイトル）が指定した文字列と完全に一致しなくても、その一部に文字列が含まれていれば検知対象となります。（部分一致）
文字列中の英字は、大文字小文字の比較を行いません。
一方、文字列をダブルクォーテーション「"」で囲むことにより、完全一致による検知を行うことも出来ます。
      入力例： "コンピュータの管理"

クライアントにてアクセスが検知された場合、コントローラーに対してウィンドウ情報を送信します。
ウィンドウ情報はコントローラーの詳細情報欄にその他の情報とともに表示されます。
クライアントパソコンとネットワークに負荷を掛けないため、規定値ではデスクトップのキャプチャー画像は表示されません。
キャプチャー画像を同時に表示させたい場合は、「画像を所得する」のチェックボックスをオンにしてください。

クライアントにてアクセスが検知されたとき、そのウィンドウを自動消去し利用を禁止することができます。
自動消去するには、「ウィンドウを消去する」のチェックボックスをオンにしてください。
消去されるウィンドウがアプリケーションのトップウィンドウであった場合、そのアプリケーションは終了することになります。

リストに登録されている内容を削除したいときは、対象のデータを選択し、[Delete]キーを押してください。

クライアントにてアクセスが検知されたとき、警告文など任意のメッセージを表示させることができます。
表示させたいメッセージは、メッセージ入力ボックスに入力します。
メッセージを表示させたくないときは、入力ボックスを空欄にします。

ご注意
本機能は「アクセスを制御するウィンドウ」の機能とは独立して動作します。
本機能を作動させるには、「制御開始」ではなく「検知」ボタンにて行います。


サンプル制御ファイル

コントローラーのセットアップ直後には、下記の２つの制御ファイルがサンプルとして登録されています。※1

１．「通信ブロック」・・・すべてのTCP/IPによる通信を阻止する設定です。
    インターネットの利用はだけでなく、サーバーや他のパソコンとの通信はすべてブロックされます。
    ただし、コントローラーとの通信は除外されます。
    通信のブロックを行うことができるのは、クライアントのOSがWindows2000およびWindowsXPの場合だけです。

２．「インターネット」・・・使用者はブラウザおよびメールソフトのみ利用することが可能な設定です。
    「InternetExplorer」と「Outlook」のみ利用可能にします。その他のアプリケーションが起動されても、利用することは出来ません。
    システムのシャットダウンやリブートなどのＯＳ操作も禁止します。「アプリ起動」により両アプリケーションをリモート起動できます。

３．「セキュリティー」・・・システム（OS）の変更処理などを一切行うことが出来なくする設定です。
    システム設定に関するほとんどの機能を利用不可にします。システムのシャットダウンなども出来ず、比較的セキュリティーレベルの高い設定です。
    より磐石な設定にするには、「レジストリ設定」を併用することが望まれます。
    同じような項目がいくつかあるのは、複数のOSに対応させるためです。（OSによってウィンドウタイトルが微妙に異なります。）

※1
ご利用になるOS及びアプリケーションのバージョンや、システムの状態によっては、若干の設定変更を行う必要があります。

制御ファイルの作成に関する チュートリアル があります。参考にしてください。


利用制限設定の手引き

利用制限設定の手引き（チュートリアル）

クライアントパソコンで利用することが出来るアプリケーションを限定するための設定手順を下記に例示します。

大まかな設定手順は下記のような流れになります。

①コントローラーで制御ファイルを作成する。

②作成した制御ファイルをクライアントに転送する。

③制御を開始する。

設定例の要件
クライアントパソコンでインターネットエクスプローラー（IE）以外の利用が出来ないようにする。

設定手順
・クライアントパソコンでインターネットエクスプローラーを起動し、起動直後の状態にしておいてください。
  表示されているページは何でもかまいません。
  この時、他に起動しているアプリケーションがあれば、すべて終了してください。

・Guardianのコントローラーを起動してください。

・クライアントリストから対象のクライアントを選択し、「詳細情報」ボタンをクリックしてください。

  詳細情報プロックが下図のようになります。

・

・コントローラーの「制御内容登録」ボタンをクリックします。
  下図のような新しいウィンドウが開きます。

・画面右上の「アクセスを制御するウィンドウ」のブロックにある「ウィンドウ情報の入手」ボタンをクリックします。
  下図のような状態になります。

・画面右中の「基本制御機能の設定」を下図のように設定します。

・画面左上の「制御ファイル」ブロックにて、リスト内の「FILE1」を選択し、ファイル名の入力欄に「IE」と入力します。
  次に「保存」ボタンをクリックし、ファイルに保存します。

・コントローラーのメイン画面に戻ります。
  制御ファイルのグループが下図のようになっていることを確認します。

・クライアントリストから対象のクライアントを選択します。

・「制御ファイル」のリストから「IE」を選択し、「制御ファイル転送」ボタンをクリックします

・クライアントリストの「制御内容」欄に「IE」と表示されます。
  これで制御ファイルがクライアントに転送されました。
  「制御開始」ボタンをクリックすれば、クライアントではインターネットエクスプローラー以外のアプリケーションは利用できなくなります。


制御ファイル転送

クライアントにて実行される制御の内容はすべてコントローラーから送られます。制御内容の設定は「制御内容登録」にて行います。
コントローラーは9種類の設定ファイルを管理できます。一方クライアントでは、制御内容を記録した設定ファイルを１セットのみ保存管理しています。
コントローラーから制御開始のコマンドが送られると、保存されている設定ファイルを読み込み、その内容に従って制御を実施します。
制御内容を変更する必要が生じたときは、コントローラーから新しい設定内容（制御ファイル）を送ります。

まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括して命令を送ります。

次に制御ファイルリストボックス内のファイルを選択し、「制御ファイル転送」ボタンをクリックします。
選択した設定内容はクライアントに送られ、クライアントではその内容をいったん自己のディスクに保存します。
このときクライアントリストボックスの制御内容欄には設定したファイル名が表示されます。


ウェイクアップ

クライアントマシンが「Wake On LAN」をサポートしている場合、そのマシンに対して電源投入の指示を送ることができます。

まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括して命令を送ります。
次に「ウェイクアップ」ボタンをクリックすると、クライアントでは電源が投入されます。

WOL(Wake On LAN)について
Guardianではクライアントに対して電源投入の指示を送る際に[MagicPacket]を利用しています。
クライアントマシンのネットワークカード（NIC）に割り振られている固有の番号であるMACアドレスを利用してマシンの識別を行います。
MACアドレスはコントローラーがクライアントと最初に通信を行ったときに自動的に取得し、クライアントリストボックスのMACアドレス欄に表示します。
よってMACアドレス欄が空欄のクライアントに対してはWOLの指示を送ることができません。
またWOLはマシンとネットワークカードの相性などにより、正常に動作しない場合があります。

クライアントマシンがWOLをサポートしているにもかかわらず（メーカーなどによる動作保証）、うまく動作しない場合はBIOSの設定を確認してください。
BIOSの設定でWOLが有効になっていないと機能しません。
また完全に電源が断たれた状態からは（電源ユニットへの通電が一度でも断たれると）電源投入ができない場合があります。
このようなときは一度手動で電源の投入を行いWindowsを起動してから、電源切断を行うことで次回以降、WOLが機能するようになります。


リブート、シャットダウン、ログオフ

リブート

まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括して命令を送ります。
次に「リブート」ボタンをクリックすると、クライアントではシステムのリブート（再起動）の動作が行われます。
このとき、編集途中のファイルなどがあった場合、ファイル保存の有無を問い合わせるダイアログボックスがクライアント側で表示されます。
このダイアログボックスにはコントローラー側で対応、処理することはできません。
クライアント側に一切ダイアログボックスを表示させずに、強制的にシステムをリブートするには「強制実行」のチェックボックスをチェックしてから「リブート」ボタンをクリックしてください。クライアントは直ちにリブート動作に移ります。
このときボックスの状態欄には「リブート」のメッセージが表示され、正常にリブート操作が行われたことを知らせます。
また開始時刻欄にはリブートされた時刻が表示されます。

シャットダウン

まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括して命令を送ります。
次に「シャットダウン」ボタンをクリックすると、クライアントではシステムのシャットダウンの動作が行われます。
このとき、編集途中のファイルなどがあった場合、ファイル保存の有無を問い合わせるダイアログボックスがクライアント側で表示されます。
このダイアログボックスにはコントローラー側で対応、処理することはできません。
クライアント側に一切ダイアログボックスを表示させずに、強制的にシステムをシャットダウンするには「強制実行」のチェックボックスをチェックしてから「シャットダウン」ボタンをクリックしてください。クライアントは直ちにシャットダウン動作に移ります。クライアント側が電源の自動切断機能を搭載した機種であった場合には、自動的に電源の切断も行います。
このときボックスの状態欄には「シャットダウン」のメッセージが表示され、正常にシャットダウン操作が行われたことを知らせます。
また開始時刻欄にはシャットダウンされた時刻が表示されます。

ログオフ

まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括して命令を送ります。
次に「ログオフ」ボタンをクリックすると、クライアントではシステムのログオフの動作が行われます。
このとき、編集途中のファイルなどがあった場合、ファイル保存の有無を問い合わせるダイアログボックスがクライアント側で表示されます。
このダイアログボックスにはコントローラー側で対応、処理することはできません。
クライアント側に一切ダイアログボックスを表示させずに、強制的にシステムをログオフするには「強制実行」のチェックボックスをチェックしてから「ログオフ」ボタンをクリックしてください。クライアントは直ちにログオフ動作に移ります。
このときボックスの状態欄には「ログオフ」のメッセージが表示され、正常にログオフ操作が行われたことを知らせます。
また開始時刻欄にはログオフされた時刻が表示されます。

ご注意
クライアント上のOSの種別や動作環境によっては、上記のコマンドが正常に機能しない場合がありますのでご注意ください。


ログオン

クライアントがログオフの状態にあるとき、そのクライアントに対してログオン命令を送ることができます。
ログオン操作に必要な「ユーザー名」、「パスワード」、「ドメイン」の情報は、「ログオン登録」にて事前に登録しておきます。

まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括して命令を送ります。
次に「ログオン」ボタンをクリックすると、下記のダイアログボックスが表示されます。

ユーザー名
ログオンユーザー名を入力します。

パスワード
ログオンパスワードを入力します。
入力されたパスワードは直ちに暗号化されて管理されます。

ドメイン
ドメイン名を入力します。

【ログオン実行】
「ログオン実行のみ」ボタンをクリックすると、クライアントではログオン動作を開始します。
ログオンが完了すると、リスト内のユーザー名欄にログオン情報として指定したユーザー名が表示されます。

【登録のみ】
「登録のみ」ボタンをクリックすると、設定内容が保存されますが、クライアントにコマンドは送信されません。

ログオン前に一度リブートする
チェックをオンにして「ログオン実行」を行うと、ログオン前にクライアントを一度再起動します。
Windows Vistaのクライアントは、本チェックをオンにして「ログオン実行」する必要があります。(直接ログオンはできません。)

本動作はクライアントマシンのレジストリに自動ログオンの設定を行うことで実行されます。
クライアントは「ログオン」の命令を受け取った後、一度リブートの動作を行い、その後指定されたログオン情報で自動ログオンされます。
よって「ログオン」の指示後、再度通信が確立するまでかなりの時間を要しますのでご注意ください。
クライアントではレジスリに登録されたログオン情報を元にログオン処理を行いますが、一度ログオンが完了しますとレジストリの内容は「ログオン」の命令を受け取る前の状態に自動復帰するようになっています。
本コマンドは管理者がメンテナンスの目的で利用することを前提に用意されているものです。
いつも特定のユーザー名で自動ログオンするように設定したい場合は、レジストリ変更の「自動ログオン」をご利用ください。


ﾘﾓｰﾄｺﾝﾄﾛｰﾙ

リモートコントロール

Guardainに内蔵された簡易リモコン機能を利用してクライアントのリモートコントロールを行うことが出来ます。
※内蔵リモコン機能には下記のような制限があります。
  ・「変換」、「無変換」キーなどの日本語入力は行えません。
  ・クライアントのウィンドウ内容の一部が表示されないことがあります。
  ・ログオン状態の時のみ利用できます。
  ・動作はログオンユーザーの権限に依存します。

クライアントにおいて、「リモート デスクトップ」や「WinVNC」が利用可能な場合、コントローラーからその動作を制御することが可能です。
クライアントを選択し、「ﾘﾓｰﾄｺﾝﾄﾛｰﾙ」ボタンをクリックするだけで、クライアントパソコンの遠隔操作が可能となります。

リモートコントロールを行うには、まず対象となるクライアントを選択します。（キーコントロールのみ複数選択可）
次に「ﾘﾓｰﾄｺﾝﾄﾛｰﾙ」ボタンをクリックすると、下記のダイアログボックスが表示されます。

利用するリモートコントロールソフトを選択します。
「WinVNC」の場合、初回のみ「vncviewer.exe」の位置をフルバスで指定する必要があります。
「接続」ボタンをクリックすると、それぞれのリモートコントロールソフトが起動します。
「リモート デスクトップ」の場合はログオン手続きが必要となります。
「WinVNC」の場合は直ちにクライアントの画面が表示されます。

上記のダイアログボックスを表示することなく、直接リモートコントロールソフトを起動させることができます。
[Shift]キーを押しながら「リモートコントロール」ボタンをクリックすると、直前に選択されたリモートコントロールソフトを直接起動します。

リモートコントロールソフトの準備
内蔵リモコン以外のリモートコントロールを行うには、対象となるクライアントパソコンにて「リモート　デスクトップ」または「WinVNC」が利用可能な状態になっている必要があります。

【WinVNC】
AT&T Laboratories Cambridge が提供しているフリーのリモートコントロールソフトです。
OSプラットフォームに依存しないソフトで、世界中に普及しているものです。
本ソフトウェアは日本国内でも企業、公共機関、個人を問わず多くの方が利用されており、日本語化パッチもあるようです。下記のサイトから入手が可能です。
http://www.realvnc.com/

「WinVNC」のインストール、セットアップ方法については、上記サイトをご参照ください。

【リモートデスクトップ】
クライアント側の設定は「コントロールパネル」から「システム」を開き、「リモート」タブにて行います。
コントローラー側の設定はご利用のOSにより異なります。詳しくは「リモート デスクトップ」のヘルプ（OS添付）をご参照ください。

キーコントロール
コントローラーからクライアントに対してキーボード入力操作を行うことができます。
本機能は複数のクライアントに対して同時に実行することが可能です。
「キーコントロール」ボタンをクリックすると、下記のウィンドウが表示されます。

このウィンドウが表示されていて且つアクティブ状態の時、コントローラーのキーボードから入力されたキー情報はクライアントに対して送信されます。
このときコントローラーパソコンは、押下されたキー情報を受け取ることはありません。(反応しません)
キー送信を行いたくない場合は、「キーコントロール」のウィンドウを非アクティブ状態にするか、「閉じる」ボタンを押してウィンドウそのものを閉じます。

注意事項
・キー送信は[Shift]、[Ctrl]、[Alt]を組み合わせた入力が可能です。
・キーを長押しすることによる連続入力は無効です。
・クライアント側においてキー入力の対象となるのは、フォーカスを持ったウィンドウおよびコントロールです。
・同時に複数のクライアントに対してキー送信を行う場合は、各クライアントのフォーカス状態に配慮する必要があります。
・送信することができないキーとしては次のようなものがあります。(日本語入力は行えません)
  [Windowsキー]、[変換キー]、[無変換キー]、[ひらがなキー]、「Ctrl + Alt + Delete」
  (クライアントおよびコントローラーのシステム状態などによっては上記以外のキーも無効となることがあります。)


アプリ起動

クライアントのディスク内に格納されているアプリケーションや、バッチファイルをリモートで起動、実行させることができます。
アプリケーションのリモート起動は「ワンライン送信」でも可能ですが、本機能を利用して行うと、アプリケーションの登録や再利用が簡単に行えます。

まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括して命令が送信されます。
次に「アプリ起動」ボタンをクリックします。下記のダイアログボックスが表示されます。

起動するアプリケーションをフルパスで「実行ファイル」入力欄に入力します。
「アプリケーション名」は単なるメモ的な性質のもので、入力は任意です。

【実行権限】
「実行権限を指定して起動する。」のチェックをオンにして実行すると、ログオンしているユーザー権限とは異なる権限でアプリケーションを起動することができます。
実行に必要なアカウント情報を「ユーザー名」、「パスワード」、「ドメイン名」に入力します。

【起動実行】
「起動実行」をクリックすると、直ちにクライアントでは入力された内容に基づいて、アプリケーションが起動します。
入力した内容は後の利用のため、リストに自動追加されます。
リスト内の行をクリックすると、その内容が上部の「実行ファイル」入力欄にコピーされ、再利用可能です。

【追加登録】
「追加登録」ボタンをクリックすると、入力された内容をリストに追加しますが、クライアントにコマンドは送信しません。

【アプリ取得】
「アプリ取得」ボタンをクリックすると、メイン画面の詳細情報リストに表示されている内容が下段のリストにコピーされます。
ただし、リストの内容は「プロセス情報」になっている必要があります。
リスト内の行をクリックすると、その内容が上部の「実行ファイル」入力欄にコピーされます。

【保存終了】
リストに表示された内容を保存し、メイン画面に戻ります。

実行権限を指定しない場合、起動するアプリケーションはログオンしているユーザーの権限で実行されます。
プログラムが起動したかどうかの確認は、「詳細情報」で行う事ができます。


レジストリ変更

クライアントに対してレジストリの登録、削除などの操作を実行することができます。
クライアントのOSがWindows Vistaの場合の動作は保証されません。（サポート対象外）

まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括して命令を送ります。
次に「レジストリ変更」ボタンをクリックします。下記のダイアログボックスが表示されます。

レジストリの設定はそれぞれ分野別のタブ画面に分かれています。
「変更実行」ボタンをクリックすると、それぞれのタブ画面に設定されている内容でレジストリの変更が行われます。
「保存終了」ボタンをクリックすると、それぞれのタブ画面に設定されている内容を一時的に保存し、メイン画面に戻ります。

システム
システムの基本環境に関する設定を行う画面です。

ネットワーク
ネットワーク関連の設定、システム起動時に自動ログオンさせるための設定を行う画面です。

インターネットエクスプローラー
マイクロソフトのインターネットエクスプローラー（IE）の利用環境に関する設定を行う画面です。

手動設定
任意のレジストリキー及び値の設定を行うための画面です。

操作ガイド
レジストリの設定内容は一時的にコントローラー側の管理ファイルに保存されます。
一度コントローラーを終了しますと、次回起動時には選択した設定項目がすべて「更新しない」に初期化されます。
これは誤操作を防止するためです。ご注意ください。（入力した文字データは初期化されません。）

変更されたレジストリは設定後直ちに有効となるものと、再起動を要するものがあります。
安全かつ確実な動作の為にも、変更後に一度クライアントを 「リブート」する事をお勧めします。

クライアントのOSがWindows 2000, Windows XPの場合の動作
ログオンしているユーザーの持つレジストリに対するアクセス権限に関係なく機能します。
設定項目は現在ログオンしているユーザーに対してのみ有効なものと、すべてのユーザーに対して共通に有効となるものがあります。（"HKEY_CURRENT_USER" に対する変更がこれに当たります。）
「すべてのユーザーに適用させる。」のチェックをオンにしてレジストリの変更を行うと、クライアントに登録されている全ユーザーに対してすべてのキー設定が有効となります。
「すべてのユーザーに適用させる。」のチェックがオンの場合、ログオフの状態でもすべてのキーに対してレジストリ変更は有効に機能します。

ご注意
レジストリの操作は慎重に行ってください。特に「手動設定」の機能をご利用になる場合は注意が必要です。
レジストリに関する十分な知識のない方が不用意に変更などを行うと、最悪の場合システムが起動しなくなる恐れがあります。
特に設定内容を複数のクライアントに適用する場合は、事前に１台のクライアントで動作テストを行うなどしてから実施していただくことを強くお勧めします。
レジストリのバックアップを取っておくと安心です。

クライアントのOSがWindows Vistaの場合の動作は保証されません。（サポート対象外）


システム

システム(OS)に機能制限を加えるレジストリ設定を行います。
各機能を有効にする場合は「Yes」を選択してください。
Windowsの初期設定値に戻したいときは、すべての項目の「No」を選択して登録を行ってください。（各項目とも「No」がWindowsのデフォルト値となっています。）

スタートメニューから「シャットダウン」を消去
スタートメニューからシャットダウンを選択できなくなります。

コントロールパネル、プリンタなどの設定を禁止する
コントロールパネル、プリンタ、ネットワーク(NT,2000,XP)などの設定を禁止します。
クライアントのOS種別により、制限される内容が異なるので注意が必要です。

Windowsの終了時に設定内容を保存しない
Windowsが終了するときに行うデスクトップ環境の保存を無効化します。システムの起動時にいつも同じデスクトップ画面（基準画面）が表示されるようになります。
「レジストリの変更」ボタンがクリックされた時点でクライアントに表示されているデスクトップ画面が基準画面となります。
設定のタイミングを誤りますと、意図しないデスクトップ画面が毎回、起動時に表示されるようになります。

タスクバーのコンテキストメニューを無効にする
タスクバー上での右クリックが無効となり、コンテキストメニューが表示されなくなります。

デスクトップ上の右クリックを無効にする
デスクトップ上での右クリックが無効となり、様々な機能の利用が出来なくなります。

レジストリエディタを使用禁止にする
ユーザーがレジストリエディタを使用することを禁止します。

フォルダオプションを無効にする
エクスプローラーの「フォルダオプション」の利用が出来なくなります。

「コンピュータのロック」を無効にする（2000,XP）
ユーザーがコンピュータをロックすることが出来なくなります。

「パスワードの変更」を無効にする（2000,XP）
ユーザーがパスワードの変更を行うことが出来なくなります。

タスクマネージャを無効にする(2000,XP)
タスクマネージャの利用を禁止し、プロセスの強制終了などが出来なくなります。

スタートメニューから「最近使ったファイル｣を消去
ファイルの利用履歴へのアクセスが出来なくなります。

スタートメニューから「検索」消去
「検索」をスタートメニューから選択できないようにします。
使用者が不用意にディスクの内容を調査することを防ぎます。

スタートメニューから「ファイル名を指定して実行」を消去
「ファイル名を指定して実行」をスタートメニューから選択できないようにします。
外部プログラムなどを簡単に起動できないようにします。

スタートメニューから「タスクバーと[スタート]メニュー」を消去
｢タスクバーと[スタート]メニュー｣をスタートメニューから選択できないようにします。

スタートメニューから共通の「プログラム」を消去
全ユーザーに共通の｢プログラム」を表示しません。

スタートメニューから「コントロールパネル」を消去
｢コントロールパネル｣をスタートメニューから選択できないようにします。

｢画面のプロパティー｣を無効化
「画面のプロパティー」を利用できなくし、表示関連の変更操作を禁止します。

アクティブデスクトップを無効にする
アクティブデスクトップの利用を禁止します。

デスクトップから「マイネットワーク」を消去
デスクトップ上の「マイネットワーク」アイコンを消去する

デスクトップ上のすべてのアイテムを消去
デスクトップ上にあるショートカットなどをすべて消去します。

エクスプローラーからドライブを消去
エクスプローラーやマイコンピュータに表示されるドライブをすべて消去します。

壁紙の変更を禁止する
利用者が壁紙を変更することを禁止します。


ネットワーク

ネットワークに関連したレジストリ変更を行います。
各機能を有効にする場合は「Yes」を選択してください。
Windowsの初期設定値に戻したいときは、すべての項目の「No」を選択して登録を行ってください。（各項目とも「No」がWindowsのデフォルト値となっています。）

デフォルトの管理共有を無効にする(2000,XP)
システムによってルートディレクトリに対してデフォルトで設定される管理共有を無効にします。

マイネットワークからコンピュータを隠す(2000,XP)
マイネットワークに他のコンピュータを表示しません。

スタートメニューから「ネットワークとダイヤルアップ接続」を隠す(2000,XP)
スタートメニューから「ネットワークとダイヤルアップ接続」を消去し、アクセスできなくします。

ネットワークドライブの接続、切断を禁止する
ネットワークドライブへの接続や切断操作が行えなくなります。

マイネットワークの「ネットワーク全体」を表示しない
マイネットワーク内の「ネットワーク全体」を消去し、ブラウジングできなくします。

マイネットワークにワークグループを表示しない
マイネットワーク内にワークグループの内容を表示しません。

最後にログオンしたユーザー名を表示しない
ログオン時に前回ログオンしたユーザー名の表示を行いません。

スタートメニューから「ログオフ」を消去
スタートメニューから「ログオフ」を消去します。

自動ログオン

ユーザー名
ログオンユーザー名を入力します。

パスワード
ログオンパスワードを入力します。
入力されたパスワードは直ちに暗号化されて管理されます。

ドメイン
ドメイン名を入力します。

操作ガイド
設定された自動ログオンに関するデータは「レジストリ変更」によってクライアントのレジストリに登録されます。
クライアントのレジストリに登録されている内容を変更したくないときは「更新しない」を選択してください。
また各入力データが空欄の場合、そのデータの更新は行われません。データ内容はそのままに自動ログオンの設定、解除のみ行いたいときにご利用ください。

本機能の「自動ログオン」はメイン画面にある「ログオン」とは動作が異なります。本機能による自動ログオンの設定は、次に変更指示が無い限り永久に継続します。


インターネットエクスプローラー

インターネットエクスプローラー (IE6のみ)

マイクロソフトのインターネットエクスプローラーに関する設定を行います。

ファイルのダウンロードを禁止
ブラウザ上でファイルのダウンロードが行えなくなります。

オートコンプリートを無効にする
セキュリティー上、オートコンプリートを無効にします。

ブラウザの終了を禁止
IEそのものの終了が出来なくなります。

コンテキストメニュー（右クリック）を無効にする
コンテンツ上の右クリックを禁止することにより、セキュリティーを高めます。

[ツール] - [インターネットオプション]を無効にする
IEの動作環境を設定、変更することが出来なくなります。

[ファイル] - [名前を付けて保存]を無効にする
ページの保存が出来なくなります。

お気に入りを無効にする
「お気に入り」の利用が出来なくなります。

[ファイル] - [新規作成] - [ウィンドウ]を無効にする
新しいブラウザのウィンドウを開くことが出来なくなります。

IEのアップデートを無効にする
IEの自動アップデートチェックが無効になります。

検索(F3キー)を無効にする
検索の機能が無効になります。

全画面表示(F11キー)を無効にする
全画面表示の操作が出来なくなります。

アドレスバーの非表示
アドレスバーが表示されません。

ツールバーの非表示
ツールバーが表示されません。

リンクバーの非表示
リンクバーが表示されません。

ツールバーのユーザー設定を禁止
ツールバーの設定が出来なくなります。

ツールバーの選択を禁止
ツールバーの表示、非表示操作が出来なくなります。

サウンドの再生を無効にする
サウンドの再生が出来なくなります。

デスクトップからInternet Explorerのアイコンを消去
デスクトップ上の「Internet Explorer」アイコンを消去します。

[ツール] - [インターネットオプション]

インターネットオプション内の各機能を無効にすることが出来ます。
各項目先頭の「タブ全体」を「無効」にすると、タブそのものが表示されなくなります。


手動設定

クライアントのレジストリに関して、以下の設定機能を提供します。

・キーの追加作成
・キーの削除
・値の追加作成
・値の削除
・値の修正

設定可能なルートキー（トップキー）は以下の５つです。

HKEY_CLASSES_ROOT
HKEY_CURRENT_USER
HKEY_LOCAL_MACHINE
HKEY_USERS
HKEY_CURRENT_CONFIG

キー
設定するキーの名前を入力します。　（入力例： Software\Microsoft\Windows\CurrentVersion\policies\Explorer)

文字列
設定する値が文字列の場合に選択します。

DWORD
設定する値がDWORDの場合に選択します。

値の名前
設定する値の名前を入力します。　　（入力例： NoSecCPL)

値のデータ
設定する値を入力します。値のタイプは「文字列」と「DWORD」の二種類をサポートしています。　（入力例： 1）
値のタイプが「DWORD」の場合は必ず１０進数で入力してください。
タイプとしてDWORDが選択されている時に数値以外のデータを入力すると設定されるデータは 「0」になります。

操作ガイド
キーの追加方法
１．「追加、修正」のラジオボタンをクリックする。
２．ルートキーを選択する。
３．「キー」を入力する。
４．「文字列」及び「DWORD」の選択はどちらでもよい。
５．「値の名前」及び「値のデータ」欄は必ず空欄とする。
６．「保存終了」をクリックしてコントローラーメイン画面に戻る。
７．クライアントを選択して「レジストリ変更」をクリックする。

値の追加方法
１．「追加、修正」のラジオボタンをクリックする。
２．ルートキーを選択する。
３．｢キー」を入力する。
４．「文字列」または「DWORD」を選択する。
５．「値の名前｣を入力する。
６．「値のデータ」を入力する。（空欄でもよい）
７．「保存終了」をクリックしてコントローラーメイン画面に戻る。
８．クライアントを選択して「レジストリ変更」をクリックする。
※値の追加時に指定したキーが存在しない場合、キーも自動的に作成されます。

キーの削除方法
１．「削除」のラジオボタンをクリックする。
２．ルートキーを選択する。
３．「キー」を入力する。
４．「文字列」及び「DWORD」の選択はどちらでもよい。
５．「値の名前」及び「値のデータ」欄は必ず空欄とする。
６．「保存終了」をクリックしてコントローラーメイン画面に戻る。
７．クライアントを選択して「レジストリ変更」をクリックする。

値の削除方法
１．「削除」のラジオボタンをクリックする。
２．ルートキーを選択する。
３．「キー」を入力する。
４．「文字列」及び「DWORD」の選択はどちらでもよい。
５．「値の名前」を入力する。
６．「値のデータ」欄は空欄とする。
７．「保存終了」をクリックしてコントローラーメイン画面に戻る。
８．クライアントを選択して「レジストリ変更」をクリックする。

値の修正方法
１．「追加、修正」のラジオボタンをクリックする。
２．ルートキーを選択する。
３．「キー」を入力する。
４．「文字列」または「DWORD」を選択する。
５．「値の名前」を入力する。
６．新しい「値のデータ」を入力する。（空欄にすると値のデータは消去される）
７．「保存終了」をクリックしてコントローラーメイン画面に戻る。
８．クライアントを選択して「レジストリ変更」をクリックする。

キー及び値の名前変更はできませんのでご注意ください。
「追加、修正」において指定したキーや値が存在しない場合は、自動的に作成される仕様となっています。


ネットワーク設定

クライアントパソコンのネットワーク設定を行ったり、Windowsファイアウォールの例外設定を自動化できます。
OSがWindows Vistaの場合、本機能は利用できません。

ネットワークの設定、変更を行う事が出来る内容は以下のものです。
・IPアドレス
・サブネットマスク
・デフォルトゲートウェイ
・DNSサーバー（優先、代替）
・DHCP利用
・コンピューター名（NetBIOS名、DNSホスト名）

設定を行うには、「ネットワーク設定を行う」ボタンをクリックします。

ネットワーク設定画面が表示されます。ネットワーク設定はコントローラーのメインプログラムとは別プロセスとして独立して動作します。
ネットワーク設定画面を表示中でも、いつでもコントローラーのメイン画面操作が可能です。

入力ボックス・・・・・・・・・・・クライアントに送信するネットワークに関する各種設定値を入力します。
「終了」ボタン・・・・・・・・・・ネットワーク設定を終了します。
「Identify」ボタン・・・・・・・クライアントパソコンに、現在の設定値を確認するためのダイアログボックスを表示します。
「復帰」ボタン・・・・・・・・・・このボタンをクリックすることにより、いつでも設定した内容をクライアントが起動したときの初期状態に戻すことが出来ます。（アンドゥ機能）
「更新」ボタン・・・・・・・・・・各入力ボックスにセットされた値を指定されたクライアントに送信し、ネットワーク設定の更新を行います。
「リブート」ボタン・・・・・・・・更新された内容を有効にするために、クライアントパソコンを再起動（リブート）します。
「リフレッシュ」ボタン・・・・・クライアントリストに表示されている内容を最新の状態に更新します。
クライアントリスト・・・・・・・・この時リスト内に表示されるのは、コントローラーメイン画面のクライアントリストに登録されているクライアントすべてではなく、ネットワーク設定画面が表示された時点で起動中のクライアントになります。リストに表示される各クライアントの表示順序を変更（ソート）することができます。ソートするには、変更したいカラムタイトルをクリックしてください。同一カラムをクリックするごとに、昇順、降順にソートされます。
リスト内のクライアントは、[Ctrl]キーと[Shift]キーを組み合わせたWindows標準の方法で複数選択することができます。また、リスト内をダブルクリックすると、表示されているクライアントすべてが選択状態となります。
リスト内の任意のクライアントを右クリックすると、現在そのクライアントに設定されている内容が上部の入力ボックスにコピーされます。（入力を省力化できます）

ネットワークの設定を変更するには、基本操作として次の手順に従います。
1.変更内容をセット
入力ボックスに変更したい内容をセットします。

２.クライアント選択
変更の対象となるクライアントをリスから選択します。
選択したクライアントが１つの場合と複数の場合で、変更の処理方法が異なります。

３.クライアントに送信
「更新」ボタンをクリックして、変更内容をクライアントに送信します。
更新に成功すると、リストの表示内容がセットした内容に書き換わります。

４．クライアントを再起動
変更内容を有効にするには、クライアントを再起動する必要があります。（すべてのOSで共通）
[Ctrl]キーを押しながら「リブート」ボタンをクリックすると、クライアントは再起動されます。

変更規則（重要）
入力ボックスにセットされた値がクライアントに送信される際には、下記の変更規則が適用されます。
基本的にDHCPがオフ（利用しない）の場合と、オン（利用する）の場合で変更処理が異なります。
また同様に、選択されているクライアントが１つだけの場合と、複数の場合では変更される内容が異なります。

DHCPがオフ（利用しない）で、クライアントの選択が１つだけの場合
・IPアドレス・・・・・入力されている値がそのまま、クライアントに適用されます。空欄の場合は、クライアントに設定されている値がそのまま残ります。
・サブネットマスク・・・・・必須入力項目です。空欄は許されません。
・デフォルトゲートウェイ・・・・・入力されている値がそのまま、クライアントに適用されます。空欄の場合は、クライアントに設定されている値は消去されます。
・DNSサーバー（優先、代替）・・・・・それぞれ入力されている値がそのまま、クライアントに適用されます。空欄の場合は、クライアントに設定されている値は消去されます。
・コンピューター名・・・・入力されている値がそのまま、クライアントに適用されます。空欄の場合は、クライアントに設定されている値がそのまま残ります。

DHCPがオン（利用する）で、クライアントの選択が１つだけの場合
・IPアドレス・・・・・入力できません。
・サブネットマスク・・・・・入力できません。
・デフォルトゲートウェイ・・・・・入力できません。
・DNSサーバー（優先、代替）・・・・・それぞれ入力されている値がそのまま、クライアントに適用されます。両方とも空欄の場合は、DNSデータは自動取得又は「なし」の設定になります。
・コンピューター名・・・・入力されている値がそのまま、クライアントに適用されます。空欄の場合は、クライアントに設定されている値がそのまま残ります。

DHCPがオフ（利用しない）で、クライアントの選択が複数の場合
・IPアドレス・・・・・入力されている値を基準値としてリストの上から順にIPアドレスの値を１つずつ増加して付与します。（0と255は除外）　空欄の場合は、各クライアントに設定されている値がそのまま残ります。
・サブネットマスク・・・・・必須入力項目です。空欄は許されません。
・デフォルトゲートウェイ・・・・・入力されている値がそのまま、クライアントに適用されます。空欄の場合は、クライアントに設定されている値は消去されます。
・DNSサーバー（優先、代替）・・・・・それぞれ入力されている値がそのまま、クライアントに適用されます。空欄の場合は、クライアントに設定されている値は消去されます。
・コンピューター名・・・・入力されている値を基準名とし、その語尾に連番が附加されてクライアントに適用されます。連番の開始値は「開始値」で設定します。　空欄の場合は、クライアントに設定されている値がそのまま残ります。

DHCPがオン（利用する）で、クライアントの選択が複数の場合
・IPアドレス・・・・・入力できません。
・サブネットマスク・・・・・入力できません。
・デフォルトゲートウェイ・・・・・入力できません。
・DNSサーバー（優先、代替）・・・・・それぞれ入力されている値がそのまま、クライアントに適用されます。両方とも空欄の場合は、DNSデータは自動取得又は「なし」の設定になります。
・コンピューター名・・・・入力されている値を基準名とし、その語尾に連番が附加されてクライアントに適用されます。連番の開始値は「開始値」で設定します。　空欄の場合は、クライアントに設定されている値がそのまま残ります。

IDentify機能
リストからクライアントを選択して「Identify」ボタンをクリックすると、クライアントパソコンでは現在のネットワーク設定値を確認するためのダイアログボックスが開きます。
多数のクライアントパソコンのセットアップを行うときなど、クライアントの画面にこのダイアログボックスを表示させておくと、巡回したときに簡単に識別、確認することが出来ますのでご便利です。
コントローラーから送信されたネットワーク設定情報はリアルタイムでこのダイアログボックスに反映されます。
クライアントにて表示されているこのダイアログボックスをコントローラーから消去するには、リストから対象のクライアントを選択し、[Shift]キーを押しながら「Identify」をクリックします。

操作ガイド
・クライアントに登録されているDNSサーバーのデータが３つ以上あった場合、リストに表示されるのは上位の２つだけです。この状態で更新を行うと、３つ目以降のデータは消去されますのでご注意ください。
・コンピューター名の変更に関して、クライアントのＯＳがWindows 2000, Windows XPの場合は、NetBIOS名とDNSホスト名ともに同時に更新されます。
・コンピューター名の変更は各クライアントにおけるホスト名が変更されるだけで、ドメインサーバーに対してコンピューターアカウントを作成するものではありません。
・クライアントを再起動させる前に、更新内容に間違いがないか十分にご確認ください。「リブート」ボタンを押す前であれば、いつでも起動時の状態に復帰させることが可能です。

ご注意
クライアントパソコンの認識にIPマルチキャストを利用している関係で、ルーターやスイッチ(L3以上)が介在したネットワーク上にあるクライアントがリストに表示されないことがあります。
その際は[Shift]キーを押しながら「リフレッシュ」ボタンをクリックしてください。クラスBの順次サーチによりクライアントを認識し、リストに自動追加します。

OSがWindows Vistaの場合、利用できません。


Windows ファイアウォール

Windows ファイアウォールの基本動作を設定することができます。
クライアントのOSがWindows Vistaの場合、本機能は利用できません。

また、発出される「Windows セキュリティの重要な警告」ダイアログに対して自動応答することができます。
一定期間、本機能を有効にした状態でクライアントの運用を行えば、ファイアウォールの例外設定を自動化することが可能です。

対象となるクライアントを選択し、「ネットワーク設定」ボタンをクリックします。

Windowsファイアウォール
動作モードと通知表示の有無を設定できます。

「Windows セキュリティの重要な警告」ダイアログへの対応
「Windows セキュリティの重要な警告」ダイアログが表示された際に処理したい内容のボタンを選択します。
「自動応答しない」を選択すると、警告ダイアログが表示されても何もしません。(デフォルト)
「設定」ボタンをクリックすると、以降警告ダイアログが表示された瞬間に設定した内容のボタン操作を自動実行します。

操作ガイド
一度設定すると、クライアントを再起動しても同様の処理を継続します。
処理方法を変更したい場合は、再度上記の設定を行ってください。

クライアントのOSがWindows Vistaの場合、本機能は利用できません。


時計合わせ

クライアントの内蔵時計を、ホストの時刻に合わせることができます。

まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括して命令を送ります。
次に「時計合わせ」ボタンをクリックすると、クライアントの内蔵時計は、コントローラーの内蔵時計の時刻に校正されます。
本機能を実行する前に、コントローラーの内蔵時計を正確な現在時刻に合わせておくことをおすすめします。


調査

修正プログラムの調査

クライアントに適用されているOSの修正プログラム(Hot Fix)の適用状況を調査することができます。
初めて本機能を利用する場合、「利用準備と環境設定」を事前に完了しておく必要があります。

修正プログラムの調査を行うには、対象となるクライアントをリストから選択し「Windows Update」ボタンをクリックします。
ただし、同時に250台以上のクライアントを選択して実行することはできません。

標準的な調査手順は以下のようになります。

1.リスト内容
  リストに表示する調査内容を選択します。
  「適用済」、「注意」、「警告」については、「環境設定」にて取得が選択されていない場合、表示されません。

2.適用状況調査
  「適用状況調査」ボタンをクリックしてクライアントの調査を開始します。
  調査対象のクライアント数や、取得する内容によって多くの時間を要することがあります。
  実行中は「閉じる」ボタンの上に「処理中」と表示されます。
  調査が完了すると、リスト内に取得した内容がコンピュータ順に表示されます。

  リストには以下の項目が表示されます。
  ・コンピュータ名・・・・クライアントのコンピュータ名です。
  ・IPアドレス・・・・・・・クライアントのIPアドレスです。
  ・文書番号・・・・・・・・修正プログラムに関するセキュリティ情報の番号です。
  ・Q番号・・・・・・・・・・修正プログラムのサポート技術情報の番号です。
  ・概要・・・・・・・・・・・・セキュリティ情報の概要です。
  ・種別・・・・・・・・・・・・セキュリティ情報の種別(OS、IE、WMPなど)です。
  ・状態・・・・・・・・・・・・適用状況です。(「適用」、「適用済」、「注意」、「警告」があります。)
  ・備考・・・・・・・・・・・・適用状況の補足説明です。
  ・登録日・・・・・・・・・・セキュリティ情報が登録(発表)された日です。
  ・更新日・・・・・・・・・・セキュリティ情報が更新された日です。
  ・文書URL・・・・・・・・・プログラムにて使用する項目です。
  ・FileURL・・・・・・・・・・プログラムにて使用する項目です。
  ・修正プログラム・・・・プログラムにて使用する項目です。

  リスト内容の変更
  リストに表示されている内容を変更したいときは、各チェックボックスの再選択を行った後、「修正」ボタンをクリックします。

  詳細情報の取得
  リストに表示されているセキュリティ情報の詳細を確認するには、対象の項目を選択し「詳細情報」ボタンをクリックします。
  ブラウザが起動し、マイクロソフトのサイトに自動接続して当該セキュリティに関する詳細な情報が表示されます。、
  対象項目をダブルクリックすることでも同様の処理を行います。

  最新データベースの確認
  画面左下の「修正プログラムデータベース」には調査に使用した修正プログラムのデータベースのバージョンと更新日が表示されています。
  データベースが最新のものであるかどうかを確認するには、「最新版のチェック」ボタンをクリックします。

ご注意
・本機能はMBSA2.0以降には対応していません。また、マイクロソフトのサポート終了後は本機能も利用できなくなります。
・「適用状況調査」ボタンをクリックすると、常に最新のデータベースをマイクロソフトのサイトから自動ダウンロードして適用状況の調査が行われます。
  よってコントローラーパソコンは自由にインターネットに接続し、マイクロソフトのサイトにアクセス出来る必要があります。
・本機能はクライアントのOSがWindows2000、WindowsXP、Windows Server　2003の時のみ利用可能です。
・本機能を利用するには、対象となるコンピュータに対して管理者のアクセス権が必要となります。


適用

修正プログラムの適用

未適用の修正プログラム(Hot Fix)をコントローラーから各クライアントに対して配信し、適用することができます。
初めて本機能を利用する場合、「利用準備と環境設定」を事前に完了しておく必要があります。
実行前に必ずページ末の「注意事項」を確認してください。

修正プログラムの適用を行うには、対象となるクライアントをリストから選択し「Windows Update」ボタンをクリックします。
ただし、同時に250台以上のクライアントを選択して実行することはできません。

標準的な調査手順は以下のようになります。

1.リスト内容の選択
  リストに表示する調査内容を選択します。
  「未適用」については必ず選択してください。
  「注意」、「警告」については任意です。

2.適用状況調査
  「適用状況調査」ボタンをクリックしてクライアントの調査を開始します。
  ただし、同時に250台以上のクライアントを選択して調査を実行することはできません。
  調査対象のクライアント数や、取得する内容によって多くの時間を要することがあります。
  実行中は「閉じる」ボタンの上に「処理中」と表示されます。
  調査が完了すると、リスト内に取得した内容がコンピュータ順に表示されます。

3.修正プログラムのダウンロード
  適用させたい項目をリストから選択します。(複数選択不可)
  「推定される修正プログラム」に適用すべき修正プログラムの候補が表示されます。
  候補にはOS種別やサービスパック適用の有無によって複数の修正プログラムが表示されることがあります。
  修正プログラム名に含まれるOS名などを基準に適用すべき項目を判断選択し、「ダウンロード」ボタンをクリックします。
  修正プログラムをダウンロードし、任意のフォルダに保存します。

  「推定される修正プログラム」に候補が全く表示されなかったり、適切な修正プログラムを判断できない場合は、「詳細情報」ボタンをクリックしてマイクロソフトのサイトから対話式にダウンロードしてください。

  カタログ
  「カタログ」ボタンをクリックすると、マイクロソフトの「Windows Update」サイトに接続します。
  本サイトにはOS種別、サービスパック別に修正プログラムが収録されていますので、任意にダウンロードしてクライアントに適用させることが可能です。

4.修正プログラムの登録
  修正プログラムを適用させる前に、ダウンロードした修正プログラムをリスト内の項目に登録(バインド)する必要があります。
  リストから適用させる項目(行)を選択します。
  このとき同一のQ番号であれば、複数のクライアントの項目(行)を同時に選択することができます。(Q番号のタイトル部分をクリックして、ソートしておくと便利です。)
  次に「修正プログラム登録」ボタンをクリックし、適用させる修正プログラムを登録します。
  登録された項目(行)の摘要欄にはチェックマークが入ります。
  登録後に適用対象から除外するには、当該行のチェックマークをオフにします。

  修正プログラムの適用は、複数の修正プログラムを一括でクライアントに適用することが可能です。(連続実行)
  その際は、上記の「修正プログラムの登録」手順を繰り返してください。
  ただし、修正プログラムの内容によっては、単独実行を要求するものがあります。(サービスパックなど)
  その場合、本プログラムでは連続実行可能かどうかを判別できませんので、マイクロソフトのサイトにてご確認ください。

  テクニック
  リスト内容のチェックをすべてオフにした状態で「更新」ボタンを押すと、リストには各クライアントが１行ずつ表示されます。
  適用状況の調査結果とは関係なく、任意の修正プログラムを適用することができます。
  「修正プログラム登録」にて任意のプログラムを各クライアントに登録(バインド)し、「修正プログラム適用」にて適用実行してください。
  通常の修正プログラム以外を適用させるときは、「環境設定」の「実行時のオプション」を変更する必要がある場合があります。

5.修正プログラムの適用
  「修正プログラムの適用」をクリックすると、下記のウィンドウが表示されます。

適用実行の方法には以下の２種類あります。

1.直ちに適用を開始
  直ちにクライアントに対して修正プログラムの配信を行い、適用作業を開始します。
2.スケジュール実行
  適用する日時を指定してスケジュール実行します。
  クライアントが稼働していない休日や深夜などに実行するのに適した方法です。

直ちに適用を開始
「直ちに適用を開始する」をクリックすると、直ちにクライアントに対して修正プログラムの配信が開始されます。
このときクライアントはログオフ状態でもかまいません。
修正プログラム適用の実行状況を示す下記のウィンドウが表示されます。

配信が完了したクライアントは修正プログラムの適用作業に移行し、すべての適用が完了した後、自動的にシステムの再起動を行います。
配信中、実行を中止したい場合は「実行中止」ボタンをクリックしてください。クライアントへの修正プログラムの配信は中断されます。
実行状況を表示するウィンドウを閉じると、実行結果が「WinUp.log」というファイルに保存されます。保存先はコントローラーのフォルダ内になります。

スケジュール実行
実行したい「日」、「時間」を入力し、「スケジュール実行する」ボタンをクリックします。
「日」の指定を行わなかった場合、直近の時間(当日または翌日)に実行されます。
指定した時間が当日においてすでに経過していた場合、実行は翌日になります。
同様に指定した日が当月においてすでに経過していた場合は、翌月の実行となります。
登録したスケジュールはOS付属の「タスク」に登録されます。
「タスク」を起動して、実行時間を変更したり、実行そのものを中止することが可能です。

スケジュール実行を行う場合、その実行時間にコントローラーパソコンは起動状態である必要があります。(ログオフ状態でもよい)
実行時間が来ると、対象クライアントの電源投入(Wake on LAN)が行われます。
電源投入の５分後にコントローラーから各クライアントに対して修正プログラムの配信が開始されます。
各クライアントではすべての修正プログラムの更新が完了すると、自動的に電源が切断されます。

注意事項
・本機能はMBSA2.0以降には対応していません。また、マイクロソフトのサポート終了後は本機能も利用できなくなります。
・本機能はクライアントのOSがWindows2000、WindowsXP、Windows Server　2003の時のみ利用可能です。
・本機能を利用するには、対象となるコンピュータに対して管理者のアクセス権が必要となります。
・複数のクライアントに対して修正プログラムの適用を行うときは、必ず１台のクライアントでテスト実行を行い、異常がないことを確認してください。
・「推定される修正プログラム」に表示される内容に自信がない場合は、必ず「詳細情報」にて確認を行ってからダウンロードしてください。
・クライアントに修正プログラムの適用を行う場合、クライアントパソコンはログオフの状態でもかまいません。
・修正プログラムの適用が正しく行われたかどうかの確認は、再度「適用状況調査」を行うことで可能です。
  「Windows Update 実行状況」のウィンドウに表示される実行結果はあくまでも参考です。
・2002年12月より前に作成された修正プログラムは連続実行することが出来ません。
  適用しようとする修正プログラムの更新日時が上記日付より古い場合は、連続実行しないでください。


利用準備、環境設定

本機能を利用するには、マイクロソフト社が提供する「Microsoft Baseline Security Analyzer (MBSA1.2.1)」がコントローラーパソコンにインストールされている必要があります。
また、コントローラーパソコンから自由にマイクロソフトのサイトに接続ができるネットワーク環境が要求されます。
「Microsoft Baseline Security Analyzer(MBSA)」の詳細についてはマイクロソフトのサイトをご参照ください。

注意事項
・本機能はMBSA2.0以降には対応していません。また、マイクロソフトのサポート終了後は本機能も利用できなくなります。

利用準備
・「Microsoft Baseline Security Analyzer (MBSA1.2.1)」をマイクロソフトのサイトよりダウンロードします。
・ダウンロードした「mbsasetup.msi」を実行し、インストールを行います。
  このときインストールしたフォルダ位置を覚えておいてください。(デフォルトフォルダを推奨)

環境設定
初めて「Windows Update」を利用する場合は必ず「環境設定」を実行する必要があります。
環境設定を行うには、メイン画面の「Windows Update」ボタンをクリックします。
「修正プログラム適用(Windows Update)」ウィンドウが開くので、「環境設定」ボタンをクリックします。

MBSAフォルダ
「Microsoft Baseline Security Analyzer (MBSA1.2.1)」をインストールしたフォルダを入力します。

調査結果保存ファイル
修正プログラムの適用状況の調査結果を保存するフォルダとファイル名をフルパスで指定します。
このファイルは外部プログラムなど)にて調査結果を再利用するためのもので、Guardianの「Windows Update」機能で利用するものではありません。

調査、取得する情報
修正プログラムの適用状況を調査する際に、取得する必要のない内容をあらかじめ除外することができます。
「適用済」のチェックをオフにすると、すでにクライアントに適用されている修正プログラムの情報取得は行われません。
「注意、警告」のチェックをオフにすると、すでにクライアントに適用されているが、問題の可能性がある修正プログラムの情報取得は行われません。
同時に多くのクライアントパソコンの調査を行うと、多大な時間を要することがあり、また調査結果のサイズも膨大なものになります。
必要のない情報を本設定でオフにすることにより、調査にかかる時間を大幅に軽減することができます。

同時転送数
一度に多数のクライアントに対して適用を実行すると、ネットワークやコントローラーパソコンに大きな負荷が掛かることがあります。
同時に転送することができるクライアント数を制限することにより、これを回避することができます。

実行時のオブション
修正プログラムを各クライアントにて実行するときに、その実行方法をオプションで指定します。
適切なオプションは実行する修正プログラムによって異なります。
規定値として、 /z と /q が与えられています。(ほとんどの修正プログラムは規定値のままでOKです)
/z 適用後にコンピュータを自動起動しません。
/q 適用時に対話的なユーザー入力を必要としません。

オプションについての詳細情報はマイクロソフトのサイトにて入手できます。

保存
各設定が終了したら、「保存」ボタンをクリックして設定内容の保存を行います。


エクスプローラー

クライアントパソコンの任意のドライブ内をエクスプローラーで自由にファイル操作することができます。

ファイル操作を行うには、まず対象となるクライアントを選択します。（複数選択はできません）
次に「エクスプローラー」ボタンをクリックすると、下記のダイアログボックスが表示されます。

表示するドライブ番号を入力して「実行」ボタンをクリックすると、クライアントのドライブ（共有資源）への接続操作を開始します。
エクスプローラーが起動し、指定したドライブの内容がルートディレクトリから表示されます。

操作ガイド
同一クライアントの複数ドライブを同時にファイル操作することはできません。
ドライブの切り替えを行うには、一度現在の接続を切断し、再接続する必要があります。
接続を切断するには、[Alt]キーを押しながら「エクスプローラー」ボタンをクリックします。
その後、再度「エクスプローラー」ボタンをクリックして他のドライブの指定を行ってください。
ただし、切断後数秒間はリソースの解放のためのインターバルが必要となることがあります。
ドライブの切り替えを行ったにもかかわらず、指定したドライブの表示ができないときは、しばらく時間をおいてから再接続してください。

複数のクライアントのファイル操作を行うことは可能です。
その際は、それぞれのクライアントに対する接続操作（上記手順）を実行してください。

接続の切断はそれまで接続していたドライブの指定は必要としません。
[Alt]キーを押しながら「エクスプローラーボタン」をクリックするだけで切断され、共有資源の解除を行います。
また、クライアントが再起動した時も自動的に切断されます。


共有、共有解除

クライアントのローカルディスク上のフォルダを共有させたり、解除したり出来ます。

フォルダの共有を行うには、まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括して命令を送ります。
次に「共有」ボタンをクリックします。下記のダイアログボックスが表示されます。

共有名
共有名を入力します。
共有名の末尾に「$」を付加すると、ブラウズ表示されません。(マイネットワークに表示されない)

共有フォルダ
共有するフォルダをフルパスで入力します。
（入力例： C:\windows\system32）

共有するグループは「Everyone」で、フルアクセスの権限が与えられます。

【共有実行】
「共有実行」ボタンをクリックすると、直ちにクライアントでは設定された内容に基づいてフォルダの共有が行われます。

【登録のみ】
「登録のみ」ボタンをクリックすると、設定内容が保存されますが、クライアントにコマンドは送信されません。

共有解除
フォルダの共有解除を行うには、まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括してメッセージを送ります。
次に「共有解除」ボタンをクリックします。直ちにクライアントでは設定された内容に基づいてフォルダの共有解除が行われます。
共有を解除するフォルダは「共有」ボタンをクリックして表示されるダイアログボックスの内容になります。


ファイル配信、中断

ファイル配信、配信中断

クライアントに対して任意のフォルダ内のファイルを配信（転送）することができます。
ファイルの種別はテキスト、バイナリーなど種類や属性を問いません。

ファイルの配信を開始するには、まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
次に「ファイル配信」ボタンをクリックします。下記のダイアログボックスが表示されます。

配信元ファイル
配信するファイルがあるコントローラーパソコンのファイル位置をフルパスで入力します。
ワイルドカードの使用が可能です。(「*.*」と設定すると、すべてのファイルが配信の対象となります。)

配信先フォルダ
配信されたファイルを格納するクライアントパソコンのフォルダ名をフルパスで入力します。
配信先として指定したフォルダがクライアントパソコンに存在しない場合は、フォルダが自動的に作成されます。

「配信実行」をクリックすると、直ちにクライアントに対してファイルの配信（転送）が行われます。
ファイルの配信中はクライアントリストの状態欄に「配信中」と表示され、配信が完了すると元の表示に復帰します。

「PC別配信実行」をクリックすると、コンピュータ別のファイル配信（転送）が行われます。
本機能はコンピュータ別のファイル回収の逆の動作をするものです。
「配信元ファイル」の入力欄に指定したフォルダ下にコンピュータ名を持つフォルダがあり、そのフォルダ内に存在するファイルが配信されます。
「配信元ファイル」の入力欄には、コンピュータ名を省いたパスを記述する必要があります。

実行例：
「配信元ファイル」の入力欄に「C:\Work\*.*」 と記述し「PC別配信実行」ボタンをクリックすると、「C:\Work」フォルダ下に存在するフォルダ名を配信先のコンピュータ名としてそのフォルダ内にある全ファイルを対象のクライアントに対してのみ転送します。
該当するコンピュータ名のクライアントが存在しない場合は、そのフォルダ内のファイルは転送されません。

ファイルの配信中はクライアントリストの状態欄に「配信中」と表示され、配信が完了すると元の表示に復帰します。
「PC別ファイル配信」では、サーバー経由の配信は行えませんのでご注意ください。

参照
「参照」ボタンをクリックすると、ドライブのルート以下の内容を一覧表示します。
選択されたファイルは配信元ファイルの入力欄に表示されます。

「登録のみ」ボタンをクリックすると、設定内容が保存されますが、クライアントにコマンドは送信されません。

サーバー経由で配信する
「サーバー経由で配信する」のチェックをオンにして「配信実行」すると、各クライアントへのファイル配信はサーバーを経由して行われます。
通常の配信と異なり、コントローラーの負荷を大幅に軽減することが出来ます。数十から数百のクライアントに対して同時に配信を行う場合は、サーバー経由での配信をお勧めします。
本機能を利用するには、サーバー上に各クライアントからアクセスが可能な共有フォルダを作成し、「サーバー名」と「共有名」を事前に設定してください。
「配信実行」をクリックすると、配信元ファイルに指定されているファイルをサーバー上の共有フォルダに一度コピーします。その際、共有フォルダ内にあるファイルは全て削除されますのでご注意ください。
サーバーへのコピーが完了後、各クライアントへの配信が開始されます。

配信中断
実行中のファイル配信を中断するには、対象となるクライアントを選択し、「ﾌｧｲﾙ配信中断」ボタンをクリックします。
クライアントリストの状態欄は、元の表示に復帰します。

ご注意
下層のフォルダ内容は配信されません。
第１行目の「すべての端末」を左クリックによって選択し、「ファイル配信」を実行することはできません。
すべてのクライアントに対して「ファイル配信」を行いたい場合は、第１行目の「すべての端末」を右クリックによって反転選択してから実行してください。
複数のクライアントに対してファイルの配信を行った場合、ファイル数とそのサイズによってはネットワークに対して大きな負荷がかかることがありますので十分ご注意ください。
また、ファイル配信は選択されたクライアントに対して同時に実行されるので、ネットワークの状態と配信する内容によっては、かなりの時間を要することがあります。


ファイル回収、回収中断

クライアントから任意のフォルダ内のファイルを回収（転送）することができます。
ファイルの種別はテキスト、バイナリーなど種類や属性を問いません。

ファイルの回収を開始するには、まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
次に「ファイル回収」ボタンをクリックします。下記のダイアログボックスが表示されます。

回収するファイル
回収するファイルがあるクライアントパソコンのファイル位置をフルパスで入力します。
ワイルドカードの使用が可能です。(「*.*」と設定すると、すべてのファイルが回収の対象となります。)

保存先フォルダ
回収されたファイルを格納するコントローラーパソコンのフォルダ名をフルパスで入力します。
回収先として指定したフォルダがコントローラーパソコンに存在しない場合は、フォルダが自動的に作成されます。

「回収実行」をクリックすると、直ちにクライアントからファイルの回収（転送）が行われます。
ファイルの回収中はクライアントリストの状態欄に「回収中」と表示され、回収が完了すると元の表示に復帰します。
「登録のみ」ボタンをクリックすると、設定内容が保存されますが、クライアントにコマンドは送信されません。

回収中断
実行中のファイル回収を中断するには、「ファイル回収中断」ボタンをクリックします。
クライアントリストの状態欄は、元の表示に復帰します。
回収を中断するパソコンの指定はできません。すべてのクライアントが対象となります。

コンピュータ名で整理
回収されたファイルをコンピュータ別のフォルダに分配、保存します。

ユーザー名で整理
回収されたファイルをユーザー別のフォルダに分配、保存します。

整　理
選択された整理方法で回収済みの全ファイルを整理します。

操作ガイド
保存先のフォルダに回収された各ファイルは次の形式のファイル名になります。
    コンピューター名_ユーザー名^ファイル名
例： コンピュータ名が「WS-1」、ユーザー名が「Guest」、ファイル名が「Sample.doc」の場合、保存されるファイル名は WS-1_Guest^Sample.doc となります。

「整理」はすべての回収が完了してから実行するようにしてください。
「整理」を実行すると、ファイル名を元に「コンピューター名」または「ユーザー名」のフォルダが自動作成されます。
「整理」を実行すると、それぞれのフォルダに格納されたファイル名はクライアント上のファイル名に変更されます。

ご注意
下層のフォルダ内容は回収されません。
第１行目の「すべての端末」を左クリックによって選択し、「ファイル回収」を実行することはできません。
すべてのクライアントに対して「ファイル回収」を行いたい場合は、第１行目の「すべての端末」を右クリックによって反転選択してから実行してください。
複数のクライアントに対してファイルの回収を行った場合、ファイル数とそのサイズによってはネットワークに対して大きな負荷がかかることがありますので十分ご注意ください。
また、ファイル回収は選択されたクライアントに対して同時に実行されるので、ネットワークの状態と回収する内容によっては、かなりの時間を要することがあります。


ファイル削除

一括ファイル削除

クライアントのディスク上の任意のファイルを削除することができます。

まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括して命令を送ります。
次に「ファイル削除」ボタンをクリックします。下記のダイアログボックスが表示されます。

削除したいファイル名をフルパスで入力欄に入力します。
ファイル名の指定にはワイルドカードが使用できます。(入力例：C:\Work\*.*)

【削除実行】
「削除実行」をクリックすると、直ちにクライアントでは入力された内容に基づいて、ファイルの削除が行われます。
ただしファイル属性が［システム］、［隠しファイル］及び［読み取り専用］のファイルについては実行されません。
ファイルの属性に関係なく削除を行うには、「属性無視」のチェックボックスをオンにして実行します。

入力した内容は後の利用のため、リストに自動追加されます。
リスト内の行をクリックすると、その内容が上部の「削除ファイル」入力欄にコピーされ、再利用可能です。

【追加登録】
「追加登録」ボタンをクリックすると、入力された内容をリストに追加しますが、クライアントにコマンドは送信しません。

【保存終了】
リストに表示された内容を保存し、メイン画面に戻ります。


ログ

ログ記録開始

クライアントにて使用者がアクセス（利用）したアプリケーションおよびウィンドウの記録（ログ）をとることができます。
ログの記録を開始するには下記の手順に従います。

まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックしての選択方法は利用できません。
次に「ログ設定」ボタンをクリックします。直ちにクライアントではログの記録が開始されます。
クライアントリストの「ログ」欄には「ON」と表示されます。以後、ログの記録にはコントローラーの動作は必要ありません。
ログの記録は次に述べる解除操作を行わない限り、永久に継続されます。
クライアントが再起動し、利用者が替わってもログの記録は継続されます。
ログの記録は他の制御内容とは競合しません。（独立して機能します。）

ログ記録解除
ログの記録を解除（停止）するには下記の手順に従います。

まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックしての選択方法は利用できません。
次に「ログ解除」ボタンをクリックします。直ちにクライアントではログの記録が解除されます。
クライアントリストの「ログ」欄は空欄となります。
「ログ解除」ボタンをクリックした時までに収集されたログはファイルに保存されます。
その後、再びログの記録が開始された場合は、既存のファイルに追加記録されていきます。

ログ回収

クライアントにてウィンドウ情報のアクセスログが取られている場合、そのログファイルをコントローラー側で回収することができます。
回収されるログの内容は、前回に回収したときからの累積した内容になります。回収後はクライアントのアクセスログはリセットされます。（クリアー）
クライアントにてアクセスログが取られている最中でも「ログ回収」は可能です。（「ログ解除」ボタンをクリックしてログの記録を停止する必要はありません。）
その際、回収されるのは「ログ回収」ボタンがクリックされた時点までの内容になります。クライアント側ではログファイルはいったんリセットされますが、ログの記録は継続されます。

手動回収
まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックしての選択方法は利用できません。
次に「ログ回収」ボタンをクリックします。
各クライアントからのログ回収はバックグラウンドで行われます。回収されたログは各クライアントごとにログファイルとしてコントローラーに格納されます。
格納されるフォルダはコントローラーがインストールされたフォルダ直下に自動作成される「GLOG」というフォルダに格納されます。
このとき、各ログファイルのファイル名は次のようになります。
ログファイル名 ＝ ＩＰアドレス+コンピュータ名.log　（例：192.168.1.1_Work1.log）
前回回収された同名のファイルがある場合は、上書きされますのでご注意ください。

自動回収
コントローラーを起動して手動でログの回収を行わなくても、コマンドラインから自動回収することができます。
バッチファイルやタスクスケジュールなどで利用することができます。

ログの自動回収を行うには、下記の手順に従います。
・コントローラープログラムが起動していないことを確認します。
・コントローラーがインストールされているフォルダ内にある「GetLogAuto.exe」を起動します。
・自動的にクライアントからログの回収が行われます。（ダイアログなどは一切表示されず、バックグラウンドで処理は行われます。）
・正常にログ回収が行われたかどうかは、フォルダに格納されたファイルにて確認してください。
  ※回収されるのは起動中のクライアントのものだけです。

ログファイルの結合
「GLOG」フォルダに格納された各クライアントのログファイルを蓄積して記録することができます。
ログファイルの蓄積記録を行うには次の手順に従います。
・コントローラーがインストールされているフォルダ内にある「GMerge.exe」を起動します。
・新しく「GLOGSAVE」フォルダが作成されます。（初回のみ）
・「GLOG」フォルダ内にある各クライアントのログファイルが「GLOGSAVE」フォルダにコピーされます。（ダイアログなどは一切表示されず、バックグラウンドで処理は行われます。）
・この時、すでに同名のファイルが存在する場合は、そのファイルに内容が追加記録されます。
・すべてのログファイルのコピーが終了した後、「GLOG」フォルダ内のログファイルはすべて削除されます。

上記の方法により各クライアント別にログファイルが蓄積記録されます。

各クライアント別に記録しないで、１つのログファイルにすべてのクライアントのログデータを記録したい場合は「GMerge.exe」に記録するファイル名を指定して起動してください。（パラメータ）
このとき指定するファイル名の拡張子は、必ず「.dat」としてください。(拡張子がなかったり、他の名称の場合は通常の記録となります。)
入力例： C:\Progra~1\007\Gremote\GMerge.exe Access.log ("Access.log" というファイルにすべてのクライアントのログデータを蓄積記録します。)

「GMerge.exe」は「GetLogAuto.exe」などと共に、バッチファイルなどに組み込んでご利用いただくとご便利です。

記録されるログの内容
クライアントより、回収されたログファイルには下記の情報が記録されています。

    ・コンピュータ名
    ・ユーザー名
    ・アクセスした時間
    ・アクセスした年月日
    ・利用したアプリケーションの実行ファイル名（起動時には先頭に"OPEN_"が付加され、終了時には"CLOSE_"が付加されます。）
    ・アクセスしたウィンドウのキャプション（ウィンドウタイトル）
    ・印刷した文書名と利用したプリンタ名
    ・デバイスの脱着、接続、切断(CD-ROM、USBの外部記録装置、ネットワーク仮想ドライブ)

記録するログ内容の選択
クライアントにて記録するログ内容を選択することができます。
選択は、「環境設定」で行います。

上記の各データはカンマにて区切られたテキストファイル（CSV形式）となっています。各種エディタや表計算ソフト、データベースソフトなどでご利用ください。
キャプション内にカンマがあった場合、スペースに置き換えられますのでご了承ください。（区切り文字と混同しない為）


ログ閲覧

クライアントのログを閲覧することができます。

まず対象となるクライアントを選択します。（複数選択はできません。）
次に「ログ閲覧」ボタンをクリックすると、下記のダイアログボックスが表示されます。

ログデータの転送には、クライアントに蓄積されているデータのサイズに応じて、数秒から数十秒かかります。
転送が終了すると、リストにログデータが記録された順に表示されます。
クライアントに送信すべきログデータがない場合は、リストは空欄のままとなります。

リスト内容
リストには下記の情報が表示されます。
  - コンピュータ名・・・取得したログのコンピュータ名
  - ユーザー名・・・・・操作を行ったユーザー名
  - 日付・・・・・・・・・・操作を行った年月日
  - 時間・・・・・・・・・・操作を行った時間
  - 分類・・・・・・・・・・ログ内容の種別
  - 内容・・・・・・・・・・ログの内容

ユーザーリストのカラムタイトルをクリックする度に、表示順序(昇順、降順)が変わります。
カラムタイトル間を左右にスライドすることで、表示幅を変更することができます。
カラムタイトルを左右にドラッグすることで表示位置を変更することができます。

分類
ログ内容は以下に分類されます。
  - ログオン・・・・・・・・・・ユーザーがログオンしたことを示します。
- ログオフ・・・・・・・・・・ユーザーがログオフしたことを示します。
- ウィンドウタイトル・・・ユーザーが利用したウィンドウのタイトル文字であることを示します。
- アプリ起動・・・・・・・・ログ内容のアプリケーションファイルをユーザーが起動したことを示します。
- アプリ終了・・・・・・・・ログ内容のアプリケーションファイルをユーザーが終了したことを示します。
- URL・・・・・・・・・・・・・ユーザーが利用したWebページのURLであることを示します。
- 印刷・・・・・・・・・・・・・ユーザーが文書の印刷を行ったことを示します。
- 接続・・・・・・・・・・・・・デバイスが挿入、接続されたことを示します。
- 切断・・・・・・・・・・・・・デバイスが排出、切断されたことを示します。

ブラウザ表示
分類が[URL]となっている行をダブルクリックすると、そのURLのページをブラウザで表示することができます。

ログを保存
表示されているログ内容をファイルに保存することができます。

操作ガイド
リスト内にデータが表示されている状態で別のクライアントのログ閲覧を行うと、表示されているデーターの後に追加表示されます。
ログ閲覧を行ってもクライアントにあるログデータはそのまま残ります。
また、ログ保存を行ってもクライアントにあるログデータはそのまま残ります。
ログファイルをクリアーしたり、回収するには「ログ回収」を利用します。


クライアント登録

クライアントリスト
登録されているクライアントのＩＰアドレス、コンピュータ名、MACアドレス、ポート番号、グループ、メモを表示します。

保存終了
「保存終了」ボタンをクリックすると、リストに表示されている内容をファイルに保存し、メイン画面に戻ります。

キャンセル
「キャンセル」ボタンをクリックすると、変更内容はすべて破棄されファイルの更新は行われません。

削除
「削除」ボタンをクリックすると、リストで選択されているクライアントを削除します。

登録
「登録」ボタンをクリックすると、ＩＰアドレス入力ボックス、MACアドレス入力ボックスおよびメモ入力ボックスに表示されている内容をリストに追加又は修正登録します。

ＩＰアドレス入力ボックス
ＩＰアドレスを入力します。

MACアドレス入力ボックス
MACアドレスを入力します。

メモ入力ボックス
メモを入力します。
クライアントに関する任意の情報を記録できます。

一括認識
「一括認識」ボタンをクリックすると、稼働中のクライアントを同時に自動認識し、リストに追加登録します。

全スキャン
「全スキャン」ボタンをクリックすると、入力されたネットワークアドレス内の全てのクライアントをスキャンし、リストに追加登録します。

指定スキャン
「指定スキャン」ボタンをクリックすると、事前に設定されたネットワークアドレス内をスキャンし、リストに追加登録します。

スキャン設定
「スキャン設定」ボタンをクリックすると、指定スキャンで利用するネットワークアドレスを設定するためのウィンドウが表示されます。
本ウィンドウにてスキャン間隔の設定を行うことも出来ます。

操作ガイド
管理したいクライアントを登録する手段として、［自動認識登録］と［手動登録］の２種類の方法が用意されています。

【自動認識登録】
稼働中のクライアントを自動で認識し、リストに追加登録します。
クライアントの認識方法には２通りあります。
自動登録を行う前に、対象のクライアントがすべて起動していることを確認してください。

1. 「一括認識登録」
通常はこの方法でクライアントの自動登録を行います。
「一括認識」ボタンをクリックすると、クライアントがリストに自動追加されます。

2. 「スキャン登録」
「一括認識登録」では、IPマルチキャストを利用している関係でルーターが介在したネットワークのクライアントを認識することができないことがあります。
このような場合は、「スキャン登録」を利用することで自動登録を行うことが出来ます。
「スキャン登録」では、設定されたネットワーク内のIPアドレスを順番にスキャンしてクライアントを自動登録します。
スキャンするネットワークアドレスの設定には、入力ボックスに都度入力する方法と、スキャンするネットワークアドレスを事前登録しておく方法があります。

「都度入力する方法」
入力ボックスに第１オクテットから第３オクテットまで下記の要領でアドレスを入力します。
入力例1： [192] [168] [1]
上記のように入力した場合、192.168.1.1～192.168.1.254までのIPアドレスをスキャンしてクライアントを検出します。
入力例1： [192] [168] [ ]
上記のように第３オクテットを空欄にして入力した場合、192.168.0.1～192.168.255.254までのIPアドレスをスキャンしてクライアントを検出します。
「全スキャン」のチェックボックスをオンにして「自動認識登録」ボタンをクリックすると、サーチを開始します。

「事前登録する方法」
事前にスキャンするアドレスを入力しておくことで、複数のネットワークアドレスをスキャンする手間を省くことが出来ます。
また、クラスBのネットワークをスキャンする際に、第３オクテットまで指定することでスキャン時間を大幅に短縮することが可能です。
「スキャン設定」ボタンをクリックすると、下記の設定ダイアログボックスが表示されます。

「スキャン間隔」は各アドレスをスキャンするときの間隔をms単位で指定しまが、通常はデフォルトの「0」で結構です。
ネットワーク環境によっては、スキャン間隔が早すぎるとうまく認識できない場合があります。
そのようなときは、スキャン間隔を増やすことで認識できるようになります。

スキャンしたいネットワークアドレスを入力ボックスに必ず第３オクテットまで入力し、「追加」ボタンをクリックするとリストに追加登録されます。
リスト内のアドレスを削除したいときは、該当のアドレスを選択してから[Delete]キーを押します。
設定終了後、「保存」ボタンをクリックして内容を保存します。
「指定スキャン」をクリックすると、登録されたネットワークアドレスのスキャンが開始されます。

【手動登録】
手動でクライアントの登録を行うには、ＩＰアドレス入力ボックスにＩＰアドレスを入力し、「登録」ボタンをクリックします。
入力されたＩＰアドレスは自動的にソートされ、リストボックス内に表示されます。
コンピュータ名、MACアドレス、ポート番号はクライアントより自動取得されます。（クライアントが稼働中の場合）

自己のＩＰアドレスも登録することができます。ウィンドウ情報（制御内容）の取得に利用できますので登録しておくと便利です。
自己のＩＰアドレスは「自動登録」では登録することができませんので手動登録をご利用ください。

【修正】
登録内容を修正したい場合は、クライアントリストから対象のクライアントを選択します。
ＩＰアドレス、MACアドレス、メモの入力ボックスに現在の値が表示されます。
修正を施し、[登録]ボタンをクリックします。
IPアドレスの変更を行った場合は、修正ではなく新規にそのアドレスのクライアントが登録されます。

【削除】
リストからクライアントを削除するには、まずリスト内でクライアントを選択します。（複数選択可）
その後、「ＩＰ削除」ボタンをクリックします。
第１行目の「すべての端末」はプログラムで予約されており、削除することはできません。

DHCPなどで毎回異なったIPアドレスがアサインされるような環境でご利用になるときは、本ダイアログボックスでは登録作業を行わず、「自動追加登録」の機能をご利用ください。
詳しくは「クライアントリスト設定」をご参照ください。

ご注意
「保存終了」ボタンをクリックしない限り、登録内容は一切保存されませんのでご注意ください。

クライアントのハードウェア構成、システムの状態によってはMACアドレスの自動取得ができない場合があります。
その際は、手動でMACアドレスを入力してください。
「ウェイクアップ」機能を利用しないのであれば、MACアドレスを登録する必要はありません。


環境設定

クライアントパソコンの動作環境(ポート番号、パスワードなど)を設定します。

まず対象となるクライアントをマウスでクリックして選択します。（複数選択可）
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括して設定内容が送られます。
次に「環境設定」ボタンをクリックします。下記のダイアログボックスが表示されます。

ポート番号
設定値として、「10001～60000」の数値を入力します。インストール直後の規定値は「55555」となっています。
クライアント用ポート番号はクライアントごとに異なる値を設定することが可能です。
入力欄に何も入力せずに空欄のまま「設定実行」すると、クライアントにおいてポート番号の変更は行われず、現行の設定値が維持されます。
転送設定されたクライアントのポート番号はリスト内の「ポート番号」欄に表示されます。
ただし、変更したポート番号は、次回クライアントが再起動したときに有効となります。再起動するまでは、旧ポート番号で動作します。
不用意にポート番号の設定を変更しますと設定値に不整合が起こり、通信の確立ができなくなる恐れがあります。十分な計画性を持って設定を行ってください。

クライアント手動解除パスワード
クライアント側において、手動でクライアントプログラムを停止させたいときに必要となるパスワードを入力します。
入力可能な設定値は、15バイト以内の文字列になります。
クライアント手動解除パスワードはクライアントごとに異なる値を設定することが可能です。
現在クライアントに設定されているパスワードを知る方法はありません。設定した値は無条件に上書き更新されますのでご注意ください。（クライアントにおける登録方法とは異なり、現パスワードの確認はありません。）
クライアントに解除用パスワードの登録がない場合、手動でのクライアントプログラム停止は行えません。
手動解除機能はあくまでも緊急用です。クライアントが「ロック」の状態にある時は、手動解除を行う事はできません。

アクティブ検出時間
クライアントにおいて一定時間マウスによる操作が行われないと、クライアントリスト内の緑ランプは消灯します。
最後にマウス操作が行われてから緑ランプを消灯するまでの時間（アクティブ検出時間）を自由に変更することができます。
設定したい時間を入力ボックスに秒単位で入力します。インストール直後の初期値は３００秒（５分）となっています。
アクティブ検出時間はクライアントごとに異なる値を設定することが可能です。
クライアントに現在設定されているアクティブ時間を知る方法はありませんのでご注意ください。
クライアントの動作状態によってはランプが正確に点灯、消灯しない事があります。

記録するログの内容
クライアントにて記録するログの内容を選択することができます。
取得する必要のない項目をオフにすることによってログファイルの容量を押さえることが可能です。
「印刷」ログの記録は、クライアントの状態によってはネットワークおよびコンピュータに負荷が掛かることがあります。(デフォルトではOFFになっています。)

プロキシー
クライアントがプロキシーを利用している場合、FTPプロトコルを利用している関係で「ファイル配信」機能をご利用いただけないことがあります。
その際は「Guardian」にプロキシーの情報を登録しておくことで、正常にご利用いただくことが可能となります。
プロキシーのタイプを選択し、接続に必要な項目を入力してください。
  ・タイプ・・・・・・・ プロキシーの種別を数字で入力します。
                      0：プロキシーを利用しない（デフォルト）
                      1：Socks V4
                      2：Socks V5
                      3：Site Host Name
                      4：User Logon
                      5：User No Logon
                      6：Open Site
                      7：Pipe
  ・アドレス・・・・・ プロキシーのIPアドレスを入力します。
  ・ポート・・・・・・・ プロキシーのポート番号を入力します。
  ・ユーザー名・・・ プロキシー利用時のユーザー名を入力します。
  ・バスワード・・・ プロキシー利用時のパスワードを入力します。

【設定実行】
「設定実行」をクリックすると、直ちにクライアントでは入力された内容の変更が行われます。

【保存終了】
リストに表示された内容を保存し、メイン画面に戻ります。

操作ガイド
クライアントとコントローラーはポート番号が一致しないと、一切通信することができません。
クライアントリストに登録されているクライアントでも、ポート番号が異なるとコントローラーは認識せず、すべてのコマンドが機能しません。
２台以上のコントローラーが存在するネットワーク環境において、このポート番号を互いに他のグループと異なる値に設定することで、誤動作を防ぐことができます。
また、クライアントを複数のグループに分けて管理したいときにも、ポート番号を変えることで効率的な管理が可能となります。
転送された新しいポート番号はクライアントプログラムが次回に起動した時に有効となります。
クライアントの再起動を行わないでポート番号の変更を行うには、[ALT]キーを押しながら 「解除」ボタンをクリックすることで設定値を有効にすることができます。（プログラムのみ再起動します。）

プロキシーデータの変更を行った場合、クライアントパソコンの再起動を行うまで設定内容は有効とはなりません。
クライアントの再起動を行わないでプロキシーデータの変更を行うには、[ALT]キーを押しながら 「解除」ボタンをクリックすることで設定値を有効にすることができます。（プログラムのみ再起動します。）


コントローラー設定

ポート番号
設定値として、「10001～60000」の数値を入力します。インストール直後の規定値は「55555」となっています。

操作ガイド
コントローラーとクライアントはポート番号が一致しないと一切通信することができません。
クライアントリストに登録されているクライアントでも、ポート番号が異なるといかなるコマンドも無効となります。
２台以上のコントローラーが存在するネットワーク環境において、このポート番号を互いに他のグループと異なる値に設定することで、意図しない動作（誤動作）を防ぐことができます。
また、クライアントを複数のグループに分けて管理を行いたいときにも、このポート番号を変えることで効率的な管理が可能となります。
変更された新しいポート番号はコントローラープログラムを次回に起動したときに初めて有効となります。
不用意にポート番号の設定を変更しますと設定値に不整合が起こり、通信の確立ができなくなる恐れがあります。十分な計画性を持って設定を行ってください。
クライアント側のポート番号の変更は「環境設定」で行います。

メール制御
電子メールを利用してコントローラーの機能を外部から利用することが可能です。

接続確認
「接続確認」ボタンをクリックすると、メールサーバーとの接続確認を行います。
ただし、メールアカウントのパスワードチェックまでは行いませんのでご注意ください。

メール制御を行う
「メール制御を行う」のチェックをオンにし「保存終了」すると、設定されたメールアドレスに対する巡回チェックが開始され、本機能が利用可能になります。
チェックをオンにする際は、各設定値を確認し、「接続確認」を行って異常がないことを必ず確認してください。
本機能を利用しない場合はチェックをオフにしてください。

メールアドレス
本機能で利用するメールアドレスを入力します。

メールアカウント
メール受信時のアカウントを入力します。

メールパスワード
メール受信時のパスワードを入力します。

POP3サーバー
受信のためのメールサーバーを入力します。

SMTPサーバー
送信のためのメールサーバーを入力します。

実行パスワード
コマンドを実行するためのパスワードを入力します。
メール内に記述されたパスワードと一致しない場合は、コマンドは実行されません。
セキュリティーのため、必ず設定するようにしてください。

返信メールアドレス(オプション)
情報を返信する為のメールアドレスを指定します。
本項目に設定がある場合、無条件にそのアドレスに対してのみ情報の返信を行います。
入力がない場合は、コマンドメールの内容に従います。

メールチェック間隔
コントローラーがメールサーバーと接続し、メールチェックを行う間隔を入力します。(1～9999秒)
「接続」、「メールチェック」、「切断」に必要な時間以上の値を設定してください。
設定値がメールチェックに必要とされる時間より短いと、不具合が発生する可能性があります。
デフォルト値は10秒となっています。

機能設定
・画像配信、プレゼンテーション機能の停止
チェックボックスをオンにすると、コントローラーのデスクトップ画像を配信したり、URL配信やアプリケーションの起動終了などのプレゼンテーション機能が無効となります。
コントローラーの誤った操作により、意図しない配信がクライアントになされることを防止することが可能です。

・詳細情報の履歴を記録しない
チェックボックスをオンにすると、「詳細情報」で得られたキャプチャー画像や各種の環境情報の記録を行わなくなります。
履歴の必要がない場合はオンにしてご利用ください。

・履歴データ保持件数
履歴データを保持する件数を、100～3000の範囲で設定します。初期件数は1,000となっています。
設定件数が多いほど、保存時の時間が長くなりますのでご注意ください。

クライアントリスト設定
クライアントリストに表示される内容に関する設定を行います。
クライアントリスト設定は、主にDHCPなどからリースされたIPアドレスをご利用になる環境の為のものです。
すべてのクライアントに固定IPアドレスがアサインされた環境でご利用になる場合は、設定の必要はありません。
（デフォルト値はすべて「ノンチェック」）の状態です。）

・起動時、クライアントリストを読み込まない
  通常コントローラーを起動したとき、クライアントリストには登録されているクライアントの内容がすべて表示されます。
  「起動時、クライアントリストを読み込まない」をオンにして起動すると、クライアントリストには何も表示されません。（第１行目以外）
  ただし、下記の「登録のないクライアントを自動登録する」がオンの場合、コントローラーが起動した時点で稼働しているクライアントは表示されます。
・終了時、クライアントリストの内容を保存しない
  「終了時、クライアントリストの内容を保存しない」をオンにしてコントローラーを終了すると、クライアントリストに表示されている内容の保存はいっさい行われません。
  前回保存したクライアントの内容がそのまま存続することになります。
・登録のないクライアントを自動登録する
  「登録のないクライアントを自動登録する」をオンにしてコントローラーを起動すると、認識したクライアントがリストにない場合、自動的にそのクライアントの情報をクライアントリストに登録します。

操作ガイド
DHCPなどによってIPアドレスがアサインされるネットワーク環境でご利用になる場合、下記の設定でご利用になることをお勧めします。
  「起動時、クライアントリストを読み込まない」・・・・・・・オン
  「終了時、クライアントリストの内容を保存しない」・・・オン
  「登録のないクライアントを自動登録する」・・・・・・・・・オン

上記の設定にすることで、常に正しいクライアント情報を表示して利用することが可能です。
ただし、上記の設定では「ウェイクアップ」の機能はご利用いただけません。その場合は下記の設定でご利用ください。

  「起動時、クライアントリストを読み込まない」・・・・・・・オフ
  「終了時、クライアントリストの内容を保存しない」・・・オフ
  「登録のないクライアントを自動登録する」・・・・・・・・・オン

コントローラー利用制限（ボタン）
コントローラーのインストール直後はすべての機能（ボタン）が有効（オン）となっています。
利用制限したい機能のボタンを「オフ」にすると、コントローラーのメイン画面で対応するボタンはグレー表示となり操作が出来なくなります。

・パスワード不一致の場合、コントローラーの起動を禁止する。
利用できるボタンを制限するのではなく、コントローラーそのものの利用を禁止したい場合は、このチェックボックスをオンにします。

・管理者パスワード
このパスワードはコントローラーの利用制限（機能制限）を行いたいときに設定するものです。
パスワードの登録、変更を行うには、先ず現パスワード入力ボックスに現在設定されているパスワードを入力します。
インストール後、初めて設定するときは現パスワード入力ボックスは空欄のままにしておいてください。
次に新パスワード入力ボックスに新しく登録したいパスワードを入力し、「保存終了」ボタンをクリックします。
このとき、現パスワードが登録されているデータと一致しないと、エラーとなり登録、変更は行われません。
登録することができるパスワードは１５バイト以内の文字列です。（英数字を推奨）
パスワードを消去したいときは、新パスワードを空欄にして「保存終了」ボタンをクリックしてください。

操作ガイド
コントローラーには、管理者でも誤って操作するとクライアントに対して重大な損害を与えかねない機能がたくさんあります。
また、管理権限のない人間に対して、一時的にコントローラーの利用を許可するときなど、すべての機能が利用できては困る場合があります。
そういったときに本機能を利用することで、セキュリティーを確保することが可能となります。
コントローラーの利用制限は起動時にボタンを無効化することで行います。

コントローラーの利用制限を行うには、必ず管理者パスワードの設定を行わなければなりません。
管理者パスワードの登録がないと、ここで設定した機能の制限は実施されず、すべての機能が有効となります。
管理者パスワードが登録されていると、コントローラーの起動時に管理者用パスワードの入力を要求するダイアログボックスが表示されます。
入力したパスワードが一致しない場合や、何も入力せず「OK」ボタンや[キャンセル]ボタンを押した場合は、利用制限が課せられたメイン画面が表示されます。
「パスワード不一致の場合、コントローラーの起動を禁止する。」がオンの場合は、コントローラーは起動しません。
一方、入力したパスワードが登録された管理者パスワードと一致した場合は、すべての機能が有効となります

保存終了
「保存終了」ボタンをクリックすると、上記の設定内容を保存します。その後ダイアログボックスをクローズし、メイン画面に戻ります。

キャンセル
「キャンセル」ボタンをクリックすると、設定内容を保存せずにメイン画面に戻ります。


リフレッシュ

コントローラーは各クライアントの動作状態を常に追跡し、リストボックスの状態欄を更新するようになっています。
しかし何らかの理由（整合性が失われた時など）で情報の再取得を行いたいときがあります。
「リフレッシュ」を実行することでクライアントの動作状態を再取得することができます。

情報の再取得を行いたいクライアントを選択して、「リフレッシュ」ボタンをクリックしてください。（複数選択可）
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括してメッセージを送ります。
現在のクライアントの動作状態が表示されます。


クライアント停止

通常の運用時に利用することはあまりない機能ですが、何らかの理由でクライアントプログラムをコントローラーから終了させたいときに本機能を利用します。
いったんこの操作を行ってしまうと、クライアントが再起動されない限り、コントローラーから制御する事は一切不可能となります。
誤って操作しないよう、十分にご注意ください。

まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括してメッセージを送ります。
次に[SHIFT]キーを押しながら「クライアント停止」ボタンをクリックすると、クライアントはすべての制御を解除した後、クライアントプログラムを自ら終了します。

ご注意
万一、何らかの理由でクライアントの解除操作が行えなくなったり、動作が不安定になった場合は、［Alt］キーを押しながら「クライアント停止」ボタンをクリックしてください。
クライアントプログラムがリセットされます。(パソコン起動時と同じ状態になります。)


メッセージ登録

メッセージ入力ボックス(上段)
テキスト文を250バイト以内で入力します。
プログラムファイルを指定する場合は半角文字でフルパス指定します。

メッセージリストボックス（下段）
登録されているメッセージ文をリスト表示します。

追加
「追加」ボタンをクリックすると、メッセージ入力ボックス（上段）のテキスト文をメッセージリストボックス（下段）に追加登録します。

削除
「削除」ボタンをクリックすると、メッセージリストボックスで選択されているテキスト文をリストから削除します。

全削除
「全削除」ボタンをクリックすると、メッセージリストボックスのテキスト文をすべて一括削除します。

終了
「終了」ボタンをクリックすると、ダイアログボックスをクローズしGRemoteメイン画面に戻ります。

操作ガイド
「ワンライン送信」でよく使う送信文を登録しておきます。
登録する内容はメッセージ文が主体ですが、コマンド文（プログラム起動など）も登録することができます。
コマンド文の場合は、アプリケーションファイルを正確にフルパス指定するようにしてください。

入力例1： c:\windows\system32\calc.exe （CドライブのWindows\system32ディレクトリにある「calc.exe」を実行します）
入力例2： c:\windows\system32\notepad.exe^^c:\boot.ini　（CドライブのWindows\system32ディレクトリにある「notepad.exe」を起動して、Cドライブのルートディレクトリにある「boot.ini」を読み込みます。）
入力例3： c:\temp\readme.txt　（CドライブのTempディレクトリにある「readme.txt」を開きます。"txt"に関連づけられているエディタが同時に起動されます。）
入力例4： c:\work\update.bat　（CドライブのWorkディレクトリにあるバッチファイル「update.bat」を開きます。）

コマンドにパラメータを付加したいときはスペースの代わりに「^^」を入力してください（文字としてのスペースと区別するため）。
「^^」は「^」を２個続けて入力します。日本語キーボードの場合、「^」は仮名の「へ」のキー位置になります。

同時に複数のアプリケーションを起動させることはできません。その場合は「アプリ起動」をご利用ください。
登録可能なメッセージ文の数に制限はありません。


ワンライン送信

メッセージ、コマンド送信

メッセージ
「メッセージ」ボタンをクリックすると、クライアントリストボックスで選択されているクライアントに対して、メッセージ文を送ります。
クライアントではメッセージを表示する下記のようなダイアログボックスが表示されます。
送られるメッセージの内容はエディトボックスに表示されているテキスト文になります。

返信付メッセージ
「返信付メッセージ」ボタンをクリックすると、クライアントリストボックスで選択されているクライアントに対して、メッセージ文を送ります。
クライアントではメッセージを表示する下記のような返信機能付ダイアログボックスが表示されます。
送られるメッセージの内容はエディトボックスに表示されているテキスト文になります。
クライアントから返信される内容は送信文のエディットボックスに入力されたテキスト文になります。

コマンド
「コマンド」ボタンをクリックすると、クライアントリストボックスで選択されているクライアントに対して、プログラムの起動指示を送ります。
クライアントでは対応するプログラムが自動起動されます。
起動するプログラムはエディトボックスに表示されているフルパス表示のプログラムファイルになります。
（指定された位置にプログラムがない場合、起動指示は破棄されます。）

操作ガイド
250バイト以内の文字列をクライアントに対して送信することができます。
送信する内容は、単なるメッセージとプログラム起動コマンドの２つに分かれます。

【メッセージの場合】
まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括してメッセージを送ります。
エディットボックス内にクライアントに対して送信したいメッセージを所定の長さ以内で入力し、「メッセージ」または「返信付メッセージ」ボタンをクリックします。
エディットボックス右端の下向き矢印ボタンをクリックすると登録されているメッセージ文が表示されますので、その中から選択して利用することもできます。
対象クライアントのデスクトップ上には、送信したメッセージを表示したダイアログボックスが表示されます。
「返信付メッセージ」の場合、クライアントは送られてきたメッセージに対して返信することができます。返信せずに終了する場合は「閉じる」ボタンをクリックします。
簡易的なメッセージツールとしてご利用いただけます。

【コマンドの場合】
まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
第１行目の「すべての端末」を右クリックすると、クライアントリスト内のすべてのクライアントが反転選択されます。
第１行目の「すべての端末」を左クリックして選択すると、すべてのクライアントに対して一括してメッセージを送ります。
クライアントのディスク内に格納されているアプリケーションや、バッチファイルをリモートで起動、実行させることができます。
ただし実行するには、正確なファイルの格納位置を知っていなければなりません。
エディットボックス内にクライアントにて起動させたいアプリケーションファイルをフルパスで入力し、「コマンド」ボタンをクリックします。
エディットボックス右端の下向き矢印ボタンをクリックすると登録されているコマンド文が表示されますので、その中から選択して利用することもできます。

入力例1： c:\windows\system32\calc.exe （CドライブのWindows\system32ディレクトリにある「calc.exe」を実行します）
入力例2： c:\windows\system32\notepad.exe^^c:\boot.ini　（CドライブのWindows\system32ディレクトリにある「notepad.exe」を起動して、Cドライブのルートディレクトリにある「boot.ini」を読み込みます。）
入力例3： c:\temp\readme.txt　（CドライブのTempディレクトリにある「readme.txt」を開きます。"txt"に関連づけられているエディタが同時に起動されます。）
入力例4： c:\work\update.bat　（CドライブのWorkディレクトリにあるバッチファイル「update.bat」を開きます。）

コマンドにパラメータを付加したいときはスペースの代わりに「^^」を入力してください（文字としてのスペースと区別するため）。
「^^」は「^」を２個続けて入力します。日本語キーボードの場合、「^」は仮名の「へ」のキー位置になります。
ただし「^^」に変換するのは最初のスペースだけで、2個目以降のスペースはそのまま記述してください。

アプリケーションファイルだけでなく、バッチファイルの設定も可能ですが、パラメータを伴うことは出来ません。ご注意ください。
プログラムが起動したかどうかの確認は、「詳細情報」で行ってください。

送信文の登録、削除
一度送信したメッセージ文やコマンド文はリストに自動登録され、同様のメッセージ文の送信を行う時に再利用することが可能です。
登録されたメッセージ文の削除を行うには、[Ctrl]キーを押しながら該当のメッセージ文をクリックします。
よく使う送信文（メッセージ文、コマンド文）の登録を 「メッセージ登録.」でまとめて行う事が出来ます。

【ワンライン送信を利用したファイル配信】
ネットワーク内にクライアントが利用できるファイルサーバが存在する場合は、次の方法でファイルの配信を行うことが出来ます。

設定例
クライアントが利用できるサーバ名を「Server1」と仮定します。
まず「Server1」に対して下記の前処理を行います。
  ・配信用のファイルを格納するためのフォルダ「RemoteShare」を作成し、共有名を「RSHARE」とし、全クライアントに共有させます。

コントローラーから下記の手順を実行します。
  ・サーバーの「RemoteShare」フォルダに配信したいファイルをコントローラーからアップロードします。
  ・メッセージ入力欄に下記のコマンドを入力してクライアントに送信します。
    C:\Windows\System32\XCOPY.EXE \\Server1\RSHARE\*.* C:\*****
        （「C:\*****」にはファイルを格納するクライアント上のフォルダを指定します。）

以上の操作を実行することで、各クライアントの指定されたディレクトリにファイルが格納されます。
コントローラーにはいっさい負荷がかかりませんので、多くのクライアントにファイルの配信を行いたいときはこの方法をご利用ください。


音声メッセージ

クライアントに対して音声のメッセージを送信するには、次の手順に従います。

まず対象となるクライアントを選択します。
（複数選択可）グループ別の選択も可能です。

次に「音声メッセージ」ボタンをクリックすると、次のダイアログボックスが表示されます。

録音する音源（マイクやCD-ROMなど）の選択や音量調整はシステムに付属の「ボリュームコントロール」等で行ってください。
「録音開始」ボタンをクリックすると、メッセージの録音が開始されます。録音可能な時間は最大180秒となっています。
録音開始から180秒が経過すると、自動的に録音は終了します。180秒以内に録音を停止する場合は、「録音停止」ボタンをクリックします。
録音内容は一旦ファイルに記録されます。
録音内容を確認するには、「テスト再生」をクリックします。満足行く録音ができるまで、何度でも録音を繰り返すことができます。
最後に「送信」ボタンをクリックすると、録音した音声メッセージが指定したクライアントに転送され、自動的に再生が開始されます。
その後、メイン画面に戻ります。

「送信」ボタンの変わりに「キャンセル」ボタンをクリックすると、音声メッセージの録音、保存だけを行って送信は行われません。
録音した内容は新しい録音を行わない限り消去されることはなく、次回以降に再利用することができます。

録音内容はコントローラーがインストールされているフォルダに「bc.wav」というファイル名で記録されます。
送信する音声メッセージは別ソフトで作成したものを利用することもできます。
ただしファイル形式は必ずWAV形式で、再生時間が180秒以内になるようにしてください。
またファイル名は「bc.wav」でなければなりません。

ご注意
「送信」ボタンをクリック後、クライアントでメッセージの再生が開始されまで数秒～十数秒の時間を要します。（録音時間と内容に依存します。）
複数のクライアントに音声メッセージの送信を行った場合、クライアントの状態（マシンパフォーマンスなど）によって再生が開始されるタイミングが異なります。
音声メッセージの送信を行っても、クライアントマシンの状態やネットワークトラフィックの状態によっては正常に機能しない場合もあります。（再生しないクライアントが発生する。）
再生しないクライアントがある場合、配信調整を行うことで正常に機能する場合があります。
ルーターを介した他のセグメントには送信できません。（インターネットなど）


キャプチャー画像配信

キャプチャー画像の配信

コントローラーまたは任意のクライアントのデスクトップ画面をキャプチャーし、全クライアントに対して配信、表示させることができます。

コントローラー画像の配信
コントローラーのデスクトップ画像の配信を行うには、下記の手順に従います。
まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
次にキーボードから[Ctrl] + [PrintScreen]または[Ctrl] + [↑]（上向き矢印）をタイプします。
このときデスクトップ上にコントローラーのウィンドウが表示されている場合、直ちに最小化されタスクバーに格納されます。
よってコントローラーのメイン画面がキャプチャー画像に含まれることは有りません。
もちろんコントローラーが予め最小化された状態でキーボード操作することも可能です。

クライアントではデスクトップのサイズにちょうど合うようにリサイズされて表示されます。
クライアントのユーザーはこのウィンドウを最小化してタスクバーに格納したり、消去することができます。
クライアントにてキャプチャー画像が表示されている状態で再度キャプチャー画像の配信を行うと、前回のウィンドウは消去され最新の画像に自動更新されます。
クライアントにて表示されているキャプチャー画像をコントローラー側から消去したいときは、キーボードから[Shift] + [PrintScreen]または[Shift] + [↑]（上向き矢印）をタイプします。

クライアント画像の配信
クライアントのデスクトップ画像の配信を実行するには、まず対象となるクライアントを選択します。（複数選択はできません。）
次に[Ctrl]キーを押しながら、「詳細情報」ボタンをクリックします。画像の配信が開始されます。この時、状態欄には「配信中」と表示されます。

ご注意
配信を受けるクライアントのデスクトップ解像度が配信元（コントローラー）のデスクトップ解像度より低い場合、画像は縮小して表示されますのでディテールが失われる可能性があります。
本機能を御利用になるには配信元と配信先のデスクトップ解像度を同一にされることをお勧めします。
キャプチャー画像の表示には数秒～１０数秒の時間を要します。（デスクトップのサイズや表示内容によって異なります。）
クライアントマシンの状態やネットワークトラフィックの状態によっては正常に機能しない場合もあります。（配信されないクライアントが発生する。）
画像が表示されないクライアントがある場合、配信調整を行うことで正常に機能する場合があります。
ルーターを介した他のセグメントには配信できません。


プレゼンテーション

コントローラーのデスクトップ画像をプレゼンテーションモードで全クライアントに配信、表示させます。
基本的な動作はキャプチャー画像配信と同じですが、よりプレゼンテーション的に利用し易いように、下記のような機能や操作性を持っています。
連続してコントローラーのデスクトップ画面をクライアントに配信、呈示したいときにご利用いただくと便利です。

・配信された画像はクライアントのデスクトップ画面にフルサイズで表示される。
  この時、クライアントに表示されていたウィンドウはタスクバー等も含めてすべてマスクされます。
・コントローラーのマウスポインターの動きはリアルタイムにクライアントに反映され表示される。（リンクします。）
・画像の更新時間は約２、３秒と高速です。（初回表示のみ、約5、６秒要します。）
・この機能の動作中はクライアントがロックされ、使用者は一切の操作を行う事が出来なくなります。

操作ガイド
プレゼンテーションモードにて画像配信を行うには、次の手順に従います。
まず対象となるクライアントを選択します。（複数選択可）
グループ別の選択も可能です。
次にコントローラーのキーボードから[Ctrl] + [Shift] + [PrintScreen]または[Ctrl] + [Shift] + [↑]（上向き矢印）をタイプします。（初回のみ）
このときデスクトップ上にコントローラーのウィンドウが表示されている場合、直ちに最小化されタスクバーに格納されます。
よってコントローラーのメイン画面がキャプチャー画像に含まれることは有りません。

クライアントでは約５、６秒後に転送された画像が、あたかも自己のデスクトップ画像のようにデスクトップいっぱいのサイズで表示されます。
この時クライアントのタスクバーもマスクされ、キーボードおよびマウスはロックされ一切の操作が出来なくなります。
コントローラーのマウスポインタを動かすと、クライアントでもリアルタイムに同期してポインタが動きます。
画像の更新（再転送）を行うには、キーボードから[PrintScreen]をタイプするか、[Ctrl]キーを押しながら マウスを右クリックします。
マウス操作による方法では、クリック後にその操作に対応したウィンドウが表示されることがありますが、このウィンドウはクライアントに転送される画像には含まれません。
上記の操作後、クライアントの画像は約２～３秒後に更新されます。
以降、同様の処理（再転送）を繰り返すことが出来ます。

プレゼンテーションモードを解除するには、コントローラーのタスクバーに最小化されたコントローラーをクリックしてメイン画面を表示します。
クライアントでは、表示されていたコントローラーのデスクトップ画像が消去され、元のデスクトップ画像に復帰します。
ロックも自動的に解除され、利用者による操作が可能となります。

ご注意
配信を受けるクライアントのデスクトップ解像度が配信元（コントローラー）のデスクトップ解像度より低い場合、画像は縮小して表示されますのでディテールが失われる可能性があります。
本機能を御利用になるには配信元と配信先のデスクトップ解像度を同一にされることをお勧めします。
クライアントマシンの状態やネットワークトラフィックの状態によっては正常に機能しない場合もあります。（配信されないクライアントが発生する。）
画像が表示されないクライアントがある場合、配信調整を行うことで正常に機能する場合があります。
ルーターを介した他のセグメントには配信できません。


アプリケーションの起動、終了

アプリケーションのワンタッチ起動、終了

コントローラーからワンタッチでアプリケーションの起動や終了処理を行う事ができます。

アプリケーションの起動
起動させたいアプリケーションのウィンドウのタイトルバー（最上部）を[Alt] + ［Shiftl］キーを押しながら左クリックします。

アプリケーションの終了
終了させたいアプリケーションのウィンドウのタイトルバー（最上部）を[Alt] + ［Ctrl］キーを押しながら左クリックします。

ご注意
本機能を利用するには、コントローラーとクライアントにおいて、ディスク上の同じ位置（パス）に同一のアプリケーションプログラムが登録されている必要があります。
対象となるクライアントを選択することは出来ません。（すべてのクライアントに対して機能します。）


URLの配信

ブラウザURLの配信

コントローラーのWEBブラウザに表示されているページのURLを配信し、クライアントのブラウザでも同じページを表示させることが出来ます。

本機能を利用するには、コントローラーおよびクライアントにおいてWEBブラウザが起動されている必要があります。
URLの配信を行うには、コントローラーのデスクトップ上で[Ctrl + Shift] キーを押しながら、マウスを左クリックします。
クリックする場所は、デスクトップ上であればどこでもかまいません。
配信はすべてのクライアント同時に行われ、ブラウザにコントローラーと同じ内容が表示されます。

ご注意
本機能は、マイクロソフトのインターネットエクスプローラー（IE）のみに対応しています。
Netscape等では機能しませんのでご注意ください。


コマンドライン動作

コントローラーを起動せずに、コマンドライン操作によって各クライアントの制御を行うことができます。
バッチファイルやタスクスケジュールなどで利用することができます。
以下の機能がコマンドライン動作にて利用可能です。

  ・解除
  ・制御開始
  ・ロック
  ・ウェイクアップ
  ・リブート
  ・シャットダウン
  ・ログオン
  ・ログオフ
  ・メッセージ
  ・返信付メッセージ
  ・コマンド
  ・制御ファイル転送
  ・クライアント停止

コマンドライン動作は、コマンドラインプログラムの「GRAuto.exe」と実行するコマンドを記録したスクリプトファイルを組み合わせて利用します。
「GRAuto.exe」はコントローラーのインストールされているフォルダに格納されています。
スクリプトファイルはコントローラーをシミュレーション操作することで作成します。

スクリプトファイルの作成
・コントローラーを起動します。
・対象となるクライアントを選択します。（複数選択可能）
・[Ctrl]キーを押しながら、実行するコマンドボタンをクリックします。（メッセージ、コマンドなどの場合は送信文の入力後にそれぞれのボタンをクリック）
・記録ファイル名入力のダイアログボックスが表示されます。

・ファイル名を８バイト以内で入力し、「記録」ボタンをクリックします。（ファイル名に拡張子は付加しないでください。）
・入力したファイル名に拡張子「dat」が自動付加され、コントローラーがインストールされているフォルダに格納されます。

※1コマンドにつき1ファイルを作成します。複数のコマンドを連続して実行したい場合は、それぞれ上記の手順にて個別のスクリプトファイルを作成する必要があります。
記録中、クリックされたボタンの命令はクライアントには送信されません。

スクリプトファイルの実行
コマンドプロンプトから下記の書式でコマンドラインを入力します。
          GRAuto.exe スクリプトファイル名
（プログラム名とスクリプト名の間には必ず半角スペースを入れてください。スクリプトファイル名には拡張子「dat」が付加されています。）

  入力例： C:\Progra~1\007\GRemote\GRAuto.exe Wakeup.dat （フォルダ名はDOS形式で指定してください。）

ご注意
・コマンドライン動作を行う際はコントローラーは必ず終了させておいてください。（同時利用はできません。）
・バッチファイル等で連続して複数のコマンドを記述する場合は各コマンド間に十分なインターバル（間隔）を設定してください。
  例えば、「ウェイクアップ」を実行した後には数分のインターバルが必要でしょう。
・コマンドラインプログラムの「GRAuto.exe」とスクリプトファイルは、コントローラーがインストールされたフォルダ以外の場所に移動して実行することはできません。


電子メールを利用した操作

電子メールによるコントローラー操作

電子メールを利用してコントローラーの機能を外部から利用することが可能です。
コントローラーの持つ下記の機能が利用可能です。

1.リストの取得
  各クライアントの「コンピュータ名」、「ユーザー名」、「状態」、「起動時間」、「制御ファイル名」、「MACアドレス」を一覧で取得できます。
  現在誰がコンピュータを利用しているかが、一目瞭然です。

2.詳細情報の取得
  「起動中のウィンドウ」、「起動中のプロセス」、「サービス」、「インストールされているアプリケーション」を一覧で取得できます。

3.デスクトップ画像の取得
  クライアントのデスクトップ画像を取得できます。(サイズ指定可)

4.ビデオ画像の取得
  クライアントにビデオカメラが接続されている場合、カメラ画像を取得できます。(サイズ指定可)
  簡易的な監視カメラになります。

5.電源投入(ウェイクアップ)
  クライアントコンピュータの電源投入が可能です。

6.電源切断(シャットダウン)
  クライアントコンピュータの電源切断が可能です。

7.メッセージ送信
  クライアントコンピュータのデスクトップ上にメッセージを表示させることが可能です。

8.コマンド送信
  クライアント上でアプリケーションを起動したり、バッチファイルを実行したり出来ます。

9.ウィンドウの強制消去
  クライアントで実行中のアプリケーションやウィンドウを強制的に終了させることが可能です。

10.ロック
  クライアントコンピュータのキーボードおよびマウスをロックしたり、解除したり出来ます。

11.制御
  制御ファイルの内容に従ってクライアントの利用制限を行ったり解除したり出来ます。
  制御ファイルの変更も可能です。

動作のしくみ
「電子メールによるコントローラー操作」は、所定の書式で記述されたコマンドメールを、予め設定されたメールアドレスに対して送信することで実行されます。
コントローラープログラムは一定間隔でメールのチェックを行い、コマンドメールを受信した場合はその記述内容に従ってコマンドを実行します。
コマンドが情報取得の命令(リスト取得やデスクトップ画像取得など)であった場合、クライアントから取得された情報を指定されたメールアドレスに返信します。

メール環境設定
メールアドレス、メールサーバなどの動作環境の設定を事前に行います。
「コントローラー設定」ボタンをクリックすると、下記の設定画面が表示されます。
「メール制御」の項目を設定してください。

接続確認
「接続確認」ボタンをクリックすると、メールサーバーとの接続確認を行います。
ただし、メールアカウントのパスワードチェックまでは行いませんのでご注意ください。

メール制御を行う
「メール制御を行う」のチェックをオンにし「保存終了」すると、設定されたメールアドレスに対する巡回チェックが開始され、本機能が利用可能になります。
チェックをオンにする際は、各設定値を確認し、「接続確認」を行って異常がないことを必ず確認してください。
本機能を利用しない場合はチェックをオフにしてください。

メールアドレス
本機能で利用するメールアドレスを入力します。

メールアカウント
メール受信時のアカウントを入力します。

メールパスワード
メール受信時のパスワードを入力します。

POP3サーバー
受信のためのメールサーバーを入力します。

SMTPサーバー
送信のためのメールサーバーを入力します。

実行パスワード
コマンドを実行するためのパスワードを入力します。
メール内に記述されたパスワードと一致しない場合は、コマンドは実行されません。
セキュリティーのため、必ず設定するようにしてください。

返信メールアドレス(オプション)
情報を返信する為のメールアドレスを指定します。
本項目に設定がある場合、無条件にそのアドレスに対してのみ情報の返信を行います。
入力がない場合は、コマンドメールの内容に従います。

メールチェック間隔
コントローラーがメールサーバーと接続し、メールチェックを行う間隔を入力します。(1～9999秒)
「接続」、「メールチェック」、「切断」に必要な時間以上の値を設定してください。
設定値がメールチェックに必要とされる時間より短いと、不具合が発生する可能性があります。
デフォルト値は10秒となっています。

コマンドメールの書式
コマンドメールは下記の書式で記述されている必要があります。(本文は全５行)
記述内容に誤りがあると、コマンドは実行されません。

宛先メールアドレス
コントローラーの「メール環境設定」において登録した「メールアドレス」を宛先アドレスとして指定してください。

件名
コマンドメールでは利用しません。任意の値を入力してください。

本文
  本文には以下の情報が記述されている必要があります。

  実行パスワード(１行目)
  コントローラーの「メール環境設定」において登録した「実行パスワード」を入力してください。

  対象クライアントのコンピュータ名(２行目)
  複数のコンピュータを対象としたいときは、各コンピュータ名を半角のカンマ[ ,]で区切って入力してください。
  また、クライアントリストに登録されている全てのクライアントを対象としたいときは半角で[ALL]と入力してください。
  ただし、「WList」、「PList」、「SList」、「AList」、「PICD」、「PICV」のコマンドについては、複数指定することは出来ません。

  実行するコマンド(３行目)
  コマンドは全て半角英字で入力してください。
  下記のコマンド一覧を参照してください。

  コマンドのパラメータ(４行目)
  下記のコマンド一覧を参照してください。

  返信先のメールアドレス(５行目) (コマンドが「LIST1」、「LIST2」、「WList」、「PList」、「SList」、「AList」、「PICD」、「PICV」の場合のみ有効)
  情報を返信するメールアドレスを入力してください。
  メールを送信したアドレスに対して返信させる場合は、ブランクでも結構です。(改行は必要)
  複数のメールアドレスに対して返信させる場合は、各メールアドレスを半角のカンマ[ ,]で区切って入力してください。

コマンド一覧

コマンド | コンピュータ名 | パラメータ | 説明
LIST1 | 記述不要 | なし | 現在のクライアントの利用状況を取得します。 各クライアントごとに、「コンピュータ名 , ユーザー名 」のフォーマットでリスト表示されます。 ユーザー名がブランクの場合、そのクライアントは稼働していないことを示します。
LIST2 | 記述不要 | なし | 現在のクライアントの利用状況を取得します。 各クライアントごとに、「コンピュータ名 , ユーザー名 , 状態, 起動時間, 制御ファイル名, MACアドレス」のフォーマットでリスト表示されます。 ユーザー名および状態欄がブランクの場合、そのクライアントは稼働していないことを 示します。
WList | コンピュータ名 (１つのみ) | なし | 起動中のウィンドウの一覧を取得します。
PList | コンピュータ名 (１つのみ) | なし | 起動中のプロセスの一覧を取得します。
SList | コンピュータ名 (１つのみ) | なし | 登録されているサービスの一覧を取得します。(NT系OSのみ)
AList | コンピュータ名 (１つのみ) | なし | インストールされているアプリケーションの一覧を取得します。
PICD | コンピュータ名 (１つのみ) | JL J1 J2 BL B1 B2 JFxxx,yyy BFxxx,yyy | 「JL」を指定すると、クライアントのデスクトップ解像度のサイズでJPEG形式のデスクトップ 画像を取得します。 「J1」を指定すると、267×199ドットのサイズでJPEG形式のデスクトップ画像を取得します。 「J2」を指定すると、133×100ドットのサイズでJPEG形式のデスクトップ画像を取得します。 「BL」を指定すると、クライアントのデスクトップ解像度のサイズでBMP形式のデスクトップ 画像を取得します。 「B1」を指定すると、267×199ドットのサイズでBMP形式のデスクトップ画像を取得します。 「B2」を指定すると、133×100ドットのサイズでBMP形式のデスクトップ画像を取得します。 「JFxxx,yyy」の書式で指定すると、xxx×yyyドットのサイズでJPEG形式のデスクトップ画像 を取得します。(最大 267×199ドット) 「BFxxx,yyy」の書式で指定すると、xxx×yyyドットのサイズでBMP形式のデスクトップ画像 を取得します。(最大 267×199ドット)
PICV | コンピュータ名 (１つのみ) | J1 J2 B1 B2 JFxxx,yyy BFxxx,yyy | 「J1」を指定すると、267×199ドットのサイズでJPEG形式のビデオカメラ画像を取得します。 「J2」を指定すると、133×100ドットのサイズでJPEG形式のビデオカメラ画像を取得します。 「B1」を指定すると、267×199ドットのサイズでBMP形式のビデオカメラ画像を取得します。 「B2」を指定すると、133×100ドットのサイズでBMP形式のビデオカメラ画像を取得します。 「JFxxx,yyy」の書式で指定すると、xxx×yyyドットのサイズでJPEG形式のビデオカメラ画像 を取得します。(最大 267×199ドット) 「BFxxx,yyy」の書式で指定すると、xxx×yyyドットのサイズでBMP形式のビデオカメラ画像 を取得します。(最大 267×199ドット)
WAKE | コンピュータ名 (ALLも可) | なし | クライアントの電源を投入します。(Wake on LAN)
SHUT | コンピュータ名 (ALLも可) | なし | クライアントの電源を切断します。(シャットダウン)
MSG | コンピュータ名 (ALLも可) | メッセージ文 | クライアントのデスクトップ上にメッセージ文を表示します。
RUN | コンピュータ名 (ALLも可) | コマンド文 | クライアントにて、アプリケーションを起動したり、バッチファイルを実行します。 コマンド文の記述方法は「コマンドの送信」を参照してください。
CLOSE | コンピュータ名 (ALLも可) | キャプション | クライアントにて、指定したキャプション名を持つウィンドウを消去します。 「ウィンドウ消去」を参照してください。
LOCK | コンピュータ名 (ALLも可) | なし | クライアントのキーボード、マウスをロックします。
UNLOCK | コンピュータ名 (ALLも可) | なし | クライアントのキーボード、マウスをロック解除します。
Control | コンピュータ名 (ALLも可) | なし | クライアントの制御を開始します。
Release | コンピュータ名 (ALLも可) | なし | クライアントの制御を解除します。
CFile | コンピュータ名 (ALLも可) | 1～9 | 制御ファイルの設定を行います。
QUIT | コンピュータ名 (ALLも可) | なし | メールチェックの動作を強制終了します。(緊急時操作) 再開するには、コントローラーを手動で再起動させる必要があります。

ご注意
・本機能を利用するには、コントローラープログラムが起動している必要があります。
・コマンドメールの本文は、必ず５行のデータで構成されている必要があります。
・パラメータ入力の必要がないコマンドの場合でも、必ず改行は行ってください。
・コントローラーがメールチェックを行った際、複数のメールが存在した場合、最後に送信されたコマンドメールのみ実行します。
・コントローラーがメールチェックを行った後は、既読、未読に関係なく、全てのメールがサーバーから削除されます。
コントローラーがチェックするメールアドレスは、本機能専用のアカウントを作成されることを強くお勧めします。
・実行パスワードは必ず設定してください。設定がない場合は、誰でも利用可能な状態となり大変危険です。
・取得された画像は、メールの添付ファイルとして送信されます。
  携帯電話にて受信する場合は、ファイルサイズと画像形式にご注意ください。
  取得できる画像は、最大384×288の解像度になります。(デスクトップ、ビデオカメラ画像とも)

コマンドメール入力例１
下記のコマンドメールを送信すると、クライアントリストに登録されている全てのクライアントパソコンの電源が投入されます。
  本文
  １行目：himitsu123
  ２行目：ALL
  ３行目：WAKE
  ４行目：
  ５行目：

コマンドメール入力例２
下記のコマンドメールを送信すると、コンピュータ名が「WS-1」というクライアントのデスクトップ画像を120×90ドットのサイズで取得します。
画像の形式はJPEGになります。
画像は「desktoppc@wayd.com」および「keitaidenwa007@ezweb.ne.jp」に返信されます。
  本文
  １行目：himitsu123
  ２行目：WS-1
  ３行目：PICD
  ４行目：JF120,90
  ５行目：desktoppc@wayd.com,keitaidenwa007@ezweb.ne.jp

コマンドメール入力例３
下記のコマンドメールを送信すると、クライアントリストに登録されている全てのクライアントパソコンのデスクトップ上にメッセージを表示します。
  本文
  １行目：himitsu123
  ２行目：ALL
  ３行目：MSG
  ４行目：残業、遅くまでご苦労様です。最後に退出される方は、施錠を忘れないでください。(管理者より)
  ５行目：


複数コントローラーの運用

同一ネットワーク内で、複数のコントローラーを運用することは可能です。
ただし、運用方法によって下記のような点に留意する必要があります。

クライアントを会社の部署単位や学校の教室単位などでグループ分けし、それぞれを個別のコントローラーで管理する場合
それぞれのグループごとに異なるポート番号の設定が必要となります。
クライアントリストに登録がなくても、IPマルチキャストによる一括送信（すべての端末を選択）を行うと、同一ネットワークにて稼動しているすべてのクライアントに命令が送られ実行されます。
ポート番号が異なれば、これらの不都合を回避することが出来ます。

同一クライアントを複数のコントローラーで管理したい場合
複数のコントローラーに同一のクライアントを登録しておき、それぞれのコントローラーから同じように管理を行いたいときは、下記のような特性を理解しておく必要があります。
・コントローラーはプログラムの開始時と、「リフレッシュ」ボタンがクリックされた際に、クライアントに対してコントローラーが起動したことを示す確立パケットを送信します。
・クライアントではこの確立パケットを受け取ると、送られてきたコントローラーのIPアドレスなどを記憶します。
・クライアントはコントローラーから送られて来た各命令に対して、その処理結果の返信をする際、記憶しているコントローラーのIPアドレスに対して行います。

複数のコントローラーが同時に起動している状態で運用する際、上記の仕様によりコマンドを送信したにも拘わらず、その結果がリスト上に反映されないことがあります。
それは他のコントローラーがそのクライアントに対する主導権を持っているためです。
このような時は「リフレッシュ」ボタンをクリックすれば、それ以降はそのコントローラーが主導権を持つことになります。


プライバシー保護とステルス動作

クライアントパソコンを利用するユーザーのプライバシーを保護するため、下記のような機能が搭載されています。

警告文の表示

起動時に下記のような警告文を表示することが出来ます。

クライアントプログラムの停止

クライアントパソコンの使用者は任意にクライアントプログラムを停止することが出来ます。

タスクトレーにある「Guardian」のアイコンを右クリックするとメニューが表示されます。

「停止」選択すると、直ちにクライアントプログラムは停止し、コントローラーからのアクセスは一切出来なくなります。
クライアントプログラムの実行を再開するには、同様にアイコンを右クリックして「開始」を選択します。
クライアントプログラムが停止状態のままパソコンの再起動を行った場合、自動的にクライアントプログラムは開始されます。

クライアントプログラムをインストール直後の状態では、このプライバシー保護機能は無効となっています。
プライバシー保護機能を動作させるには、コントローラーにて下記の手順を実行します。
    ・対象となるクライアントをリストから選択します。（複数選択可）
    ・メッセージ入力欄に「PRIVACYON」と入力し、「コマンド」ボタンをクリックします。
    ・クライアントの次回起動時からプライバシー機能が有効となります。（下記の停止処理を実行するまで継続します。）

一方、プライバシー保護機能を停止したいときは、下記の手順を実行します。
    ・対象となるクライアントをリストから選択します。（複数選択可）
    ・メッセージ入力欄に「PRIVACYOFF」と入力し、「コマンド」ボタンをクリックします。
    ・クライアントの次回起動時からプライバシー機能が無効となります。

ご注意
プライバシー保護機能が無効の状態では、クライアントのデスクトップにはクライアントプログラムが実行中であることを示すものは何もなく、ステルス動作となります。
管理者の方は使用者のプライバシー保護について、十分に配慮した運用をお願いします。


ユーザー登録

ライセンス登録、購入方法

Guardianはシェアウェアです。
本ソフトウェアの試用期間は、初回インストールの日から３０日間です。試用期間内はすべての機能を制限なく利用することができます。
試用期間が経過した後、本ソフトウェアを継続して使用したい場合はユーザー登録を行わなければなりません。
ユーザー登録をするには、次に説明する手順でライセンス番号の登録を行っていただきます。。

ライセンス登録手順
・使用料金を支払う（下記の送金方法を参照）
・製品固有の番号であるプロダクトＩＤを開発者に通知する。（通知方法は電子メールで行うことができます。ライセンス番号申請フォームをご利用ください。）
・後程、開発者よりライセンス番号が送られてきます。（原則として平日２４時間以内）
・ライセンス番号をシステムに登録します。

プロダクトＩＤの取得及びライセンス番号の登録方法は「ライセンス登録方法」をご参照ください。

「Guardian」のプロダクトIDおよびライセンス番号は機器固有のものとなっています。
ライセンスの申請を行うときは、必ず最終的にご利用になるマシンにてプロダクトＩＤの取得を行ってください。
申請後にマシンの変更を行った場合は、発行されたライセンス番号は無効となります。
機器変更に伴うライセンス番号の再発行は、初回の発行を含めて１ライセンスにつき、年１回までは無償とさせていただきます。
１年以内に複数機器のリプレースをご計画の方は、事前に「Guardianサポート」までご相談ください。

使用料金 (インストールする１クライアントマシンにつき、１ライセンスが必要です。コントローラーにはライセンスは必要ありません。）
１ライセンス・・・・・・・・・・・2,100円(消費税込み)

ボリュームディスカウント（一括購入の場合）
１０ライセンスパック・・・・・・・・・・15,750円 (消費税込み)
５０ライセンスパック・・・・・・・・・・52,500円 (消費税込み)
フリーライセンス版・・・・・・・・・・525,000円 （クライアント数に制限のないノンプロテクトバージョンです。）(消費税込み)

※１０ライセンス以上をご購入の場合、ご要望により使用権を証明するためのライセンス証書を発行させていただきます。（無償）
※ボリュームディスカウントをご利用の方はサポートまでお問い合わせください。

送金方法
【銀行振り込み】
銀行振り込みにて送金をご希望の方は、ご面倒でもサポートまでメールにてお問い合わせください。
直ちに振込先等のご案内をさせていただきます。
また、企業、各種団体などで見積書、請求書、領収証が必要な方も、遠慮なくお申し出ください。

【業者扱い】
企業、教育機関、官公庁などで直接のご購入が困難な場合、出入り業者扱いでご購入いただくことも可能です。
具体的にはサポートまでお問い合わせください。

下記の支払い方法もご利用いただけますが、１度に複数のライセンスを購入することはできません。

【Vector シェアレジ】
（株）ベクターが提供するシェアウェア代金の送金サービスです。
クレジットカードをお持ちの方ならどなたでも簡単に送金できます。
シェアレジ番号は【 ＳＲ００８５６３ 】です。

試用版の制限について
本ソフトウェアは前述の試用期間内であれば、全機能が無制限に利用できます。
試用版はライセンス登録することにより、そのまま正規版としてご利用いただけます。


ライセンス登録方法

多数のクライアントのライセンス登録を行うには「一括ライセンス登録」による方法がご便利です。

「Guardian」のプロダクトIDおよびライセンス番号は機器固有のものとなっています。
ライセンスの申請を行うときは、必ず最終的にご利用になるマシンにてプロダクトＩＤの取得を行ってください。
申請後にマシンの変更を行った場合は、発行されたライセンス番号は無効となります。
機器変更に伴うライセンス番号の再発行は、初回の発行を含めて１ライセンスにつき年１回までは無償とさせていただきます。
１年以内に複数機器のリプレースをご計画の方は、購入前に「Guardianサポート」までご相談ください。

Guardianのライセンス番号はOSの再インストールやハードディスクの交換を行っても変わりません。
購入時に登録したライセンス番号をそのまま入力していただければ結構です。
万一、ライセンス番号を忘れてしまった場合は、再度プロダクトIDをお知らせいただければ無償で再発行いたします。

プロダクトＩＤの取得方法
クライアントがインストールされているフォルダ内にある「GRegist.exe」を起動します。
下記のようなダイアログボックスが表示されます。
画面最上部のタイトルバー左端にある小さなアイコンをクリックします。

プルダウンメニューの中からユーザー情報をクリックすると下記のようなライセンス情報のダイアログボックスが表示されます。

マシン固有のプロダクトＩＤ番号が上段のボックスに表示されます。
ライセンスの申請はこのプロダクトＩＤをご通知ください。

ライセンス番号の入力方法
上記のダイアログボックス内の下段にあるライセンス番号入力ボックスに開発者より通知されたライセンス番号を入力し、「登録」ボタンをクリックします。
正しいライセンス番号が入力されますと、ユーザーとして無事登録された旨を示すメッセージが表示されます。
間違ったライセンス番号が入力されると警告を発しますので、開発者から送られてきたライセンス番号をよく確かめた後、再入力してください。
正しいライセンス番号を入力しているにも拘わらずエラーとなる場合は、開発者までご連絡ください。


一括ライセンス登録

多数のクライアントのライセンス登録を一括で行うことができます。
この方法をご利用いただければ、いちいち各クライアントのプロダクトIDをお調べいただく必要がなくなります。
自動登録は下記の手順にて行われます。

１．コントローラーを起動します。
２．ライセンス登録するすべてのクライアントがリストに登録されていることを確認します。（クライアントが起動している必要はありません。）
３．「すべての端末」を選択し、「リフレッシュ」ボタンをクリックします。
４．「CTRL」キーを押しながら「クライアント登録」ボタンをクリックします。
５．コントローラーをインストールしたフォルダ内に作成されたユーザー登録ファイル「ProductID.dat」をメールの添付ファイルとして「Guardianサポート」まで送付します。

後ほど「Guardianサポート」より、ライセンス情報が格納されたファイル「License.dat」がメールの添付ファイルとして届きます。

１．コントローラーを起動します。
２．ライセンス登録するすべてのクライアントを起動します。（ユーザー名の表示を確認）
３．「すべての端末」を選択し、「リフレッシュ」ボタンをクリックします。
４．「Guardianサポート」より届いた「License.dat」をコントローラーがインストールされているフォルダにコピーします。（「ProductID.dat」があったところ）
５．「CTRL」 + 「SHIFT」キーを押しながら「クライアント登録」ボタンをクリックします。
６．ライセンス情報が各クライアントに送られ、自動登録されます。

以上の操作でクライアントのライセンス登録は完了します。

ご注意

・コントローラーが複数ある場合は各コントローラーごとに上記の作業を行ってください。（「ProductID.dat」および「License.dat」もコントローラーごとに用意します。「ProductID.dat」をお送りいただく際には、適当にリネームしていただいて結構です。「ProductID1.dat 」、「ProductID2.dat 」など）
・「ProductID.dat」はテキストファイルですので、「メモ帳」などで開いて確認してください。万一ファイルに登録された件数が、実際よりも少ない場合は何らかの障害が考えられます。（取りこぼしなど）
・ライセンスの申請は何回に分けて行っていただいても結構です。その際、追加分のクライアントだけが登録された「ProductID.dat」をわざわざ作成する必要はありません。すでに登録済みのクライアントが含まれた「ProductID.dat」をお送りいただければ結構です。ライセンスの登録は同一のクライアントに対して何度重複登録しても支障はありません。


ライセンス番号申請フォーム

・電子メールのタイトルは必ず"Guardian License"としてください。
・電子メール本文の内容は、必ず下記の事項をご記入ください。

（万一記入漏れがありますと、ライセンス番号の発行が遅れる場合がございます。）

---------------------------------------------------------------

ライセンス番号申請様式

《記入必須項目》

登録申請者氏名：

会社名又は団体名：

電子メールアドレス：

送金方法：

送金名義：

送金日：

プロダクトＩＤ：

---------------------------------------------------------------

下記の事項の記入は任意です。

ご住所：

電話番号：

使用機器

（メーカー）：

（ＯＳ）：

（主記憶容量）：


サポート

Guardianに関するご質問、ご意見などはサポートまで電子メールにてお問い合わせください。
また下記のGuardianホームページにおいて、最新情報の入手や最新バージョンのダウンロード などが行えます。
http://007.jp/jp/


利用規約

本ソフトウェアをご利用いただくには、下記の事項をご確認、ご承認いただきます。
ご承認いただけない場合は、本ソフトウェアに関するすべてを破棄していただきます。
また、すでに支払われた使用料の返還はできませんので、ご注意ください。

1.本ソフトウェアの試用期間は、初回インストールの日から起算して30日以内とします。

2.本ソフトウェアの試用版の複製、及び再配布は、何人も自由に行うことができるものとします。

3.本ソフトウェアを試用期間経過後、継続して使用する場合は開発者又は販売者の指定した方法で、所定の使用料金（ライセンス料）を使用者は支払うものとします。

4.本ソフトウェアの使用権は１ライセンスにつき１マシン（機器）とします。

5.使用者はいかなる理由においても、本ソフトウェアを改造またはリバースエンジニアリングすることはできません。

6.使用者は開発者又は販売者の許可なく、第三者に本ソフトウェア及びその複製を移転したり、使用権の譲渡をする事はできません。

7.本ソフトウェアを使用したことにより発生したいかなる損害に対しても、開発者及び販売者は一切その責任を負わないものとします。

8.本ソフトウェアの所有権及び著作権は、大泉真一に帰属します。


動作異常

動作がおかしい

Guardianの機能の一部またはすべてがうまく動作しない場合、症状によって様々な原因が考えられます。
インストールは正常に終了したにもかかわらず、うまく動作しない時の一番の原因としては、システムモジュールのバージョンがあります。
「Guardian」はWindowsAPIの最新関数を利用していますので、システムモジュールが古いと誤動作することがあります。
特に「MSVCRT.DLL」と「MFC42.DLL」が古いと、多くの障害が発生します。先ず、システムモジュールを最新の状態に更新してから再度動作確認を行ってみてください。

「クライアント登録」ができない

クライアントの登録方法には「自動登録」と「手動登録」の２種類があります。通常はクライアントを動作させておいた状態で、「自動登録」によってクライアントの登録を行う方法が一般的です。「自動登録」によってクライアントが認識できない場合は、下記の障害が考えられます。

・クライアントが起動していない。
クライアントが起動しているかどうかをデスクトップ上で確認する方法はありません。OSがWindows NT, Windows 2000, Windows XPの場合は、タスクマネージャを利用することで動作確認ができます。プロセス一覧に「GClient.exe」があれば、クライアントは動作しています。OSがWindows98,Meの場合は「システム情報」の実行中のタスクで同様に確認することができます。（「システム情報」はOSインストール時のオプションです。）

・通信に障害がある
先ずコントローラーとクライアント間で「PING」の確認を行ってください。「PING」が通らない場合は通信環境の設定を確認してください。またシステムが「Guardian」の動作環境を満たしているか、今一度確認してください。
確率的には低いのですが、ポート番号の設定も念のためご確認ください。他の通信ソフトと重複している場合は障害が発生することがあります。またポート番号を初期設定から変更してご利用の場合は、クライアントとコントローラーのポート番号が合致しているかも確認してください。

キャプチャー画像の表示ができない

「Norton Internet Security」、「ウイルスバスター」、「Black ICE」などローカルパソコン上で動作するファイアウォールソフトをコントローラーまたはクライアントにてご利用の場合、画像転送用のパケットがブロックされることがあります。
ファイアウォールソフトの設定を変更すれば、キャプチャー画像を問題なく表示することができるようになります。

「レジストリ変更」ができない
「レジストリ変更」を行ってもクライアントで内容が反映されない場合は、次の点を確認してください。

・リブートしているか
レジストリの変更は多くの場合、システムの再起動を行わないと有効にはなりません。「リブート」をご利用ください。

動作が安定しない （クライアントに対する各種制御コマンドが、実行されたり、されなかったりする。）
クライアントパソコンにおいて節電機能などが働いていると、コントローラーからのコマンドをミスする事があります。
コントローラーから発出したパケット（コマンド）が何らかの理由で消失した場合、コントローラーは自動再送いたしません。ご注意ください。
クライアントで節電機能などが働いている場合、レスポンスが極端に遅れる場合があります。制御を確実にするためには、コマンド発出前に「リフレッシュ」を行うことが有効です。また時々、すべての端末に対して「リフレッシュ」を行うこともよい手段でしょう。

「ウェイクアップ」、「電源切断（シャットダウン）」が機能しない
ウェイクアップを実現するには、クライアントが「Wake On LAN」に対応していなければなりません。対応しているかどうかはメーカー製パソコンの場合はそのメーカーにお問い合わせください。自作パソコンの場合はマザーボード、ネットワークカード、PCケース（電源）のすべてがWOL対応になっていなければなりません。また部品によっては相性（？）も存在するようです。
シャットダウンしても電源切断しない場合、次のケースが考えられます。
・パソコンに電源管理機能が無い。
・OSがWindowsNT4.0である。
「HAL.DLL」というシステムモジュールが自動電源切断に対応していなければなりません。「HAL.DLL」は各パソコンメーカーから供給されます。（無いメーカーも多い）
特に「Multi CPU」搭載パソコンの場合は失敗するケースが多いようです。

応答しないクライアントがある
複数のクライアントに対してコマンドを送出した際、一部のクライアントが応答しないことがあります。
これには次のような原因が考えられます。

・クライアントが省電力機能などによりスリープ状態にあるとき。
・ネットワークトラフィックが高負荷のとき。

パソコンの省電力機能が働いてスリープ状態にあるときは、コントローラーからのコマンドに対して応答しないことがあります。
このようなクライアントに対してコマンドの再送を行っても反応しない場合は、ネットワーク機能が停止していることが考えられます。
パソコンの省電力機能を確認してください。

第１行目の「すべての端末」を左クリックしてコマンドの送出を行ったときにこのような障害が発生した場合は、パケットの取りこぼしが考えられます。
その際は「すべての端末」を右クリックしてすべてのクライアントを反転選択した状態でコマンドの送出を行ってみてください。
この方法で問題が解決するようなら、ネットワーク上の問題（固有特性）が考えられます。


配信調整

クライアントパソコンの状態やネットワーク環境によっては、すべてのクライアントパソコンに画像や音声メッセージの配信が行えないことがあります。
その際は通信パラメータを調整することで、配信の信頼性を向上させることができます。

調整はコントローラーパソコンにて行います。
まず、コントローラーがインストールされているフォルダ内にある「SetCFT.exe」を起動します。
その際、、コントローラーのプログラムを終了させる必要はありません。

調整項目には「サイズ」と「タイミング」の２種類があり、それぞれ係数の設定を行います。
サイズの初期値は31、タイミングの初期値は10 となっています。
サイズは１パケットのバイト数に関係する設定値で、1～33までの値が設定可能です。
サイズを大きな値にするとパケットサイズが大きくなり、結果として短い時間で転送を完了することが可能となります。
逆に設定値を小さな値にすると、転送時間は長くなります。設定値を最大値の33に設定すれば、最高のパフォーマンスが得られます。
配信されないクライアントパソコンがある場合は、5～10程度の値に設定して動作検証されることをお勧めします。

タイミングはパケットの送信タイミングに関係する設定値で、1～99までの値が設定可能です。
タイミングを大きな値にすると各パケットの間隔が長くなり、結果として転送にはより多くの時間が必要となります。
逆に設定値を小さな値にすると、転送時間は短くなります。設定値を4以下にすると、障害が発生する可能性が高くなります。
配信されないクライアントパソコンがある場合は、30～50程度の値に設定して動作検証されることをお勧めします。

それぞれの項目を入力し「登録」ボタンをクリックすると、設定値が保存され、次回以降その設定値での転送が行われます。
コントローラーのプログラムを再起動する必要はありません。

「初期化」ボタンをクリックすると、それぞれインストール直後の初期値に戻ります。

ご注意
配信の調整を行っても、クライアントマシンの状態やネットワークトラフィックの状態によっては正常に機能しない場合もあります。


自動ログオン

クライアントがログオフの状態にあるとき、そのクライアントに対してログオン指示を送ることができます。
ただし、この機能が利用できるのは、クライアントのOSがWindows NT, Windows 2000, Windows XPでサービスとして登録、実行されている場合です。（Win95,98,Meは無効）

まず「ユーザー名」、「パスワード」、「ドメイン」に所定のデータを入力します。
まず対象となるクライアントをマウスでクリックして選択します。（複数選択可）
第１行目の「すべての端末」を選択すると、すべてのクライアントに対して指示を送ります。
次に「ログオン」ボタンをクリックすると、クライアントではログオンの動作が行われます。
ログオンが完了すると状態欄には「解除」のメッセージが表示され、正常にログオン操作が行われたことを知らせます。
また動作時刻欄にはログオンされた時刻が表示されます。
万一、上記の表示が得られない場合は、クライアント上でクライアントプログラムが起動していないか、通信上の障害が考えられますので、ご確認ください。

ご注意
「自動ログオン」の機能はクライアントマシンのレジストリに自動ログオンの設定を行うことで実行されます。クライアントは「ログオン」の指示を受け取った後、一度リブートの動作を行い、その後指定されたログオン情報で自動ログオンされます。よって「ログオン」の指示後、再度通信が確立するまでかなりの時間を要しますのでご注意ください。

クライアントではレジスリに登録されたログオン情報を元にログオン処理を行いますが、一度ログオンが完了しますとレジストリの内容は「ログオン」の指示を受け取る前の状態に自動復帰するようになっています。

入力されたログオン情報はコントローラー側で記録され、次回以降コントローラーを起動したときに再表示されます。
画面からログオン情報を消去したいときは、入力ボックスを空欄にしてから「ログオン」ボタンをクリックすることで内部記録されているデータは消去されます。
この操作は起動していないクライアントを選択した状態で行うとよいでしょう。


パソコン利用制限

クライアントパソコンを利用できるユーザーを制限することができます。
利用権限のないユーザー名でログオンしてパソコンを利用しようとすると、警告メッセージが表示されてユーザーはそのパソコンの利用ができなくなります。
パソコン利用の制限を行うには下記の手順に従います。

  １．利用制限方法の指定
  ２．ユーザーリストの作成
  ３．利用制限を開始する。（スイッチをONにする）

１．利用制限方法の指定
利用権限のないユーザーを検出したときの動作方法を指定します。
設定は「環境設定」にて行います。

２．ユーザーリストの作成
利用を制限するユーザーは事前にコントローラー側にファイルとして登録しておきます。
利用制限の登録方法（ユーザーリスト）には二種類あります。

    １．利用を禁止するユーザー名をファイルに登録しておく方法
        利用を禁止したいユーザー名があらかじめ分かっている場合に利用できる手段です。
        利用を禁止したいユーザー名を「NGUser.dat」というテキストファイルに登録します。
        ファイルに登録されているユーザー名でクライアントにログオンした場合、利用制限の機能が働きます。
        登録は「メモ帳」などのテキストエディタを利用して行ってください。記述は下記のルールに従ってください。
          ・1ユーザー名につき、１行を使用してください。（ユーザーごとに改行）
          ・ユーザー名は大文字、小文字など厳格に識別されますので、正確に入力してください。
          ・空白行は絶対に入れないでください。
          ・最大登録数は1,000ユーザーです。
          ・ユーザー名を何も入力せずにログオンしたユーザーを利用禁止にしたい場合は、ユーザー名に UnknownUser と入力してください。

    ２．利用を許可するユーザー名をファイルに登録しておく方法
        この方法は利用者を限定する上で極めて有効な手段ですが、あらかじめ許可を与えるユーザー名をすべて登録しておく必要があります。
        登録漏れがあると、そのユーザーは一切利用できなくなりますのでご注意ください。
        利用を許可するユーザー名を「OKUser.dat」というテキストファイルに登録します。
        ファイルに登録されていないユーザー名でクライアントにログオンした場合、利用権限がない旨のメッセージが表示された後、自動的にそのパソコンはシャットダウンします。
        登録は「メモ帳」などのテキストエディタを利用して行ってください。記述は下記のルールに従ってください。
          ・1ユーザー名につき、１行を使用してください。（改行）
          ・ユーザー名は大文字、小文字など厳格に識別されますので、正確に入力してください。
          ・空白行は絶対に入れないでください。
          ・最大登録数は1,000ユーザーです。
          ・ユーザー名を何も入力せずにログオンしたユーザーに利用許可を与えたい場合は、ユーザー名に UnknownUser と入力してください。
        この方法を利用しない場合は、「OKUser.dat」の内容をすべて消去するか、「OKUser.dat」ファイルそのものを削除しておいてください。
        １行でも登録されたユーザーがある場合は、登録のないユーザーすべてに対して利用制限の機能が働いてしまいます。

３．利用制限を開始する。（スイッチをONにする）
利用制限を開始するには、「ユーザー制限」ボタンをクリックします。ボタン直下に「現在 ON」と状態表示されます。
利用制限を解除するにはもう一度「ユーザー制限」ボタンをクリックします。表示は「現在 OFF」に変わります。
本設定はコントローラーを終了する際に状態が記憶され、次回起動時に反映されます。

ご注意
ユーザーの利用制限はコントローラーが起動しているときのみ機能します。
コントローラーが稼動していない状態のときは、クライアントは通常の動作を行います。
コントローラーを起動したとき、稼動中のクライアントで利用制限の対象となるマシンがあった場合、直ちにそのクライアントには利用制限が課せられます。（制限ONの場合）
動作方法に「シャットダウン」を選択している場合は注意してください。
クライアントのOSがWindows95,98,Meの場合、ログオフの制限はご利用いただけません。


通信調整

コマンド送信間隔の調整
クライアントパソコンの状態やネットワーク環境によっては、複数のクライアントパソコンにコマンドを送信してもうまく機能しないことがあります。
このようなときは、コマンドの送信間隔を調整することによって改善されることがあります。

まず、コントローラープログラムが起動している場合は終了させてください。
次にコントローラーがインストールされているフォルダ内にある「SetPM.exe」を起動します。

「コマンド送信間隔」の入力ボックスに設定したい値(ms)を入力し、「登録」ボタンをクリックします。
ネットワークパフォーマンスが原因の場合、設定値として10～200辺りをお試しください。

画像転送方式の選択
拡大画像(等倍画像)の転送が全く行えなかったり頻繁に失敗する場合は、画像の転送方式を変更することによって改善することがあります。

まず、コントローラープログラムが起動している場合は終了させてください。
次にコントローラーがインストールされているフォルダ内にある「SetPM.exe」を起動します。

デフォルトの転送方式は「方式１」となっています。
方式を選択し、「登録」ボタンをクリックしてください。


システムモジュールの更新

インストールするシステムの環境によっては、下記のような障害が発生することがあります。

    ・セットアップ中にエラーメッセージが表示されてインストールできない。（転送プロセスエラーなど）
    ・キャプチャー画像が表示されない。
    ・クライアントの自動追加ができない。
    ・クライアントにコマンドを送っても動作しない。
    ・リストにクライアントが何も表示されない。
    ・動作がどうも不安定である。

インストール時によくあるエラーメッセージとして「転送プロセスエラー」があり、これはコンポーネントをシステムに登録する時に発生します。
また、インストールは成功しても、プログラムの一部あるいは全部の機能が動作しないことがあります。
これはご利用のシステムに、必要とされるシステムモジュールがないか、バージョンが古いために発生します。
上記のような障害が発生した場合は、下記の対策を行うことで解消します。
対策法には３種類あります。適用方法については「ＯＳ環境別対応方法」をご参照ください。

対策１
システムモジュール更新ユーティリティー「SystemModules.exe」をダウンロードして実行してください。
「SystemModules.exe」は自己解凍型のファイルとなっており、実行しますとセットアップ用ファイルが抽出されます。
更新方法は、セットアップファイル中の「最初にお読みください.txt」をご参照ください。
このプログラムは下記ファイルの更新を行います。

    ・「MFC42.DLL」
    ・「MSVCRT.DLL」
     ・「MSVBVM50.DLL」
     ・「MSVBVM60.DLL」

対策２
下記のサイトよりシステムモジュール更新ユーティリティー「speu.exe」をダウンロードして実行してください。
このプログラムはマイクロソフトが提供するユーティリティーで、「SystemModules.exe」では更新されないいくつかのモジュールの更新を行います。

http://download.jp.microsoft.com/windows/mfclib/speu.exe (ファイル)
http://www.asia.microsoft.com/japan/support/kb/articles/j046/3/32.htm (説明)

対策３
インターネットエクスプローラー（ＩＥ）の最新バージョンをインストールしてください。
ＩＥの最新バージョンをインストールすることで、システムはかなり最新の状態に更新されます。

ＯＳ環境別対応方法

Windows NT4.0の場合
１．インストールされている、またはインストール途中のGuardianプログラムは一旦アンインストールしてください。
２．システムを再起動させてください。
３．対策２又は対策３を実行してください。（どちらでも結構です。）
４．システムを再起動させてください。
５．対策1を実行してください。
６．システムを再起動してください。
７．Guardianプログラムをインストールしてください。（コントローラー又はクライアント）
８．システムを再起動してください。

Windows 98の場合
１．インストールされている、またはインストール途中のGuardianプログラムは一旦アンインストールしてください。
２．システムを再起動させてください。
３．対策２又は対策３を実行してください。（どちらでも結構です。）
４．システムを再起動させてください。
５．Guardianプログラムをインストールしてください。（コントローラー又はクライアント）
６．システムを再起動してください。

Windows 98 SE、Windows Meの場合
１．インストールされている、またはインストール途中のGuardianプログラムは一旦アンインストールしてください。
２．システムを再起動させてください。
３．対策２を実行してください。
４．システムを再起動させてください。
５．Guardianプログラムをインストールしてください。（コントローラー又はクライアント）
６．システムを再起動してください。

上記のすべての対策を実施しても不具合が解消されない場合は、お手数ですがサポートまでご連絡ください。


インストールできない

「クライアント環境」、「コントローラー環境」ともインストールできない原因として下記のようなことが考えられます。

原因１　システムモジュールが欠落しているか、バージョンが古い。

対　策　「システムモジュールの更新」をご参照ください。

原因２　インストールするユーザーの権限が無い。

インストールするマシンのOSがWindows NT, Windows 2000, Windows XPの場合、インストールする為にはAdministratorの権限が必要となります。

対　策 必ずAdministratorの権限を持ったユーザー名でログオンしてから、インストールを行ってください。


バージョンアップ

現在インストールされているGuardianのバージョンがV7.5.1以降であればコントローラー、クライアントとも上書きインストールすることができます。
それよりも古いバージョンからは一度アンインストールを行ってから、新規インストールにてバージョンアップを行っていただく必要があります。
（開発元から登録ユーザーに対して無償で提供される、アップデートツールを利用できる場合は、この限りではありません。）

【コントローラー環境】のバージョンアップ
コントローラーを上書きインストールするために「GRInstall.exe」を起動すると、「アプリケーションの追加と削除」のウィンドウが表示されます。
必ず、「修正」を選択してから「次へ」ボタンをクリックしインストールを進めてください。（「変更」では上書インストールされません。）

【クライアント環境】のバージョンアップ
クライアントの上書きインストールでは、「アプリケーションの追加と削除」のウィンドウは表示されません。
また、インストールするフォルダの変更はできません。
起動している他のアプリケーションはすべて終了させてください。
クライアントプログラムが動作している場合は、コントローラーから停止させてください。（「クライアント停止」を利用）
インストールプログラムの「GCInstall.exe」を適当なフォルダに格納してください。（Program Filesフォルダ直下にて実行した場合は、インストールの完了後に「GCInstall.exe」は自動的に削除されますのでご便利です。）
「GCInstall.exe」を起動します。起動はなるべく［スタート］－［ファイル名を指定して実行］から行ってください。
インストール作業はすべて自動で行われ、完了後にシステムは自動的に再起動します。
強制的に再起動しますので、実行には十分にご注意ください。
正規登録ユーザーには、開発者から毎回提供されるオートアップデートプログラム「GCUpdate.exe」を利用してアップデートされることをお勧めします。